10 Replies Latest reply on Oct 6, 2016 2:24 PM by maxhardy

    Black screen after installing driver on RX480

    ciborg

      Hi, I just bought a Sapphire RX480 8 GB and I get no signal input on my monitor while installing the official 16.6.2 Drivers. I waited for about 60 minutes and then restarted.

      Since then I got a black screen on windows login screen (sound still works).

      I uninstalled the drivers in safe mode which at least let me use the card with windows basic adapter.

      I already tried reinstalling and redownloading the drivers with direct and automatic install.

      I'm running Windows 10 Pro with an Intel i5-3570K on a MSI Z77A-G43 mainboard, 8 GB G.Skill RAM and a Thermaltake Berlin 630W.

        • Re: Black screen after installing driver on RX480
          amdmatt

          We'd like to help, please can you provide the following information.

          INFORMATION REQUIRED WHEN POSTING A QUESTION

           

          For example, how is the display connected to the gpu? Are you using any adapters or dongles? Make and model of the display?

           

          In the meantime, you can try using Crimson 16.6.1 or 16.5.3.

            • Re: Black screen after installing driver on RX480
              ciborg

              I have a BenQ G2420HDBL (Digital) connected via HDMI cable and a DVI adapter on the monitor

               

              I will try those versions, thanks for the quick reply

               

              UPDATE:

              Ok so I am not able to install ANY AMD Driver because it doesn't recognize my video card anymore. I tried uninstalling the "Microsoft Basic Display Device" but it just seems to reinstall everytime after just a few seconds. If I try to install an AMD Driver it just installs the audio driver but not the video driver. I tried in both safe and normal mode, I also used a recovery point from windows (the point was before I installed my new card) but that didn't change anything. I cleaned the installs by using the AMD clean uninstall utility and DDU for intel and nvidia drivers which apparently where still installed (I'm guessing only bits of those because I uninstalled them both).

               

              Also I forgot to mention that my onboard Intel 4000 was working fine after the problems I had with the new card, I will test if it's still working now.

                • Re: Black screen after installing driver on RX480
                  amdpete

                  Most likely your motherboard BIOS is set for the onboard Intel graphics to be your primary card not the 480 card.  You would need to set it the other way around or disable the onboard GPU.

                   

                  Use the Display Driver Uninstall (DDU) app to correct the driver install issue.

                  1 of 1 people found this helpful
                    • Re: Black screen after installing driver on RX480
                      ciborg

                      I already looked at my BIOS and saw that the onboard gpu was deactivated as long as the 480 was installed. It's set to PEG so my video card should be prioritized anyway. I had a geforce 770 before the 480 and that worked fine with the same motherboard, the only parts i switched where the video card and the power supply because my last one broke down on me after 3 years (also I think it was responsible for the 770 breaking down because of a busted capacitor on the board of the card).

                       

                      My onboard graphics is working fine so maybe I just got a broken card? I don't think anything else was damaged by the old PSU because it's all working except for the 480. I could try and use my other PCI-e slot maybe the slot took some damage but why should I get a signal on my monitor when using the card without AMD drivers then?

                        • Re: Black screen after installing driver on RX480
                          amdpete

                          Have you got a HDMI or Displayport display (TV or monitor) you can test with instead of DVI? (once you have the display drivers installed that is)

                           

                          I wouldn't have thought the card is broken if it can boot into windows with the Microsoft basic driver.  You could maybe try it at a friends house to see if it works on their machine.

                            • Re: Black screen after installing driver on RX480
                              ciborg

                              I just tried the rx480 in another pc in my house. It didn't work at all the monitor didn't get a signal from the start instead of just at login screen. I also tried a gt640 in my pc and it is getting recognized correctly as gt640 by windows, the correct driver was installed automatically and it works great. So I will go ahead and send the 480 back to the shop I got it from and get a new one.

                               

                              Thanks alot for your help though I really appreciate a support that answers this quickly =)

                               

                              Just as a note I am using the same cable for my onboard graphics so I didn't think it could be that.

                    • Re: Black screen after installing driver on RX480
                      ciborg

                      So sadly I have to re-open this thread...

                      After I sent it back to the shop they tested it and told me they couldn't reproduce the error. I went ahead and did a BIOS update, reset my windows 10 to a clean install and was then able to install the drivers manually via the device-manager.

                       

                      The automatic installer from AMD still wasn't able to detect my card though so I didn't get any services beyond the pure display driver. I did get the performance I was expecting (i.e. about 80-90fps on epic settings in overwatch and about 60-80 in world of warcraft).

                       

                      But a few days ago I got the same black screen issue I had before. It resolved itself after 2 restarts, but it required more and more restarts everytime it happened again. Today it finally broke and after 10 restarts I gave up and re-enabled my onboard graphics.

                       

                      I think the driver is crashing as soon as it starts. I don't know what to do anymore but buy a new card which I can't afford. My last money went into this one.

                       

                      Also I had issues with world of warcraft though I do not know if that relates to the card/driver or if it's an issue with the game. I played in borderless windowed mode and the game window went black suddenly. I had to tab out of the game and back in, only then did it come back. This happened twice in the last 3-4 days (I play daily so it wasn't often). I couldn't find any connection to an action of mine because I wasn't doing anything when it happened.

                        • Re: Black screen after installing driver on RX480
                          ciborg

                          Ok after some search in the forums here I tried turning off pci gen 3....that itself didn't work but the cards fan didn't spin at 100% for a second like it did before. I then also turned off the windows function to let my antivirus program scan the drivers before they started and that seemed to fix it. I did not try to install the "normal" driver package yet but it seems to work now.

                          Any idea why that fixed it?

                           

                          I am using Bitdefender Antivirus Free

                            • Re: Black screen after installing driver on RX480
                              ciborg

                              Only a week later and it doesn't work again.....it seems very random. Somehow it resolved itself after a few minutes of black screen on login but this trial and error rebooting isn't a solution! I also tried installing a newer version of the drivers and had the same issue as always when trying to install it. As soon as the display driver starts installing the screen goes black simultaniously the cards fan spins at maximum for about a second then nothing but black screen. If you can't help me sadly my only option will be to buy a new card (which won't be amd since I never had any problems with nvidia cards).

                          • Re: Black screen after installing driver on RX480
                            maxhardy

                            My laptop intel i5 not switchable + amd radeon hd 7650m  2GB GPU i update Crimson then issue

                            started black screen on windows logon. then i clean the hard-disk ,installed new OS windows 8,8.1,10

                            when i try install any official stock catalyst or crimson ,DDU,amdcleaneruntlity,registry cleaner.

                            while installing display driver issue with black screen crash and some time mouse is showing flickering .....

                            i try many driver version not able install stuck or freezing..after only way hard shutdown

                            then i try uninstall amd display driver on safe mode then it able to login normal with Basic display adapter.

                            now unable to install any amd display driver for GPU it useless...

                            i have no found any solution in forums .

                             

                             

                             

                            finally i find the fix for my laptop  Amd HD 7650M 2GB + i5 intel

                             

                            a.black screen issue when logon and b.installation black screen

                            1st try with hdmi / vga connected second monitor then try to install  or try to turn on laptop still issue persists

                            it a hardware failure gpu dead.try below step it worked for me.

                            1. need "air heat gun" and "heat thermal paste".

                            2. disassemble laptop fully.

                            3.remove heat sink with fan from motherboard clean the fan dust if your have and now able to find chip process and AMD  Gpu in laptop.

                            4.read the chip which one is GPU and take "air heat gun" blow up-to 5 to 10 min then wait to cool 30 min don't touch chip.

                            5.put the thermal paste on both intel proccess + amd gpu chip place the heat sink carefully.and assemble your laptop

                            6. turn on  install any catalyst driver .i have install 15.11 catalyst  (don't install crimson driver it burn your GPU)

                            and enjoy

                            it working fine for me...

                            this very risk i have sony laptop the company is closed . i have no choice to service. i done by myself.

                            it help someone keep try any dead gpu and black screen issue