27 Replies Latest reply on May 24, 2017 4:23 PM by t3hbernardo

    Multiple Problems With RX 480

    johnraiden

      Greetings everyone;

       

      I have just bought an RX 480 and I am having multiple major problems, seemingly without proper solutions so I wanted to make my own thread.

       

      1-) FreeSync does not work properly. When it is turned on, screen flickers with color distortions with some games like Heroes of the Storm and GTA V.

       

      2-)Crimson software (16.6.2) cannot control the GPU fan properly by itself, I had to make manual adjustments too keep the card from going 88+ degrees. Also temperatures are quite high, 40 at idle and as I said goes up and beyond 88 if left unattended. With manual fan profile I can keep it around 76 degrees with 3500 rpm of fan speed, which is quite noisy. Though this matter is about the build quality so there is nothing to fix. (Small heatsink with insufficient thermal conductivity, fan is very good though.)

       

      3-)At some point, my mouse cursor gets corrupted as in the picture. This seems to happen quicker if I alt+tab out of a game a few times. Cursor becomes hardly visible. This also includes in-game cursors with different models.

       

      2qxZj.jpg

       

      4-)If I alt-tab frequently out of an exclusive fullscreen game, at some point I get a black screen and PC restarts.

       

      5-)In Heroes of the Storm, there are lots of rendering errors, tile textures are not even rendered, floor is all black. Almost all particle effects are coming on top of the models. For example Tyrael's wings are visible as if Tyrael is transparent.

       

      6-)When I shut down my PC I sometimes get a memory error regarding radeon drivers with a memory address, could not screenshot/note it though..

       

      All of these problems started to occur when I switched from a GTX 570, so I am positive they are GPU/driver based. All previous NVIDIA drivers were uninstalled through driver uninstaller tool in safe mode.

       

      Here are my PC specs:

       

      CPU: Intel i7-2600K @ 4.2GHz (Has been overclocked for years, no problems whatsoever)

      RAM:GSkill RipjawsX DDR3 1600Mhz 4x2GB CL9 1.5V

      Motherboard: Asus Sabertooth P67

      GPU:AMD Sapphire RX-480

      OS: Windows 10 x64

      Monitor: ASUS MG278Q 144Hz 1440p connected through DP

      PSU: 1000W (Don't remember the brand, could me Thermaltake)

       

      Thank you.

       

      UPDATE 1: I have re-installed the drivers just in case. Now flickering happens without freesync enabled and every time, including desktop...

        • Re: Multiple Problems With RX 480
          anastasopoulosnikolaos@yahoo.gr

          did you try to install a fresh edition of crimson 16.2.2? Check again perhaps thia you instal before ita not for this card actually.do not install drivers for the cards box

          • Re: Multiple Problems With RX 480
            jimmyd1964

            It seems that ARLT will build what ever you want , lots of conversation on German sites in reference to it. But 9 years old, I would get a new Gold rated PSU (at least), Maybe Corsair or Seasonic. Or some other good brand name. Look at warranties and reviews.

            Good luck

            • Re: Multiple Problems With RX 480
              dodo5

              Hallo,

               

              i have installed my RX 480 (4GB) today and have similar Problems. When running Games the screen starts flickering with color distortions after ~10 minutes, even when tabbing out to the desktop. The GPU heats up quite a bit while gaming, but the temperature keeps well below critical. The flickering remains until the GPU has cooled down again. I also use a Freesync Display.

               

              Also the mouse cursor becomes corrupted during gaming:

               

              Cursor.jpg

              Running the magnifier tool solves the cursor problem for me. However, after closing the magnifier the cursor is bugged again.

               

              Radeon SW Version: 16.6.2

              OS:  Microsoft Windows 7 Ultimate 6.01.7601 (Service Pack 1) x64

               

              PC specs:ASUS Sabertooth 990FX Rev 1

              AMD FX 8150

              4x 4 GB Corsair  DDR3-1600 Ram

              Radeon RX 480 4GB

               

              Display:

              AOC G2460PF 1920x1080 @ 144 Hz Freesync

               

              PSU:

              800W Corsair GS800

              • Re: Multiple Problems With RX 480
                sputnik1969

                Same problem with the mouse cursor - but its only corrupted on main display, the 2 additional display on left and right side aren't affected !
                I used a HD 7950 boost until i bought RX480 and i never had this problem in the past

                • Re: Multiple Problems With RX 480
                  johnraiden

                  Greetings everyone!

                   

                  Today I used "return to factory settings" option in the crimson software (although I only modified saturation and made a fan profile..)

                   

                  Until now I had no problems of sorts I listed. And yes I again modified saturation and made a fan profile, oddly no longer having problems. It has just been a few hours though, so I will keep you updated. I would appreciate it if you did the same!

                  • Re: Multiple Problems With RX 480
                    godya

                    I have almost the same problems with my new Sapphire RX 480... It sucks!

                     

                    - Random mouse cursor corruption (Crimson 16.7.1 - 16.9.1)
                    - Random static black screens (Crimson 16.7.3 - 16.8.2)
                    - Random BSOD's / VIDEO-SCHEDULER_INTERNAL_ERROR (Crimson 16.7.1)
                    - Freesync flickering (Crimson 16.7.1 - 16.9.2)
                    - Boot-Crash (Crimson 16.8.2)

                    - h.264 Video Codec Black Screen Flickering (16.7.3 - 16.9.2)

                     

                    Hurray! Crimson 16.9.2 has fixed my mouse cursor corruption bug... only the Freesync bug und Video playback bug remains... hope a solution will come soon...

                     

                     

                    Hardware:
                    ========


                    System: Brand new Lenovo ThinkStation P700
                    UEFI-BIOS: A5KT89AUS (latest Version!)
                    PSU: 650 Watt / 1x 6-Pin AUX (80 Plus Platinum)
                    CPU: 2x OctalCore Intel Xeon E5-2630 V3 / 2.4 GHz Base-Clock / 3.2 GHz Turbo-Clock / 85 Watt TDP
                    GPU: AMD - Sapphire RX 480 / 8 GB VRAM
                    Chipset: Intel C612
                    RAM: 8x 8 GB Crucial ECC RDIMM (Micron 18ASF1G72PZ-2G1A2)
                    Storage: 1x 512 GB Samsung 850 EVO / 1x 512 GB Samsung 840 / 1x 2 TB SSHD Seagate ST2000DX001
                    Display: Acer Predator XG270HU (Freesync: 40 Hz - 144 Hz)
                    OS: Windows 10 Pro 64-Bit (Build 1607)

                     

                    Note: The Acer XG270HU Display works fine on my old System* with Freesync enabled! No BSOD, No Black-Screen, No Mouse-Cursor-Corruption.
                    Old System: Intel i7 920 / Radeon R9 285 / Crimson 15.12 / Windows 10 Pro 64-Bit Build 1607

                    • Re: Multiple Problems With RX 480
                      cphyt7

                      Hi all, I had the cursor bug with my new RX 480 as well. Looked similar to OP.

                       

                      I found that turning off Mouse Cursor Shadow has fixed the problem for me.

                      On Windows 10: Control Panel - Mouse - Pointers - Uncheck Enable Point Shadow (lower left hand corner)

                      Settings on my RX 480 are stock. Running 2 DP monitors with 144hz Freesync.

                      I had the cursor bug multiple times per day since installing the card. I made this change 3 days ago and it has not returned.

                      Good luck!

                      • Re: Multiple Problems With RX 480
                        polyamid

                        Ah, very interesting to read from people having the same problems. Only for your information:

                         

                         

                        I have MSI radeon RX480 8GB  on same ASUS Freesync monitor and I spended hours now to explore the problems with this card.

                        Over all I´m very satisfied with the card and I´m very sad, that AMD every time they fix one driver error, they open another.

                        So my Story:

                         

                         

                        I got the RX480 and was very suprised about the high temps and the noisy fan. So I decided to change the cooler into a Arctic Accelero Mono Plus. Now the card is quiet like a charm. nearly the same time I patched crimson drivers to 16.7.3 and the problem with random black screens in idle or wile browsing started.

                        At first I thought my modification was the fault. Was thinking I crashed my RX480 with that. Only the fact, that the card is stable in stress tests and the temps are uncritical, leads me to trust in my modification. So I looked for an error with other components or UEFI Settings.

                        Later after hours of checks of SSDs, cables, rams and changing a lot of drivers, I read here that crimson versions since 16.7.3 cause black screens.

                         

                         

                        Crimson 16.6 : many wattman crashes, the mouse pointer bug similar to yours, freesync flickering with my ASUS Monitor (same model) and sync problems.

                        Crimson 16.7.1+16.7.2: works better no crashes. Crashes with wattman not so often.

                        Crimson 16.7.3 - 16.8.2: Problems with random Black screens wile surfing or in idle. stable while gaming. Sometimes purple or white screen instead of black one. Computer is up in background but you can only power it down by Switch.

                         

                         

                        So I recommend the Crimson 16.7.2 because it has nice functionality with Doom, lesser Freesync and pointer problems and seems to have no black screen issue (have to test a little bit further).

                         

                         

                        I heard rumors, that black screens have something to do with manual fan setting. Someone who can say something about that? Wasn´t able to test it but without modified fan am not able to bring my modded fan on normal speed(It has only 1500rpm).

                        • Re: Multiple Problems With RX 480
                          phat

                          I am having the same issue with the mouse pointer

                           

                          20160830_213749.jpg

                           

                          Microsoft Windows 10 (10.0) Professional 64-bit   (Build 14393)

                          Intel Core i7 3770K

                          Radeon (TM) RX 480 Graphics

                           

                           

                          Acer XF270HU 2560 x 1440 @ 144 Hz

                           

                          i checked that the pointer shadow was never on. turned on and off just in case. same thing.

                           

                          any other ideas?

                          • Re: Multiple Problems With RX 480
                            seikusa

                            Powercolor Support told me AMD is aware of the cursor problem and working on a driver update. They asked me to be paitent.

                            The support guy said he would email me as soon as a fix has been made by AMD.

                              • Re: Multiple Problems With RX 480
                                bronzeknee

                                It has been a problem with Radeon drivers for over 10 years.  Search google for it...

                                 

                                Something tells me they are stringing you guys along.  If you can't use one of the workarounds then you should RMA the card while  you still have a chance because it won't be fixed.

                              • Re: Multiple Problems With RX 480
                                etayorius

                                XFX RX 480 having exactly the same issue with the mouse getting corrupted, using 16.8.3 on Win7 x64 with an i5 6500 and 8GB of DDR4.

                                 

                                I am also having an issue where forcing vsync through Crimson profiles get's completely ignored, some games like Skyrim, Fallout3, FalloutNV and Fallout4, GTA4 and Oblivion will just completely ignore any setting in the profile. And wattman just keeps crashing like crazy 6 out of 10 times.

                                • Re: Multiple Problems With RX 480
                                  tailored_construct

                                  mention this In another thread/post with the same issue but will repeat here as I was also having the same problem until I did the possible fix bellow which appears to be stable for me for a couple of days now:

                                   

                                  You could try the following which appears to have worked for me, but be aware it involves changing(increasing) the voltage to your GDDR5 memory on the graphics card so may invalidate your warranty and should be done at your own risk.  that being said AMD have taken the sensible precaution to prevent silly settings that could do any serious damage.

                                   

                                   

                                  In Global Wattman (within Radeon Settings) go to 'the Memory Voltage Control (mV)' setting select the toggle to switch from 'Auto' to 'Manual' and try changing 'ONLY' the 'Voltage Control (mV)' from '1000' to '1050'. this is a small increase.  the maximum is 1150 but that is unnecessary in this instance as we are just aiming for stability. the control panel sensibly does not allow settings that will do harm.

                                   

                                   

                                  would be interested in knowing if this resolves the issue for you and anyone else for that matter.  I have not experienced the mouse cursor corruption for a couple of days now regardless of enabling/disabling Power Efficiency and Compatibility Mode.

                                   

                                  Good Luck.

                                   

                                  AMD Radeon RX 480 8GB  - GDDR5_1050mV_mouse_cursor_fix.jpg

                                  • Re: Multiple Problems With RX 480
                                    onewholived

                                    I got my Sapphire RX 480 Nitro lately and I have many issues too.

                                    I'm using 144Hz screen which causes green/purple flickering on desktop. It works fine on 120Hz though.

                                    In games 144Hz works fine since clocks are high there.

                                     

                                    I also have that mouse cursor issue.

                                     

                                    Sometimes my GPU load gets stuck to 100% without spesific reason, reboot fixes this.

                                     

                                    I feel that fan profile doesn't work properly. Sometimes the fan speed gets really high for short time and then back down.

                                     

                                    Can't say I would be satisfied this point. But I guess these all are fixable issues.

                                     

                                    Edit: And also my Windows 10 doesn't detect my BenQ XL2411Z monitor like before. Now it is just seen as Generic PnP monitor.

                                     

                                    PC:

                                     

                                    AMD FX-8320

                                    Asus Sabertooth 990FX

                                    Sapphire RX 480 Nitro 4GB

                                    Corsair AX850W

                                    Windows 10 64-bit

                                      • Re: Multiple Problems With RX 480
                                        killerloop

                                        Same problems with the mouse cursor as mentioned above.

                                         

                                        PC specs (new system):

                                        Gigabyte Z170X Gaming G7

                                        Intel Core i7 6700K

                                        2x 16GB G.Skill DIMM DDR4-2133 Kit

                                        Sapp8GB D5 RX 480 NITRO+ with Radeon Software 16.8.3

                                         

                                        PSU:

                                        be quiet! Pure Power 9 600W

                                         

                                        Display:

                                        3x Samsung U32E850R 3840x2160 @ 60 Hz 2xHDMI, 1x DisplayPort

                                         

                                        It only happens on the primary screen, on the other screens the mouse cursor is ok. Is this a hardware or software problem? Thinking about returning the card.

                                      • Re: Multiple Problems With RX 480
                                        etayorius

                                        It seems AMD finally made and official acknowledge of the mouse corruption issue, check 16-9-1 Release Notes:

                                         

                                        Radeon Software Crimson Edition 16.9.1 Release Notes

                                         

                                        Known Issues

                                          • Mouse cursor corruption may be experienced very intermittently on the Radeon RX 480.
                                        • Re: Multiple Problems With RX 480
                                          etayorius

                                          Mouse corruption on RX480 is back with Relive Drivers... GEEESH!!!

                                           

                                          Win7 x64 i5 6500 8GB DDR4 2133mhz Asus H110M-A

                                          • Re: Multiple Problems With RX 480
                                            ejec1190

                                            I have the problem that I blink the screen in black after playing for a while.

                                            When I install the (Asus ai suite) Windows 10 start not to update the windows automatically, no sale even looked white

                                            Then enter the BIOS and set the two GPUs, the Intel and the AMD Rx 480 enabled. Install Intel drivers and fixed the problem.

                                            All the test done in the vga give correct performance. The problem is very rare.

                                             

                                             

                                            PC

                                            Intel i74790k

                                            AMD RX480 Crimson ReLive Edition 16.12.2 Optional

                                            RAM 16 Corsair

                                            Fuerte coolermasrer 800w 80plus gold

                                            maximus vii ranger

                                            • Re: Multiple Problems With RX 480
                                              t3hbernardo

                                              I'm getting insane stutter in general, especially when running Elite in a borderless window with three screens and moving the cursor from one screen to another, also while win+tabbing. Sometimes getting the win+tab animation to even start takes longer than a second. This is sometimes accompanied by all headphone audio stuttering (but not speaker, they're both connected to mobo realtek hd audio)

                                               

                                              6700K 4.5GHz, Z170 Maximus Hero, 24Gb kingston ram (latencies tightened and memtest86 stable), Samsung 960 Evo M.2 system drive