1 Reply Latest reply on May 23, 2016 6:29 AM by amdmatt

    XFX R9 380 driver issue

    tborg

      Hi Guys,

      I'm new to this forum so thanks in advance for any assistance.

       

      We recently got Dell Precision 5810 Workstations which came pre configured with Windows 7 SP1. These workstations are packing 16GB of RAM and a Xeon E5-1630 with an 825W PSU. We then proceeded with installing an XFX R9 380 Double dissipation VGA. The purpose of these workstations will be mainly 3D rendering.

       

      The problem i have is that whenever we install the driver, being either from the installation DVD which came with the Video card, AMD's auto-detect tool, and manually downloading the latest driver ( Display Driver version 16.15.2211 + Crimson edition software), only the minimal driver set is being installed. Not even the CCC is installed. In fact when I run the driver setup from the installation DVD which came with the VGA and run the custom setup, only the HDMI audio and install manager are available for install. Furthermore the PC is not recognizing the video card since from the device manager and under display adapters " Standard graphics adapter" is shown. Tried reseating the VGA and made sure that the  2,  6 pin power supply connectors are correctly inserted but still to no avail..

       

      Furthermore we have another identical workstation installed with an identical video card however this time around the VGA is recognized by the system but the Catalyst control centre is still nowhere to be found and trust me I checked everywhere.

       

      Also its good to point out that when I installed the driver on the first workstation, the driver installed itself fine and VGA was being recognized however the CCC was missing. I read in forums that removing and re-installing driver resolves this problem so that is what I did however now I have the problem I explained in the second paragraph.

       

      I am open to suggestions as my back is against the wall here. I also opened support tickets with XFX and DELL to try and determine the origin of the problem and am still awaiting a reply. Thought I'd give this forum a go next

       

      Thanks in advance.

       

      Regards,

      Tim