16 Replies Latest reply on Sep 18, 2016 6:12 PM by kyrillik

    THREAD_STUCK_IN_DEVICE_DRIVER THREAD_STUCK_IN_DEVICE_DRIVER THREAD_STUCK_IN_DEVICE_DRIVER THREAD_STUCK_IN_DEVICE_DRIVER

    boo025

      Hi,

       

      I've been having this issue since Crimson 16.1 came out and ever since then I've been waiting and waiting, hoping for a fix. However, it never came.

       

      My issue is pretty simple: when you try to install Crimson, the system freezes and then BSOD with THREAD_STUCK_IN_DEVICE_DRIVER.

       

      My system at the moment is as follows:

      • i5-6600K @ Stock
      • Asus Z170-A
      • 16GB DDR4
      • 2x Sapphire Tri-X 290X (Crossfired)
      • Asus MG279Q (DisplayPort)

       

      I tried every methods that I could dig from this forum and other forums:

      • DDU + AMD Uninstallation Tool
      • Cut Internet when installing the driver
      • Reformat Windows 10
      • Tried in different system (i7-4790K, Asus Z97-A)
      • Disable Integrated Graphic
      • Enable Integrated Graphic, unplug all monitors from discrete GPU, install driver
      • Disable FreeSync from monitor
      • Disable CrossFire
      • Use HDMI instead of DisplayPort
      • Update BIOS
      • Don't install Raptr or AMD Gaming Tools
      • (I'm sure I forgot to list some other things I tried)
      • All combination of above

       

      Only thing that I haven't tried is installing driver with just single GPU, but I cannot do that because of my custom built watercooling. Another method I didn't try is using different monitor.

       

      I have bunch of dump as well, and submitted bug reports (which never got addressed).

       

      I'm currently stuck at Crimson 15.12. Anything higher causes my system to freeze and die in horrible death.

       

      Personally I'm kind of getting sick and tired of troubleshooting so this is a desparate plea for help. If any AMD rep is reading this, I'm seriously willing to take my PC to 1 Commerce Valley Drive so I can help you guys debug this issue (hell, I used to work there.)

       

      Thanks,