3 Replies Latest reply on Apr 10, 2016 8:38 PM by luan.cestari

    Latest Linux AMD Radeon Driver links are missing

    luan.cestari

      Hi,

       

      I tried to find the links for R9 390 driver but all the linux drivers for the latest version of driver are broken,for example this one http://www2.ati.com/drivers/linux/fglrx64_p_i_c-15.302-1.x86_64_rhel7_64a.rpm which wit redirect to a page called 'incomplete' . Could someone fix this please?

       

      Also, I tried the driver that I found on http://www.techspot.com/downloads/drivers/essentials/amd-radeon-crimson-linux/ and I got problems during the compilation o the kernel module, I saw the code that had the problem (which I had to uninstall the driver as the GUI stopped to work, the uninstall process was not very friendly or well documented). The code have some preprocessor macros for newer kernels (such as the one that I'm using ) and it tries to use the seq_printf function which doesn't return nothing (void) but it tries to get the return to see the length (the variable was called 'len') . Is it fixed or is this issue addressed to next release ? I can recompile/install that again to get more details if you guys need.

       

      I also saw that it seems some issues with the current Xorg project ( https://bluehatrecord.wordpress.com/2016/01/10/installing-the-proprietary-amd-crimson-driver-on-fedora-23-with-linux-kernel-4-2-8/ ) , is there any way we could fix that as well?

       

      Kind regards,

      Luan