5 Replies Latest reply on Jan 29, 2016 9:41 AM by Septor

    GPU scaling cannot be turned off

    midix

      I want to use smaller resolutions on my monitor for various reasons (older games, vision problems) but GPU scaling mode has some artifacts on Windows 10 (this will be another topic), therefore I want to use my monitor's built-in scaling. I know that 1024x768 resolution is supported by my monitor because I see this resolution in the OSD Information box while Windows is booting and I see it also in safe mode and when AMD drivers are not installed.

       

      Here is my video demonstrating the issue:

      AMD GPU scaling got stuck - YouTube

       

      As you can see, the monitor always shows that the actual resolution is its full native resolution 1920x1080 and AMD scaling controls still work despite the fact that GPU scaling is disabled. I tried toggling it On/Off - did not help. I tried completely uninstall drivers - did not help.

       

      AMD, please fix the bug! If I disable GPU scaling, I expect the scaling controls to become disabled and my monitor to show that the resolution indeed is 1024x768@60Hz.

       

       

      My system specs:

       

      GPU: ASUS HD7750-1GD5

      Monitor: ViewSonic VP2365WB, connected through DVI port.

      Video drivers: Crimson 15.12 (but I had the same issues with earlier Catalyst too)

       

      Motherboard: Gigabyte GA-H67A-USB3-B3 with the latest BIOS available

      CPU: i3-2120

      RAM: Kingston 4x2 = 8GB

      OS: Windows 10 Pro 64 bit with November update

      PSU: Gigabyte Superb 550P

        • Re: GPU scaling cannot be turned off
          qwixt

          Try creating a custom resolution for that resolution from the "Display->Additional Settings" popup.

            • Re: GPU scaling cannot be turned off
              midix

              Thanks for the suggestion. Already tried that - the screen flickers once, the resolution seems to get accepted, but still it is applied through GPU scaling because the monitor OSD says 1920x1080.

               

              I tried the same with integrated Inteld HD 2000 and it works correctly - if I pick any resolution which is supported by my monitor, then the scaling list shows additional option "Maintain display scaling" and if I pick that, then monitor OSD shows that it is indeed using the selected resolution 1024x768@60Hz.

               

              I remember that on Windows 7 also AMD Catalyst GPU scaling worked fine (I mean - it could be turned off), but now they have broken something on Win 10 with their new Crimson Settings app.

            • Re: GPU scaling cannot be turned off
              midix

              After lots of debugging and reinstalling multiple driver versions from 13.9 to 15.12 multiple times I found the fix and I found the driver version which started having issues with GPU scaling.

               

              My GPU scaling tests were considered passed if GPU scaling controls and resolution settings provide the same consistent and predictable behavior as they did in earlier Catalyst versions and work the same way as similar settings in Intel GPU drivers. That means:

               

              - 1) if configured Desktop resolution is lower (e.g. 1024x768) than native recommended resolution (e.g. 1920x1080) of the monitor AND "Enable GPU Scaling" is checked, then monitor OSD reports that it is at its native recommended resolution AND all scaling radio buttons are enabled and work as expected

              - 2) if configured Desktop resolution is lower than native recommended resolution of the monitor AND "Enable GPU Scaling" is not checked, then monitor OSD reports that it is at the specified resolution AND all scaling radio buttons are disabled

               

              I found out that drivers version amd-catalyst-14.4-64bit-win8.1-win8-win7-whql-aug.exe (Catalyst 14.4, driver package 14.10.1006-140417a-171099C) passed both these tests. Starting with amd-catalyst-14-9-win7-win8.1-64bit-dd-ccc-whql.exe  (Catalyst 14.9, driver package 14.301.1001-140915a-176154C) something got broken and test 2) failed - radio buttons remained enabled when they should not be enabled, and thus I could create some weird combination of GPU scaling disabled but the desktop image being centered and scaled both by GPU and my monitor.

               

              Here's the proof:

              http://i.imgur.com/vysrB8i.png

              (please open in new tab, for some reason this message board fails to embed imgur images)

               

              This is confusing - radio buttons should be disabled if scaling is unchecked. It worked that way in Catalyst prior to 14.9.

               

              But that was just a minor issue. The culprit of my troubles was that AMD Uninstall utility amdcleanuputility.exe which I used after each test and before installing new version of AMD drivers, did not delete everything it should!

               

              Sometimes when upgrading to the next driver version I noticed that after installing AMD drivers "Enable GPU Scaling" could not be unchecked - it always reverted back to checked after clicking Apply, and OSD monitor reported that actual resolution is never GPU scaled. For Crimson Settings, "GPU scaling" behaved the other way round - it always was Off and I could not make it On - I clicked, it said On, but when I moved my mouse away, it became Off again, but my monitor showed that Crimson Settings is lying - the scaling is being applied.

               

              By doing some Internet searches I found out that the "Enable GPU Scaling" checkbox issue got fixed if I manually set GPUScalingXX (XX may vary, my was GPUScaling06) value in Windows registry to 00. After this fix, synchronisation between this reg key and Catalyst was correct again - I could see the registry value changing between 0/1 according to the GPU scaling checkbox. For some driver versions this was enough. For Crimson, it did not fix the issue. The On/Off setting started behaving correctly, but OSD menu on my monitor still told that Crimson is lying.

               

              At one point by some lucky guess (and also some despair and anger) I manually deleted the entire registry key for the display driver and verified that Device Manager shows the display driver as "Microsoft Basic Display Adapter".

              In my case I had to delete [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0001].

              If someone want's to follow this idea, please use the correct key which can be found in Catalyst (or Crimson) software information - it might differ from my registry keys.

              WARNING: deleting this key makes Windows to forget your graphics card on next boot and it will install "Microsoft Basic Display Adapter". Generally, this is what I wanted to achieve, but there is always a risk to seriously break something when using regedit.

               

               

              Then I reinstalled the latest AMD drivers again. Voila! Now it works!

               

              After that I ran amdcleanuputility.exe again and opened regedit - indeed, amdcleanuputility does not delete many entries under 0001 key. I ran all my tests again with multiple AMD driver versions, and I became more and more convinced - if I do not delete 0001 key, there are some issues with GPU scaling.

               

              But that's not all - after changing resolution and "Enable GPU Scaling"  multiple times, it gets stuck again - sometimes I can not get into scaling mode, and sometimes I cannot get out of it, although the checkbox shows that I should have the right mode. Only resetting to default native res and deleting GPUScaling06 value seemed to help for a while.

               

              So, the morale of the story - don't trust amdcleanuputility when upgrading AMD drivers - delete entire registry key for you graphics card and reboot before installing new drivers.

               

              I think that amdcleanuputility should be capable to deal with this situation and it should delete all the registry keys created by AMD drivers. Or even better - new driver packages should call uninstallers of the old package which in turn should delete all its stuff.

               

              I noticed that amdcleanuputility did not uninstall even Radeon Settings app - after reboot, I saw cnext.exe running and I had to stop it manually and delete AMD folder.

               

              I hope that AMD will listen and fix its uninistallers and/or cleanup utilities and undo the GPU scaling changes they broke after 14.4.

              1 of 1 people found this helpful
              • Re: GPU scaling cannot be turned off
                Septor

                This is likely because of the changes in Win10 and Aero.

                Now when you change resolution in Win10 DWM (Aero desktop) will use shaders and scale the desktop.

                But, there is a way around this!

                 

                If you go to:

                     Display Settings -> Advanced Display Settings -> Display Adapter Properties -> List All Modes

                then you will get a list of all resolution and refresh rates you can set.  Select the one you want, for example 1024x768 60Hz 32bpp and click apply.

                You should get a full mode change and have native 1024x768 mode as you like.

                 

                Hope that works for you... blame Microsoft/Win10.