4 Replies Latest reply on Jun 1, 2015 4:24 PM by kingfish

    problem with driver

    jwest

      Hello,

       

           After downloading 14.12 driver via your Autodetect program, it is starting to install and during instalation I get my notebook's monitor off. It's like lights in display are off and even after reboot it is still switched off. Only in safe mode works and making a backup to 12.xx version of driver helps.

           Can you help me to fix this problem?

        • Re: problem with driver
          dominik523

          14.12 or omega driver didnt want to work for me either. I have sapphire hd 6850 and after the windows login screen I get strange lines. When the desktop goes up, I just get black screen and I cant do anything.

          • Re: problem with driver
            kingfish

            What is your laptop manufacturer and exact model number? Do you have switchable graphics?

              • Re: problem with driver
                jwest

                Asus X54H, Intel Core 2 Duo, ATI Radeon 6470M. It's not about switchable graphics. It's about Radeon's best in the world drivers. I got a solution of this issue by editing registry. But it would be better for all, if Radeon's drivers will work properly by default without any changes from user's side.

                  • Re: problem with driver
                    kingfish

                    It's a shame we lost all our posts when AMD moved to this forum format...but your older Asus, like mine ( Asus N61jq ) and everyone else's, will not accept any driver (except the old, old Asus support drivers) without forcing a black screen. This is a Asus issue and has been known for years. It works fine with the newest drivers when using a external monitor . It just blacks out the laptop screen. AMD has nothing to do with it. If you went to the Asus laptop forums, you would find hundreds of post. I do not know if it has been corrected with the newer laptops. It doesn't bother me as mine is hooked up to a monitor and never leaves the house...the grandkids play their games on it. The last good driver that did not cause this was the 13.4. If you have Windows 7 64 bit these work >Download AMD Catalyst 13.4 Software Suite Vista/7 64-bit | techPowerUp

                     

                     

                    EDIT: Found a old forum post > The specified item was not found.