3 Replies Latest reply on Mar 9, 2012 2:56 PM by mikism

    Windows Server 2008 R2 x64

    pcmaster

      Can anyone confirm that ATI OpenCL SDK and all other needed stuff (like the newest GPU drivers) work on Windows Server 2008 R2 x64?

      Big thanks!

        • Windows Server 2008 R2 x64
          omkaranathan

          pcmaster,

          Windows Server 2008 is not an officially supported OS and we haven't tested it out yet. But I think you should be able to run OpenCL as it is similar to Windows Vista. Could you try running OpenCL and post the outcome? It will benefit other users with the same config too. 

            • Re: Windows Server 2008 R2 x64
              ckumsta

              hello,

                I'm actually trying to install "12-2_pre_certified_vista_win7_64_dd_ccc" driver on my system :

              - HP DL370G6

              - Windows 2008R2 x64

              - FirePro V8800

               

              Driver looks like installed (screen resolution ok, in device manager I get Driver Provider "Advanced Micro Device Inc." and driver version 8.950.0.0).

              But I don't have access to OpenCL (neither my application, nor GPU-Z).

               

              I tried to install "AMD-APP-SDK-v2.6-Windows-64", in case of missing dll, but this does nothing (it says it installs, but does nothing in reality).

               

              Christophe.

            • Re: Windows Server 2008 R2 x64
              mikism

              Hey,

              I do have 2008R2 x64 currently installed on my machine (had almost since the release) and I can confirm that drivers and OpenCL runtime do work although this OS is not officially supported by AMD.

              Up until version 12.0, my driver update process was like this:

              1. Uninstall all drivers via Device Manager, all Catalyst Control Center applications.
              2. Wipe out what's left of it using DriverCleaner, clean registry with CCleaner
              3. Then manually install drivers and all needed Catalyst Control Center components.

              The reason I had to go through all of this is that Catalyst Control Center Installer is the one (and seems like the only) thing that does not want to support 2008R2: it just won't find my hardware and won't install anything. But manual thing worked.

              Now this changed with CCC 12.1. I had to reinstall my OS because CCC did not recognize the hardware (or maybe my registries were messed up because of all those manual driver upgrades). But after the clean install I was able to use the CCC Installer. However, it did not install OpenCL runtime so I had to do it manually. And this was also true for HydraVision and AMD Media Codec Package. Fortunately now everything works fine: CCC, OpenCL, DirectCompute, DirectX, HydraVision and Crossfire (I do have a couple of HD6850s).

              So all the problems I had so far were only CCC related. If you only require the drivers and OpenCL you can install them manually and everything will work.

              As for the 12.2 version, I've downloaded it already but did not try installing it. Once I do it, I'll let you know if I had any success (or failures for that matter).

               

              Mike