cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

Ryzen Master / 5800X - No Cores or Clock Speed

I had just purchased and installed a 5800x in my system. I had previously been running a 3900XT and didn't have these issues.

In Ryzen Master, I cannot apply any settings because it tells me:

"Invalid count for core disabled. Number of active cores should be more than 1. Select valid values and apply again"

rm3.png

I then noticed, it indeed shows no cores (0/0) under About:

rm.png

And, under "Core Section" there is no longer anything listed:

rm2.png

And Finally, the "Peak Speed" remains at 0MHz at all times:

rm4.png

At first, I thought maybe it was something funky going on because I changed chips without changing software or anything. I tried uninstalling Ryzen Master, downloading it again from AMD and reinstalling. No Change. I then downloaded the chipset drivers again and reinstalled. No Change. I updated my BIOS to the newest offering from ASUS, reset my CMOS and again, no change. I then thought maybe it's due to Windows being installed with my old CPU, so I wiped my hard drive and reinstalled Windows, AMD Chipset Drivers and Ryzen Master again. Still no change.

 

Also, maybe completely unrelated, I use Argus Monitor to set my fan speeds and monitor my system parameters, however after installing the 5800x, my core temperature stays at 0.0*C:

am.png

And under the "Overview" section, it shows core 1 at 0*C, but shows temperature for all other cores:

am1.png

I had installed the newest version, which indicates it supports the 5800x, both initially and after reinstalling Windows.

 

Are all these issues a chip issue, did I get a defective chip? Is this a driver or software issue? Anyone else experiencing this, find any solutions or work arounds, or am I just stuck waiting for updates from AMD?

Thanks!

0 Likes
1 Solution

New version of Ryzen Master released in the past few days works fine. But I believe you need the latest bios as well. 

View solution in original post

15 Replies

Sounds to me like a detection issue, likely due to BIOS. Does Task Manager show all the cores (below), and can you run a program on all 16 logical cores? If so, report it to ASUS.

 

 

image.png

 

0 Likes

Yes, showing 16 logical cores in task manager:

I was running 3001 BIOS, released beginning of December and updated to the newest (beta, version 3202) with no change.

 

ASUS Prime x570-Pro motherboard, btw. Forgot that in the first post.

0 Likes
Then don't worry about it. The Ryzen 5000 series still has bugs to be worked out by both AMD and the AIBs.
0 Likes

I just bought a new car, but I can only push the gas pedal half way down. It's ok though, they'll fix it with software at some point.

I got a new front door installed, but it only opens 3/4 of the way. It's okay though, it's still a new edition, they'll fix it at some point.

I got a new faucet installed, but they water only comes out at half speed, just a trickle. It's okay though, it's new so I could only expect it to work partially until they refine it further.

 

Come on... We buy things and expect them to be working. Why is it so commonly accepted for everything to still be in "Beta" at release. Especially these big corporations, they spend million upon millions in R&D, you think they'd do the same with QC. Also, with more digging online, I found posts going back to late November, people having the same issue. Almost 2 months and AMD hasn't put out a working update for Ryzen Master for all their new chips?

Was looking for some sort of head count, as to who is having this issue as well and what is the root cause... I guess I'm the only one who can't use Ryzen Master on my new $500 chip. **bleep**, guess I was a sucker to buy a 5800x before it was ready for the general public, 2 months after RELEASE that is.

 

0 Likes
You buy a new game, but you can only progress so far until a game breaking bug prevents your progress, or worse, corrupts your save file.

You buy a new graphics card, but face persistent issues for perhaps months until reputable tech sites call them out on them to fix them.

You buy a new cell phone, and may face a multitude of issues until the manufacturer decides to fix them, if they ever do.

You buy a new CPU, but the BIOS files pump the voltage up to and in excess of 1.5v, potentially causing damage to the chip, but also causing excessive heat production which limits its performance.

With all technology there will be bugs which will take time to fix, especially if a bug is limited to a specific hardware and software combination to trigger. So just have patience for the people who know -a lot- more about said hardware and software than you do to work them out, just submit a bug report to AMD and ASUS.
0 Likes

Ah, seems it's coming to light what's going on here:

Igor's Lab - 5600x and 5800x Spotted with 2 CCD's 

 

Seems chances are I have a 5800x that didn't make the cut to be a 5950x and was sold as a 5800x with 1 CCD disabled.

Cool. Now for AMD to push out an update for Ryzen Master, I suppose.

0 Likes

Having the same problem on Asus prime x570 pro with r7 5800x, any solution yet?

0 Likes

Not that I've found. I did see there is a new Beta BIOS out today, haven't tried it yet.

Apparently we got 5950x's with one chiplet disabled. Have to wait for AMD to come out with an update for Ryzen Master to address it.

Argus Monitor had an update on their website after I emailed them, that issue is resolved in their latest version.

0 Likes

Thank you for finding that that link. I guess I have also gotten the failed 5950x. I have the exact same issue with Ryzen Master on the 5800x, and with the most up to date everything on a brand new build.  It is quite annoying, since we can't use any of the modes on the software. It really is incredible that the chip makers own program cant read something as basic as processor speed, and that it would be stuck trying to read the obviously deactivated sections instead.

0 Likes

Same problem here with Ryzen 7 5800X and Asus TUF X570 Plus. Bios 3402 Beta instaled and still no working. Lisa Sue please help us.

0 Likes

Same here on 5600X

0 Likes
mrsense
Adept II

It seems you tried everything you can. Does the system run stable?

Since you also tried the fresh installation of Windows 10, I think you can safely narrow the issue down to either the bios or cpu.

The next step is either try another motherboard (another brand) or another 5800X.  Can you return the cpu and get a replacement?

 

0 Likes
TaichiRK
Journeyman III

I also have the same problem with a 5800x and an asus x570 gaming-e
Any solution?

0 Likes

New version of Ryzen Master released in the past few days works fine. But I believe you need the latest bios as well. 

I contacted support 2 days ago and they just replied back today - 24 February 2021 (Australian time).

I installed the new version of Ryzen Master which is 2.6.1.1797 and now everything is working 100% in Basic and Advanced Mode.

The AMD support representative advised that I do a clean install of Ryzen Master and also clear the Motherboard BIOS as well.
If anyone can't get the new version working properly after installing the update, I recommend you follow the instructions that AMD sent, because they definitely worked.

AMD Support Instructions

1. Reset the motherboard BIOS (clear CMOS). Remove the CMOS battery for few minutes and reinsert it.
On my ASUS PRIME X570-PRO/CSM motherboard, I had to short out the CLRTC pins in bottom right corner to clear CMOS.

2. Please download and install the free version of Revo Uninstaller on your computer and remove the Ryzen Master including the registry entries.

https://www.revouninstaller.com/revo-uninstaller-free-download/

I then ran Revo Uninstaller to uninstall Ryzen Master.
Revo then scanned for fragments of program which it found - then I deleted all fragments.

3. After uninstalling Ryzen master, reinstall it from the below link.

https://www.amd.com/en/technologies/ryzen-master

After I could see that Ryzen Master was now working correctly, I re-booted again and re-configured all my custom BIOS settings. Everything is now fixed and I am very happy.

 

Relax!
0 Likes