Showing results for 
Search instead for 
Did you mean: 


Adept I

Ryzen 5800X problems on B550 Motherboards

Recently bought a Ryzen 5800X chip, but have been experiencing bad crashes. Hoping for answers. A summary of what happened when I used two different motherboards.

CPU: AMD Ryzen 7 5800X

PSU: Corsair RM750X

System Memory: Corsair Vengeance LPX 16GB (2 X 8GB) DDR4 3600 (PC4-28800) C18


Storage: SAMSUNG 970 EVO Plus SSD 2TB 

First motherboard: ASUS ROG Strix B550-F Gaming (WiFi 6) 

- The system was running fine for two days, then experienced a WHEA_Uncorrectable_error BSOD 

- After the error, motherboard was no longer able to read the Samsung EVO 970 Plus NVME SSD from the second M.2 slot PCIe 3.0 slot. Thus Windows 10 could not boot. Wi-Fi modem on board the motherboard was also no longer working.

- Replaced the Samsung NVME SSD with another unit. Motherboard was able to read the SSD, but at much slower speeds. I placed the SSD in the first M.2 slot (PCIe 4), and the motherboard was able to read the SSD at full speeds. PC was able to boot up and run Windows 10.

- However, it seemed like the motherboard was damaged since one of the M.2 slots was no longer reading memory at normal speeds, and the Wi-Fi modem was no longer functioning. So I decided to get another motherboard.

Second motherboard: MSI MPG B550 Gaming Edge WiFi Gaming motherboard:

- I tried again using this motherboard, but experienced the same WHEA BSOD error after running the PC for an hour. Once the error occurred, the motherboard was again no longer able to read the NVME SSD from the second M.2 PCIe 3.0 slot. I also could not get the motherboard's Wi-Fi modem working.

- I placed the NVME SSD in the primary M.2 slot PCIe 4.0. The motherboard was able to boot back up and get to Windows 10. However, I noticed I was getting numerous WHEA errors in the Windows 10 event viewer.

- I then made sure to downclock the RAM to 3200 MHZ, and update the AMD chipset driver. After that, I was no longer getting WHEA errors in the event viewer. I also ran a Memtest86 on the RAM and found no errors.

- The PC was running fine for a day. But then the next morning, I got another BSOD error involving the WDF01000.sys hardware driver file.

- The motherboard could no longer boot into Windows 10 after that, despite repeated attempts. I removed the Samsung NVME SSD to try to get to the motherboard's BIOS, and reinstall Windows 10. However, the PC struggled to get to the BIOS screen. Only one out of five times did the BIOS screen load.

- As a result, the system was also unable to reinstall Windows 10 over the NVME SSD. I gave up and then contacted AMD's warranty support. Haven't heard much since. My ticket number is 8201031346

- I currently plan to try to build the PC again by getting another B550 motherboard, placing the Samsung NVME SSD in the primary M.2 slot, and buying 3200 MHz RAM. But I'm worried the 5800X CPU is defective or something is wrong with the PSU.

3 Replies

Did you manage to solve this?

I've got the same issue with my 5800X, Since I installed it in November.

Adept III

Are you updating the motherboard/s BIOS for 5000 series cpu's?


Yeah I'm on the latest Asus tuf B550M plus wifi beta bios the one that's meant to fix the USB issues. Before that I was on the previous latest. The first BIOS I tried was the first BIOS that supported the 5000 series CPU's it hasn't helped.