cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

Highlighted
Journeyman III
Journeyman III

Ryzen 5600x Does not post - MSI EZ debug light CPU

Hi,

I just finished my first ever PC build and it was not as easy as it should have been. After six hours i managed to get the computer up and running and while troubleshooting i noticed that others have had this same problem that i had, so hopefully this helps at least some of you.

Problem that i had was that i installed the parts, started the computer and all the fans and lights started working, but MSI EZ debug light for CPU was on and the display did not wake up.

Final conclusion in short, there was something with the RAM sticks and i still dont understand what. I had two Kingston HyperX Predator RAM sticks - Did not work. I swapped an old(er) RAM stick to the computer and i was able to get into BIOS. After installing Windows, drivers and updates, i swapped the Kingston RAMs back, enabled the XMP profiles and everything worked as it should. Im not sure could this be some kind of a compatibility problem with the BIOS and some of the RAM stick or something... hopefully it will be fixed as soon as possible.

 

Troubleshooting: Due to the EZ debug light i assumed that the problem is somewhere in the CPU, so i checked that the CPU pins were fine - twice. I did the post test by removing all other components (except one Kingston RAM) and cables except the 24pin and 8pin CPU power cable, but i still got the CPU debug light.

I swapped the Kingston RAM stick from one to another but did not work. I noticed that the BIOS version was printed on the motherboard and it was version 1.0, so i used the Flash BIOS button on the back of the motherboard to flash the BIOS from v1.0 to v1.4 which was the newest version. Did not fix the problem.

I did it twice and before the second time i did reset the CMOS. Also the Flash BIOS usage was quite a job. It seems that the newer USB (with blue connector) does not work with at least not with my motherboard, so the USB stick should be a bit older. Power should be ON from the PSU, but the computer should be OFF and the USB stick should be connected before you turn the PSU power ON. After pressing the Flash -button, all the RGB lights on the motherboard and the CPU debug light turned on and after the flash was ready, computer boots itself automatically.

After the BIOS update i had done everything that i could think of or what i could find from the internet. The last thing i was able to do was to change the RAM stick to an older one and for some reason that worked - Computer posted immediately and i was in the BIOS.

BIOS version was the newest v1.4, but i did the BIOS update once more (just to be sure) from the BIOS. After installing Windows, drivers and updates the computer work fine without problems. Although i havent done any stress tests like benchmarks or gaming with it yet so we'll see...

 

My computer:

Case - be quiet! Pure Base 500DX

Motherboard - MSI MPG B550 GAMING EDGE WIFI

Power - be quiet! Pure Power 11 CM

GPU - MSI GeForce RTX 3070 Ventus 3X OC

CPU - AMD Ryzen 5 5600X

RAM - Kingston HyperX Predator DDR4-3200 C16 DC - 2x8GB

SSD - Samsung 860 EVO 2.5" SSD - 1TB

SSD M.2 - Samsung 980 PRO SSD 250gb

 

RAM memory that i used to get into BIOS.

RAM-1x-8GB-Samsung-NON-ECC-UNBUFFERED-DDR4-2666MHZ-PC4-21300-UDIMM-M378A1K43CB2-CTD

Tags (1)
0 Kudos