Showing results for 
Search instead for 
Did you mean: 


Adept I

No security device fTPM

One time i changed my memory speed from 3200 to 3400 and my PC turned on from the 5 time with error

"New CPU installed. fTPM NV corrupted or fTPM NV structure changed.

Press Y to reset fTPM. If you have Bitlocker or encryption enabled, the system will not boot without a recovery key.

Press N to keep previous fTPM record and continue system boot. fTPM will not enable in new CPU, you can swap back to the old CPU to recover TPM related keys and data"

After this my fTPM doesnt work. OS doesnt see TPM like before (no in device manager, tpm.msc)

No security devices in BIOS

I reinstalled OS, reset BIOS with clrcts , battery and both.

In BIOS fTPM -enabled, Secure boot , Csm off.

Thank you

ASUS b450-pro gaming, ryzen 5-2600, last BIOS



8 Replies


Thank you,  but i catch this error once and after this my fTPM is corrupted.

Even with new SSD and new Windows. 


Have you tried Re-installing BIOS again. That should erase everything from the previous BIOS including any fTPM settings hopefully and set everything back to factory default.

But if you were using Bitlocker than you would need the key to have access to your SSD/HDD.



Yes. installed previos version, nothing. Then actual again - nothing.


Try opening a AMD SUPPORT ticket and see what they suggest from here:

Done. I think fTPM driver in CPU doesn't start or something..

I've had exactly the same issue with a Gigabyte B550M-DS3H, 5600x with BIOS F13. I'm using bitlocker and luckily I had my recovery key set up. There was no obvious cause for this error, it just sprung on me randomly after a reboot.

Journeyman III

I don't know that is your problem solved or not, but I have the same issue. I did a memory oc as well, but I'm not sure that the problem started before the memory oc or after it.