Showing results for 
Search instead for 
Did you mean: 

PC Building

Adept I

Crashes with newly build 7900x3D | Asus TUF GAMING B650M-PLUS WIFI | G.Skill 64GB

Summary of issue: Spontanious restarts without blue screens on newly build system.

  • Crashes sometimes for example when browsing, saving a file.
  • Crashes everytime with Geekbench and Aida64 'CPU PhotoWorxx' benchmark, which is a 'bandwidthtest' I've read.

What I have tried:

  • BIOS upgrades, from stock 0823 till recent version 1636
  • BIOS changes, purely for stability porposes
  • CPU (+/- 20) curve en geheugen van 1.4 -> 1.44
  • With and without EXPO settings 4800 - 5200
  • Two memory bank installed in A2 and B2, as well as independent in A2
  • Memtest result is a green 'pass'
  • OS & Drivers are all up2date

System Specifications:

  • PSU: Corsair RM850e
  • Mainboard: Asus TUF GAMING B650M-PLUS WIFI (R2M0KC255442N9E)
  • Bios: Stock 0823 till upgraded 1636 (AGESA version to Combo AM5 PI
  • CPU: AMD Ryzen 9 7900X3D
  • Cooling: Be Quiet! Dark Rock Pro 4
  • Memory: G.Skill Trident Z Neo F5-6000J3040G32Gx2-TZ5N (2x 32GB DDR5 6000Mhz)
  • Video: Asustek Nvidia RTX3060 GA106-302
  • Storage: Transcend 250H TS4TMTE250H & Samsung SSD 850 EVO 1TB
  • OS: Windows 11 Pro 22H2 OS Build 22621.2134
  • AMD Drivers installed

I don't notice a power or temperature issue.
Still, I can't figure out what triggers the system into a reboot, without blue screen.
Just the Geekbench get's the system in a reboot every time.
Hoping anyone has more experience in debugging such issues.

10 Replies
Community Manager

Hello @SPRK , welcome to Red Team!

A system crash is normally caused by memory not being sufficient or misconfigured. Updating the BIOS isn't necessary most of the time, in fact, I only update the BIOS if it's recommended by the motherboard's manufacturer. Do you have an extra/different pair of memory sticks you can try? 

I never used Geekbench, that said, is it compatible with Win 11? (Win 11 can be tricky). Does your hardware meet the app's min requirements? Are there other similar tools/apps you can try?


Your biggest fan!
CPU: AMD Ryzen 7 5800X3D GPU: AMD Radeon RX 6800XT

Hi Sam,

I'm normally an 'if it ain't broke, don't fix it' regarding to BIOS.
There where memory compatibility improvements mentioned, so I had to try.
I've ordered new memory that's on the Asus QVL and can return the current one.
I've also checked the QVL of G.Skill, who mentioned it is compatible with the Asus board.
Except the Asus QVL checks compatibility with a certain CPU & memory.

I've never had a problem before, that wasn't on a QVL.
When I have received the new memory I'll report back here as well.

Regarding test/bench software, I'm happy I can reproduce this behaviour with multiple tools.
Certain CPU tests are perfectly fine. The random reboots when browsing these forums are the worst 🙂

Adept III

I would check that the RAM you have is specifically guaranteed to work with your Motherboard's chipset.  I had a similar issue with some Corsair RAM that I bought and even though the Motherboard's QVL said it was "compatible", according to Corsair that wasn't exactly true.  It would run with all settings on "Auto", sure, but that was at the bare-bottom settings for frequency and the CL timings were garbage.  Any attempt to run it at rated Frequency and CL Timings resulted in constant crashes or just plain failure to even POST.

Definitely check with G.Skill about the compatibility specifically with the B650 Chipset.

Ryzen 9 5950X|Sapphire Nitro+ Radeon 6950XT|128GB Corsair Vengeance Pro RGB DDR4-3600 (4x32)|ASUS Crosshair Dark Hero VIII|Corsair iCUE 5000X RGB|Corsair iCUE H150i AIO|Samsung G55A 32" Monitor|Windows 10 Pro 64-bit
Journeyman III

I have similiar Problems.

AMD Ryzen 7 7800X3D 8x 4.20GHz So.AM5 WOF

Gigabyte X670E Aorus Master AMD X670E

1000 Watt be quiet! Pure Power 12 M Modular 80+ Gold


64GB G.Skill Trident Z5 NEO DDR5-6000 DIMM CL30 Dual Kit (F5-6000J3040G32GX2-TZ5N)

2TB Kingston KC3000 M.2 PCIe 4.0 x4 3D-NAND TLC (SKC3000D/2048G)

Adept I

I've exchanged the memory to comply with QVL.

From: G.Skill Trident Z Neo F5-6000J3040G32Gx2-TZ5N
To: Kingston Technology FURY Beast KF556C40BBK2-64

Re-seated again the CPU, and removed the Video-card and additional storage, only M.2. now.
Still the same issues.
Again contacted Asus to investigate the issue.

Adept I


I was asked by ASUS how I connected the mainboard. I explained the regular 24p is connected and the 8 pin power for the CPU. The additional 4 pin at the CPU is not connected.
I've received the following information from ASUS:

Well the 7900X3D does require alot of power.
So in this case I'd recommend connecting the extra 4 pin to see if there is an improvement in the crashing.

As you might know the 7900x3D has a TDP of 120 W. It was easy to run a fact check.
I even limitted the CPU in ECO mode to 65 W and the crash was there.
To my knowledge the 8 and 4pin both go to the same 12V power plane, connected to the whole VRM.
With this info, the additional 4 pins are not required to connect.
All in, I'm a bit dissapointed by the aswers from ASUS I received.

As I could crash the system with AIDA64 'CPU Photoworxx' I was pointed: this was a CPU and memory subsystem test. Having the memory controller on the CPU, it was the most obvious to replaced next.
I've send back the CPU and am waiting for the store to test the CPU as well before replacing it.

Adept I

The verdict is in: The Ryzen 9 7900x3D was malfunctioning.
The supplier who sold the CPU, did the same tests, with the same crashing conclusion.

They never believed the proof I shared, which caused a crash, until they saw it with their own eyes.
I wouldn't believe myself, reading it back.

  • Visit was a crash while the page loaded.
  • Geekbench after ~ 2 - 3 minutes.
  • Aida64 'CPU PhotoWorxx' benchmark

Now waiting on a new CPU.


I hope it will solve your issue, but i am afraid it will not. As a Dutch consumer as well i have had 2 times the new Ryzen 7 7800X3D bot times sealed and bought at Megekko. 2x the same sealed new MSI Mag Tomahawk B650 wifi motherboard.  And 2 times AMD qualified ram from Corsair once 5600 and last 6000mhz.


Both very unstable cpu's crashing out. 1th one no post after 2 hours. Last one did still post but lagging like crazy.

Used 2 completly different systems with different PSU, monitor and cables, gpu and ssd. And no luck at all.

I just never experienced anything that unstable besides the RX5700XT at launch i guess. That was a horror show as well.

Let's hope that AMD learns to sell products that are final and have good drivers and bios revisions. These are no accidents, but must be a design error or very bad driver support. Eighter way it did not work.


AMD is forcing you to buy Nvidia/Intel...i truelly do not understand that!

My Intel I7=14700KF uses a lot of power and can run hot. But is rocksolid and with XMP 6000 on for over a month now!


So please AMD wake up! I truelly tried to buy AMD and to advise, but it's getting harder every time like this.

Adept I

And the new CPU solved the issues.
Now running stable on a 7900x3D

Journeyman III

I had 2 times the same issue with buying a Ryzen 7 7800X3D.

Used 2x times a new motherboard the MSI Mag Tomahawk B650 wifi and both times AMD qualified Corsair ram. 

1th time it was 5600mhz and 2nd 6000mhz cl30 ram.


My set set did not work anymore after 2 hours. Black screen and sometimes it posted into Windows 10 pro and going black again.


2nd set i have used 6000 mhz Corsair AMD EXPO ram. Updated the bios and installed all drivers. Used all different components, like ssd, PSU, keyboard and mouse as well a different monitor and GPU.


2nd time it lasted a bit longer, but after enabling EXPO everything became very unstable again and would not be stable again when defaulted.


I feel AMD has released something that was not finished.  1th set tried in September and 2nd in november.

Both times resend and got refunded. And i had to make the step to Intel and bought a I7-14700KF and it is rock stable with XMP 6000mhz.


On the AMD system i only used 2 stick of ram 16gb each and placing then in A2 and B2 and tried A2 alone. No luck.


I feel the chiplet and the V3d casche with poor drivers and bios is the cause. As a long time AMD user i finally got back to Intel. And thats all on AMD. Was happy with my Ryzen 9 5900X.

Next item to sell is my RX7900XT as it still is sometimes causing me issues although it's not that bad. But the idle power consumption with driver 23.12.1 at 44 watts at 144 hz with a dual monitor setup and 85 watts at 165hz is unexeptable for me and will force me to buy the overpriced Nvidia rtx 4070ti super or 4080 super that will come.


I hope someone at AMD is reading it and does something with it, because launching products with broken drivers is something AMD does native. I have a RX5700XT back then i sold after 4 months with black, and blue screens...

So instead of trying making a fancy Adrenalin UI try releasing stable drivers instead?