Showing results for 
Search instead for 
Did you mean: 

PC Building

Volunteer Moderator

Corrupted Bios

I decided to build a PC for my cousin and the best thing happened when I cleared the CMOS. It now won't event attempt to power on or post. I tested the PSU with my X370 board and it posts with no issues. I test to see if the B450 board that is giving me problems would power on by jumping the power switch pins. No sir. I think the bios chip failed or something. I built the same PC on both boards and the X370 works fine. I went so far as to leave out the CMOS battery for 2 hours in the B450 Aorus Pro WiFi and it just won't take power. The motherboard lights don't even power on. It had been through the RMA process before for this and I think it's dead. I ordered a new B550 board with a Ryzen 5 5600X to replace it so I can start the build for my cousin while I troubleshoot the issue. The configuration was B450 Aorus Pro WiFi, Ryzen 5 2600X, 2 by 8GB T Force Vulcan 3000mhz RAM, Gigabyte GTX 1660 Super Gaming 3X Fans, and my trusty Corsair CX750m 750 watt PSU. I'm at a loss. The Aorus board is just past warranty. I would separate the text in this post but my phone goes crazy when I hit the enter button on this site. Sorry for all the jumbled text. I guess this all works out because I can build something new for my cousin, but I do want to get the Aorus board functional again at some point. My cousin's specs will be B550 Aorus Elite AX V2, Ryzen 5 5600X, 2 by 8GB Corsair Vengeance RGB Pro 3200mhz RAM, CX750m Corsair 750 watt PSU, Samsung 970 Evo Plus, Gigabyte GTX 1660 Super Gaming, in a 4000D case. I'm stoked to start the build.

ASRock X570 Taichi, Ryzen 7 5700X, 32GB RAM 3600Mhz, Gigabyte RX 6800 XT Gaming OC, Corsair HX1000 1000 Watt Fully Modular PSU, Win11Pro
9 Replies

are you working with this inside or outside of the case?

IF it's still in the  case, then I'd set it up on a flat static free surface and visually inspected the motherboard for burnt traces or bulging/blown caps. I'd look the power inputs on the motherboard as well for burnt marks.

plugging everything in together outside of the case will eliminate the case as a source of issues


ThreeDee PC specs
Volunteer Moderator

Will do. I went so far as to try both boards in the case however the B350I, I had thought it was X370I previously, is ITX so it uses a different standoff pattern. I will work some more on it this evening. 

ASRock X570 Taichi, Ryzen 7 5700X, 32GB RAM 3600Mhz, Gigabyte RX 6800 XT Gaming OC, Corsair HX1000 1000 Watt Fully Modular PSU, Win11Pro

I don't know this specific board but I have just tried to have a look at it, you may know more about it than me so I will ask this question. While I understand that you can run QFlash from within BIOS does your board have anywhere a button marked QFlash possibly with a LED on the button?

The Reason I ask is I have an Gigabyte Aorus Extreme X670E which has said button and a USB port marked BIOS, if I stick a USB memory stick in that port and press the QFlash button - regardless of if the machine is just a bare board with no RAM, GPU or CPU it will burn a new BIOS from the USB memory stick (provided one is on there named GIGABYTE.BIN) saving your skin.

The other type that I am aware of is the Systems with dual BIOS where you have a backup BIOS and a primary BIOS which your system appears to have from the manual - I just don't know how to access it - do you have another computer on which you can send that question to Gigabyte themselves? I would do that first, It might be as simple as holding down a specific key while turning the computer on from cold will enable the backup BIOS.


Found the info on it - have a look here.

Gigabyte Dual Bios info 

No bios flashback on the Aorus B450 Pro Wifi. It has dual bios, however it had this same issue before and I had to RMA it. Warranty is up now so I will probably invest in the cable kit that allows a bios to be flashed directly onto the chips using a clip that attaches directly to the chips themselves. Also, it would be a nice thing to have. 

The board is not accepting power, so it can't even power a mouse or keyboard. The debug lights don't even turn on. It is as bricked as a board can be.

I still have not had the time to investigate the board for possible physical defects, but I suspect some of the traces are faulty, so I probably will not even see it with a magnifying glass.  

ASRock X570 Taichi, Ryzen 7 5700X, 32GB RAM 3600Mhz, Gigabyte RX 6800 XT Gaming OC, Corsair HX1000 1000 Watt Fully Modular PSU, Win11Pro
Volunteer Moderator

Definitely take everything out of the case and work outside the case.  Standoffs in the wrong spot when the motherboard is mounted to the case can cause serious problems, such as shorting.  

So no indication that the motherboard is powering up?  No debug lights coming on?  Could be the power supply, or maybe there is a circuit breaker that tripped in the PSU or in the circuit feeding your PSU.  

Lets see some pictures.  Look for burn marks on the bottom of the motherboard.

As Albert Einstein said, "I could have done so much more with a Big Al's Computer!".

My guess would be that you are right in this instance, if it is not the BIOS then it is the PGC ( Power Good Capacitor ) it returns a signal to the PSU to say "Yup got power over here, all good" if that capacitor dies then the board will not turn on at all. You could try identifying it but honestly it's probably more trouble than it's worth if the PGC has died.


Had almost the same problem with my MSI X470 board when I tried to build the Ryzen 7 2700X machine back about 1 week ago.  Really frustrating  when it won't even power up.  I just took it apart again and put it all in the closet.  I'll check it all out again sometime later.  If I'm still around. lol

Volunteer Moderator

I will come back to this when I have time and money to throw at the problem to find what is causing the actual issue. 

The way it happened was bizarre to say the least. 

I went to install Windows offline and it didn't install any drivers for the integrated LAN or WIFI, so I went back and tried to do another fresh Windows install and it still had no connections available for the standard online installation. This is when I cleared the CMOS and everything broke.

At first the CPU LED was illuminated. Naturally I removed the RAM modules to see if it would skip over CPU to the DRAM light and it would not. Then I removed the CMOS battery hoping it would reset the CMOS and I would be able to POST again. This made the board no longer receive power. I then tested the exact same parts on my B350I Pro AC. This did in fact POST to BIOS. 

I then tried again with the same parts with the B450 Aorus Pro Wifi and it was still unable to receive power. No LEDs illuminated on the board and fans did not start spinning. It was as if I did not have the PSU switched to the on position. I checked the connections once more and found nothing was disconnected. 

I tested the PSU with my Dr. Power 2 and everything was fine with the 24pin, PCIE power, as well as the EPS and SATA and Molex connections. 

To state this once more, I did have to RMA the board nearly two and a half years ago, and I assume the issue was not completely resolved in the process, and more likely just "quick fixed".

Maybe later in the month I will find some time to examine the board for physical defects, but for now this is just too much effort to resurrect a board that I have a replacement for. 

Now that I build my cousin a PC with brand new parts I will probably recycle the 2600x, RAM and Nvme for my SFF build I plan to do to replace my XBox One, as another media streaming PC.

ASRock X570 Taichi, Ryzen 7 5700X, 32GB RAM 3600Mhz, Gigabyte RX 6800 XT Gaming OC, Corsair HX1000 1000 Watt Fully Modular PSU, Win11Pro
Volunteer Moderator

Thank you to everyone who chimed in trying to help. I love this community, and how many people posted to save the poor broken board really does make me happy. I have taken all the suggestions into consideration and whenever I feel like being frustrated again I may give that board one more try. 🙂 You all are awesome.

ASRock X570 Taichi, Ryzen 7 5700X, 32GB RAM 3600Mhz, Gigabyte RX 6800 XT Gaming OC, Corsair HX1000 1000 Watt Fully Modular PSU, Win11Pro