Showing results for 
Search instead for 
Did you mean: 


Adept I

What is going on with OpenCL and Ryzen?

I like AMD and Ryzen for the sheer number of cores and horsepower it has, aside from other things, and I used to be able to see "AMD PARALLEL ACCELERATED PROCESSING UNIT, RYZEN 7 1700X" under my VRay tab render settings in Maya for OpenCL at least. I am not sure if it showed up for CUDA too, as I have both brands in my possession for testing purposes. Anyways. I read that AMD stopped OpenCL support for CPUs? Because of some bug? I never had any issues with my Ryzen 7 1700x in Maya and every time Maya launched, it would show 2 "available" OpenCL devices, one for my GPU and one for the CPU. But that's no longer the case. I tried installing the older cheapsets and so far nothing has worked. I just don't wanna lose on performance I could and should be getting from Ryzen too. VRay now just shows CPU/C++ whereas before I would see both AMD PARALLEL ACCELERATED PROCESSING UNIT, as well as my Vega 64. Please help me figure this out. I would appreciate it.

7 Replies

This thread at Reddit asks the same question. It seems like CPU OpenCL is still supported on LInux but not Windows: 

Also from another Reddit thread: 

This previous AMD Thread, Moderator Dipak, mentions that CPU is no longer supported as an OpenCL Device: 

Best place to post your question is the same AMD Forum that Deepak ‌ moderates at OpenCL‌.  Someone there might be able to assist you better.

Thanks for the links. I did read one those reddit posts before asking here. To me it sounds like it could be Windows? But if this is indeed AMD ceasing OpenCL support for its Ryzen CPUs, then I shouldn't be seeing Ryzen pop up under available devices earlier. Did AMD officially cease support for CPU OPENCL? or not? I would appreciate an answer.


Moderator Deepak ‌would probably be the best person to answer your question or post your question at OpenCL


Yes, elstaci‌ is correct. OpenCL support for CPU devices has been dropped starting with Adrenalin 18.8.1. 

As I know, there is an open source version of OpenCL with CPU support and it is available here: POCL . You may try this one.

Thank you elstaci for your reply and providing those links.


Thanks for the answer. Do you know why it was dropped? And do I still need to install Adrenalin's earlier version even with an Nvidia card to get OpenCL CPU support back? I am not too terribly concerned since I will mostly be using my RTX 2070 which runs faster on CUDA+CPU anyways, but I am keeping the Vega 64 handy and wanna know how to get OpenCL CPU support back. I just don't understand why they would do this.


Sorry, I'm not aware of the exact reason(s) for dropping the CPU support. That was our OpenCL team's internal decision. However, AFAIK, switching compiler tool-chain could be one of the reasons behind this. 

For OpenCL CPU support, you can use previous drivers or you may try POCL as I mentioned above.



By the way, I'm moving this thread to our OpenCL developer forum and I've whitelisted you also.