cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

salty_roman
Adept II

RX 5700 XT fluctuating clock speeds

Hello,

I'm getting clock speeds issue on my RX 5700 XT Pulse.

My GPU settings (undervolt/overclock) (was stable and issueless):

  • Core: 2000MHz (actual 1930-1940MHz)
  • Core Voltage: 1080mv
  • Memory: 910MHz (actual 1820MHz)
  • Power limit: 0%

Problem description:

  • If I have custom settings set in AMD Wattman I'm reaching 99% usage (which is normal = no vsync) but not getting to factory clocks.
  • GPU is reaching clocks between 1600-1640MHz on Core and Memory clocks are sometimes jumping from 875MHz to mentioned 910MHz.
  • If I put Power limit to 50% which kinda solves my issue but I was able to run that settings mentioned above without any touch on Power limit.

When it happend:

  • Yesterday when I installed new driver 19.11.1. I DDU it and installed 19.10.1 and still it seems I have the same issue.

My possible solutions for it:

  • Drivers (Tried 19.11.1. , 19.10.1 and will try 19.10.2)
  • PCIe settings in BIOS is set to Auto instead of 3.0
  • Shader cache (as I read in similar issue post)
  • High performance set in Windows (Power options)
  • Let me know what you think the case might be.

Thank you for your help and time.

-----------------

My Setup:

Ryzen 5 1600 @4GHz (stable, no thermal throtteling)

RX 5700 XT Pulse

16 GB 3000MHz

EVGA 650W Gold Quality

Gigabyte AB350 Gaming rev. 1.0

31 Replies

It's "normal" I guess, with the same thing happens. It's just a power saving feature from AMD,... 

Never had my boost speed of 2035 mhz, my card is 4 days old,... Maximum so far is 1930Mhz but only just a few seconds. None of my other system components get used 100% so I do not have a bottleneck. 

You should complain to AMD about it and also your custom card maker, ask them for a specific game profile driver option that disables power saving so the card runs stock speed minimum or higher,...  

Nividia has this, I never had problems with FPS drops due to low frequency and fluctuations with Nvidia,...

So if I write them they will give me what? Custom BIOS or guide to disable it? But if they will give me guide on how to disable it why there is none guide on the internet? Sorry if I sound dumb but I don't get it. I understand they have some power savings within the software itself but why I don't have the option do disable it. Thank you

Yeah that's the point, there is no option,... 

You have to report that it's malfunctioning so they know something is wrong and ask them for the option to disable this,...

Here on the forum there are just normal people, they do not work for AMD,...

That's dumb that they are hiding options which some people may want to disable. I had NVIDIA and it was kind of weird that I'm missing power saving option, RX 5700 XT is my first gpu from AMD

Indeed, I also switched to a AMD GPU just 4 days ago because of better performance/quality/price. Sadly now there are driver issues,... 

Just report it,... It's a simple solution,...

Update: Fluctuating isn't problem anymore it was fixed by installing 19.11.1. it was due to driver 19.9.2. which created my issue mentioned above.

About power option settings: So I spoke with a guy from Sapphire about my problem and he told me that GPU power saving is controlled by OS not GPU itself. I am still in contact with him but I want to if I should contact AMD support or if it's true what he said, seems weird to me that OS is controlling GPU power savings.

0 Likes

I do not see what harm it can bring to contact AMD,... 

The driver works on Windows so maybe windows is not properly working with the driver, maybe that's what the guy meant. Eitherway it's their responsibility to make it work,...

I reported my problems and they are looking into it (asus) and AMD itself thanked my for my feedback and told me to wait for the next driver so I assume it's a driver problem.

0 Likes

I will contact AMD but don't know how or where.

About the driver: the guy from Sapphire told me that power savings on GPU are controlled by OS so there is no option, I actually don't understand what you mean by "driver problem".

What issue did you report to the AMD support and what answer you got from him.

0 Likes

Well there is no point telling you about my problems again and explaining,... 

If you do not have any problems with your GPU anymore of course you do not need to contact AMD,... 

0 Likes

Sorry I forgot that you mentioned your problems and read your post about it.

So about the power saving is there SOMEWHERE option to disable it or you just made it up. Sorry for saying that but if guy from Sapphire tells me there is no option and you are telling me different information is quite confusing.

0 Likes

?

Euhm the option I told you about is with NVIDIA DRIVERS ! 

The whole point is that AMD DOES NOT HAVE THIS OPTION. 

Your a bit confused I understand,... 

 

See my first post and the last sentence,... 

0 Likes

"ask them for a specific game profile driver option that disables power saving so the card runs stock speed minimum or higher"

That's why I thought there is an option, this sentence got me off.

0 Likes

Oh, well yes I meant aks them to make it

It's simple, basically it's just turning the power saving crap off, it just does not work properly in some games. 

I do not need power saving for a high performance gaming rig,... 

The point is to have a smooth gameplay with no FPS drops, not windows or AMD drivers constantly lowering frequency's causing FPS drop and making some games even unplayable. 

0 Likes

Like I will ask them if they have plans to make this option for end users. If I want to ask AMD about it where should I go? I cannot find DIRECT support from AMD only those forums.

0 Likes

https://www.amd.com/en/support/contact-email-form 

You need to learn to use google  

google : amd support contact 

0 Likes

Don't get me started please, thank you for the link.

0 Likes
kuski
Journeyman III

Ever got it fixed?

0 Likes

for me yes, I send the card back and got my money back. Now running 2060 super, as smooth as butter,... 

0 Likes

Oh.. I wish there was simple driver fix for my card. It worked perfectly but just recently the core clock speed started fluctuating a lot.. if only that problem goes away all would be good..

0 Likes
koszalek
Adept III

IMG_20200306_122721.jpghi, try version 19.11.3, but also uninstall chipset drivers as well as ryzen master, before installing drivers 19.11.3 turn off the internet and uncheck it

0 Likes

Hello. I don't have ryzen master, but do have the chipset drivers, is it really good idea to remove those? I want my CPU working well. And by "uncheck it" you mean to uncheck the factory reset box?

0 Likes
koszalek
Adept III

hi, no chipset driver will work, yes factory reset box

0 Likes

Wtf!! I tried to install that driver and it said I already had it partially and then I clicked "restart" as it asked it. And now my monitor dont have any signal?!?! I shouldnt have listened.. I cant use my pc at all (( the fans are spinning but absolutely no signal and no light on keyboard or mouse.. what do I do??

0 Likes
koszalek
Adept III

have you made the upgrade win10?

0 Likes

I was able to somehow boot, I had to restore all my bios settings tho... Im back at the newest gpu driver but when I tried to benchmark a game it started lagging way more than before and then it crashed my pc.. what is wrong with this

0 Likes
koszalek
Adept III

with two or three versions of the amd driver I also had a black screen as well as installing the chipset driver from October or December

0 Likes
koszalek
Adept III

problems came with the win10 1909 version, I returned to 1903 and it's ok now, if you have the latest win10 upgrade please uninstall it

0 Likes

how do you return?

0 Likes
koszalek
Adept III

0 Likes

Go to control panel and disable/enable the card, it should run full speed all the time. that's the only thing that has worked for me with my 5600 xt.

0 Likes


@salty_roman wrote:
Hello,

I'm getting clock speeds issue on my RX 5700 XT Pulse.

My GPU settings (undervolt/overclock) (was stable and issueless):
  • Core: 2000MHz (actual 1930-1940MHz)
  • Core Voltage: 1080mv
  • Memory: 910MHz (actual 1820MHz)
  • Power limit: 0%
Problem description:
  • If I have custom settings set in AMD Wattman I'm reaching 99% usage (which is normal = no vsync) but not getting to factory clocks.
  • GPU is reaching clocks between 1600-1640MHz on Core and Memory clocks are sometimes jumping from 875MHz to mentioned 910MHz.
  • If I put Power limit to 50% which kinda solves my issue but I was able to run that settings mentioned above without any touch on Power limit.
When it happend:
  • Yesterday when I installed new driver 19.11.1. I DDU it and installed 19.10.1 and still it seems I have the same issue.
My possible solutions for it:
  • Drivers (Tried 19.11.1. , 19.10.1 and will try 19.10.2)
  • PCIe settings in BIOS is set to Auto instead of 3.0
  • Shader cache (as I read in similar issue post)
  • High performance set in Windows (Power options)
  • Let me know what you think the case might be.
Thank you for your help and time.

-----------------

My Setup:

Ryzen 5 1600 @4GHz (stable, no thermal throtteling)

RX 5700 XT Pulse

16 GB 3000MHz

EVGA 650W Gold Quality

Gigabyte AB350 Gaming rev. 1.0


You already did the best thing and should go back to it. Raise the Power Limit slider to 50.

If you find an older driver worked better for you return to it and contact AMD support with the issue with the problem driver https://www.amd.com/en/support/contact-email-form

0 Likes