cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

marcoschaap
Adept II
Adept II

Powercolor RX6900 XT and HP Reverb (G1& G2) problems

Hi,

I've also posted this on the HP Support forum: 

I have a BSOD problem with my G2 upon connecting the DP cable to the GPU my system instantly freezes and after that shows a BSOD with Stop Code MEMORY_MANAGEMENT. To rule out a headset problem I tried my dad's G1, with that headset the system doesn't crash but both the screens stay black.

Ultimately I fired up my old Dell Visor WMR and it worked. Curious fact is that the Visor has a HDMI plug and the G1 & G2 obviously only feature DP plugs. Both the G1 and the G2 worked perfectly on my 2080Ti. Could this be a similar driver issue as what AMD had fixed for the 6800 (XT) in the current driver?

System Specs:

AMD 5800XT

MSI X570 Tomahawk

Powercolor 6900XT Red Devil

32GB G.Skill F4-3600C15 @ XMP speed

 

Came from a 2080Ti which had no problems running the G2. After switching GPU's I ultimately even re-installed my W10 to ensure no "left-overs" would interfere with the G2. If I install the AMD GPU driver while keeping the G2 plugged in (i kept it plugged in during the whole W10 installation and first few Windows Update cycles) the driver installer flashes the screen briefly and after that the system reboots.

If I unplug the DP cable of the headset while installing the AMD GPU driver the installation finishes successfully, however as soon as I plug in the DP cable a BSOD appears with stop code MEMORY_MANAGEMENT. I'm utterly disappointed because I already sold my 2080Ti...

0 Kudos
37 Replies
taskforce131
Elite
Elite

Re: Powercolor RX6900 XT and HP Reverb (G1& G2) problems

you might need to update your bios for this video card biso 7C84v153(Beta version) is for 6800 video cards but it is beta so you might get i to lot of problems . never sell you video card when you getting new one until you test it for 1 week or so 

0 Kudos
marcoschaap
Adept II
Adept II

Re: Powercolor RX6900 XT and HP Reverb (G1& G2) problems

I have that BIOS installed already, also tried a few previous versions to rule out that casuse. I get what you say about not selling it, but ultimately I feel this top end hardware (both the 6900Xt and the G2) should be a working combination, I was also not aware of problems as there is very little information about it. Also the fixes for the 6800 (XT) GPU's in the current driver for the Reverb state no known issues with the 6900XT.

I'll just hope something is found very soon.

0 Kudos
kman83
Adept I
Adept I

Re: Powercolor RX6900 XT and HP Reverb (G1& G2) problems

I have the exact same issue. Instant crash restart when plugging into an port including external usb hub. Tried uninstalling drivers even new windows install.

6800xt Merc via riser cable. 

z490 Maximus Xii Hero Wifi

10900k

32gb trident royal z 3600

taskforce131
Elite
Elite

Re: Powercolor RX6900 XT and HP Reverb (G1& G2) problems

@kman83 @marcoschaap it is more likely your mother board think that G2 is a graphic card or boot able device.  

 

Do you guys have usb c connector for your G2 ? Because the USB c part is is for VR gaming they might F it up with DP. 

0 Kudos
kman83
Adept I
Adept I

Re: Powercolor RX6900 XT and HP Reverb (G1& G2) problems

Yes. Tried that too. 

I can cause the same error to happen with nothing plugged in via the windows verifier. So it looks like its a driver issue.

DRIVER_VERIFIER_DETECTED_VIOLATION (c4)
A device driver attempting to corrupt the system has been caught. This is
because the driver was specified in the registry as being suspect (by the
administrator) and the kernel has enabled substantial checking of this driver.
If the driver attempts to corrupt the system, bugchecks 0xC4, 0xC1 and 0xA will
be among the most commonly seen crashes.
Arguments:
Arg1: 0000000000002000, Code Integrity Issue: The caller specified an executable pool type. (Expected: NonPagedPoolNx)
Arg2: fffff80b3d3f1d93, The address in the driver's code where the error was detected.
Arg3: 0000000000000000, Pool Type.
Arg4: 0000000000726274, Pool Tag (if provided).

taskforce131
Elite
Elite

Re: Powercolor RX6900 XT and HP Reverb (G1& G2) problems

Check your firewall see if it blocked the AMD drivers also check the administrator permissions. You might accidently block the driver :rolling_on_the_floor_laughing:. Check the registry to see if AMD software is block or not . 

@kman83 

0 Kudos
marcoschaap
Adept II
Adept II

Re: Powercolor RX6900 XT and HP Reverb (G1& G2) problems

With 2080Ti in that same motherboard the G2 worked like a charm. How could this be a motherboard issue? I've tried multiple combinations of things which all did not help. I have tested three headsets (2 DP connectors and 1 HDMI) and only the latter works. I've read multiple users which report problems on DP connected hardware with very high resolution / frequency combinations. I'd suspect the error is to be searched in that corner.

0 Kudos
taskforce131
Elite
Elite

Re: Powercolor RX6900 XT and HP Reverb (G1& G2) problems

"because the driver was specified in the registry as being suspect (by the
administrator)"

check if your system is blocking the AMD software or not 

 

 check this one 

https://windowsreport.com/driver-verifier-detected-violation-windows-10/

https://www.youtube.com/watch?v=P2zdKbEEinM

0 Kudos
kman83
Adept I
Adept I

Re: Powercolor RX6900 XT and HP Reverb (G1& G2) problems

I have gone through and checked. All AMD stuff is allowed in firewall. I have done every step in that check list. I'm suss on the realtek usb 2.0 when it loads it crashes. 

If I use my usb 2.0 slot it doesn't crash and the realtek usb 2.0 will load and sound comes out of the headset. But then mrp wont go any further. 

My main monitor is 49rg9 5120x1440 120h.

 

 

0 Kudos