Showing results for 
Search instead for 
Did you mean: 


Journeyman III

AMD Radeon HD7570 maximum resolution problem

Hi guys,

I've tried to find if someone raised this question before on the forum, but I couldn't.

So I need your help guys, someone who's got better knowledge and experience, or any idea where can I start again.

The system: Dell Optiplex 3010 with an OEM AMD Radeon HD 7570 1GB LP PCI-e

Cable: 4K (4k@60Hz, HDCP2.2...) High Speed cable with the same capability HDMI/DV-I adapter (because the card doesn't have HDMI port)

TV: Samsung UE49MU6470 4K (I think this is irrelevant, however I listed just in case)

Amplifier: Yamaha RX-V673 (capable to passthrough 4K resolution or even upscale to 4K)

The card capable to do a max. resolution of 2560x1600 on DV-I port (as per AMD product info), however I have tried the DP port also just in case, with no luck.

I cannot reach that resolution, only full HD.

Please see the pictures attached. That maximum resolution not even listed on the AMD driver properties also on the Windows 10 Advanced display setting shows full HD resolution.

It looks to me the Video Card sending a wrong signal/resolution to the Amplifier/TV.

The hardware definitely capable to show the max. res. (even more) so I assume the video card driver is wrong or I might need to dig in to the video card setup further?

Latest driver updated via Catalyst Centre 15.301.1901.0 (Catalyst suggested this is the latest version for this card).

Could you please help me and point me to the right direction.

I really appreciate any help or idea to resolve this issue as I just fed up now.

Many thanks in advance.

0 Replies