Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Sapphire RX480 Nitro+ 8GB stopped working.

Yesterday my PC randomly restarted during some light-weight gaming. Upon restarting no image was being displayed on the screen despite the system booting succesfully. Tried switching from DP to HDMI but that didn't work.Then I plugged DP cable into my motherboard to use the iGPU of my processor and that worked properly, allowing me to find out that UEFI doesn't even pick the card up being inserted in a PCIE slot anymore.
Card's LEDs light up, fans don't spin. Putting it into another PCIE slot does nothing.
Tried a backup card and it worked without any issues, so it's not my motherboard being the problem.
Did the card die on me?
That'd be pretty upsetting considering it's barely 3 years old, has never been overclocked and hasn't seen much dust due to proper cleaning.
Is there anything else that I should do, or am I out of options?
My system:
i5 6600K
2x8GB of 3200MHz ram
Sapphire RX480 Nitro+ 8GB

7 Replies
Journeyman III

I 've just had the same problem with the same GPU. I don't understand what have happend.
Did you get any answer from amd support ?

I have the same problem happen 2 days ago. I'm keen on testing the card on another computer to see if it's really dead. Might take awhile with the pandemic and all.


No reply whatsoever. The card was already out of warranty, so Sapphire refused to replace it.

Bought a Sapphire 5700XT Nitro+ SE in january to replace the dead 480 and in less than 12 months it started artifacting. I'm pretty much done with Sapphire considering i've had their premium versions of cards either die or malfunction.

Today my card stopped working as well.

Nitro+ RX 480 8GB

When connected, fans are spinning but no video is being displayed on any port. Had to remove it to let the system boot with iGPU. I have recently bought ASUS TUF Gaming VG279QM monitor and been running it at 280 Hz. Could see system errors whenever system was going to sleep that "device connected to Display Port stopped working" - but I read that this issue is monitor related - its not able to standby while free-sync is on.

I am not going to purchase Sapphire products anymore - its made to fail one day. 


flip the bios switch - reboot
if not working: also do a cmos

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
Journeyman III

Same happened to me like 5 months ago i tried doing some things but nothing worked i dont know what to do now. 
fans dont spin only the led is on.

any help?

Journeyman III

This happened to me today.  I know the card is older, but it has worked fine until now.  I've been looking through forums to try and find a fix, and will try some of the suggested solutions tomorrow.  Anyone have a success story on this issue?  Only seeing failures.