Showing results for 
Search instead for 
Did you mean: 

GPU Developer Tools

Journeyman III

AMD ADL on Linux, unsupported?!


Based on the documentation, ADL SDK supports linux (example Ubuntu). I made a lot of research, but I do not know, how can I use ADL on my ubuntu machine. The documentation writes:


For LINUX OS, the locations and binary names are:

Linux 32-bit Runtimes (32-bit OS and 64-bit OS):


Linux 64-bit Runtimes (64-bit OS):



On these locations, there is no "" file. Furthermore, I did not find it on my system. I installed the latest driver and an older one, but not solved this problem. I also downloaded the ADL 10 zip, but there is no "install file" or any installation instruction in it.

Any ideas what should I try?

Thanks for your answer and help!

Best regards,


1 Reply

AFAIK ADL is now legacy library which was worked with old "fglrx" driver. Now when AMD moved to new AMDGPU-PRO it is quite possible that it will not work any more.

Also ADL SDK was just header file. You were supposed to open with dlopen() and then retrieve corresponding function pointer with dlsym().