Showing results for 
Search instead for 
Did you mean: 

General Discussions

Adept I

verification tool, new 5700 video card...system check did not pass

grrrrr. lol

new 5700 card from Best buy, have the codes for 3 month, and the games code, neither work. 

i registered on amd rewards, entered the code, downloaded, ran, reentered the code, then i get system check did not pass.  i have tried this more times than i would like to admit, not sure what or why.... 

i have it listed in device manager, i also disabled my onboard, no change. 

not sure if its a code issue, system issue, or something else.... 

debating pulling this card out, and running to microcenter for something else..... 

the card is a Radeon-RX-5700-mech-oc  msi 

i put in a support ticket with amd already.

thanks for your time

9 Replies

Open a Reward Support ticket ( ) and give them your Coupon code and verify that it is for the correct GPU that you purchased.

Some Users in the past, at least, for the Ryzen Processors received the wrong code for their specific processor. Seems like certain Processor models have different game codes. This might be the same situation with you and your GPU card.

Adept I

Sounds good, I opened a ticket the other day, receipt, coupon codes, error screen shots. I'll try to call them tomorrow. 

For the codes that didn't work, was it bounced back to the retailer , or was amd good about helping?? 

Thank you for your time 


Here is one thread where it had the wrong code for a 3rd generation processor: .

This was how it got resolved:

Adept I

Yep, I saw that yesterday..... no mention how they got the other code... if from amd or the retailer. . 

BB is pretty clueless so far...   they forwarded it to a top specialist,  and called back yesterday. . They told me to make sure I had the card installed......     BB said they have other codes, but since that didn't work,  it's not their deal and they can't /won't help.

I'll try calling amd tomorrow,  to see what they say.  Not sure what else to do. 

Last from best buy, I was to contact Microsoft and AMD myself to try to resolve this. 

I purchased the Microsoft pass, 1st month for $1   should be able to add the code later for the free months. 

Adept I

Hi, my 5600XT purchased recently gave the exact same error as well.

May i know is there any update after calling them? I have already sent a support ticket but no reply yet.

update1: now it says, " system did not pass", "coupon code already used"...i have checked my "claimed rewards" section and it is empty.

the AMD rewards support still have not replied to me.

Adept I

update, end of last week, amd sent me the codes, both did not need to use the activation tool.

before that every code failed verification. i sent an email, explained i only had 2 days to return the card and would like to get this sorted. the next codes were non tool codes. i did have to send an email saying it has been 10 days and still waiting, the next response was here are codes, those used the tool, and failed again. thats when i said i had just days to return the card, they replied quicker after that.

i did submit the receipt, screenshot of device manager, error screen shot from the tool, codes best buy had sent me screen shots, 

not sure why the tool hated my system, glad to be past it though. 

i did call a couple times, nice people at amd, not sure if it helped at all though calling, but couldn't hurt. he said the rewards was busy, and some were having issues...   Not sure if it was fluff or not... 

So in the end, what did AMD do? they sent you new codes that worked? or they did verification for you?


the last set of codes they sent me did not use the verification tool. so that entire process was not used. I entered the code on redeem rewards, then 2 options popped up, video card, not sure the other, then after checking that, i was able to claim the games and microsoft pass... 

all of the previous codes needed me to download and run the verification too. 

(hope this makes sense)

Thank you for clarifying. 

The amdrewards support team sent me new codes as well, PVT was not used.