Showing results for 
Search instead for 
Did you mean: 

General Discussions

Journeyman III

Unable to solve secure boot.

I have a Gigabyte x570 GAMING and every time I enable secure boot, my hard drives disappear and the bios cannot find them in order to boot from them. Help!

4 Replies

Sounds like your Hard drive was created with a MBR Partition on it.

For UEFI Mode to work you need to change the Hard Drive partition from MBR to GPT.

MBR Partition has 3 Windows Partitions created by Windows while on a GPT it has 4 Windows Partitions created by Windows.

MBR is compatible only with Legacy BIOS versions (CSM MODE) while GPT is compatible with UEFI Mode.

Go to Windows Disk Management and see if your Windows  Hard drive is MBR or GPT. If it shows to be MBR there is a Microsoft program that can change the drive from MBR to GPT without losing any data.

Otherwise you would need to do a clean Windows Installation with a GPT Hard drive.

If your Hard drive is GPT then post back more information and detail about what is going on and what you did to troubleshoot the problem.

Post the Make & Model of the Windows Drive  and how it is connected to the motherboard.




Install Win 10 21H1 from USB in UEFI mode via boot selection as this will override boot sequence, as needed. For the X570 Taichi's BIOS is "clunky" compared to some more "developed" BIOS's to which I have to use F11. If I don't my motherboard won't find a bootable device and just "stop". Once it starts the install process in UEFI it will create 3 disk partitions, 1st being a EFI, 2nd being boot and etc, and the 3rd Recovery Partition on my primary M.2 which shouldn't be any different from a SSD or HD.

I struggled with getting SMART on my X570 Taichi, 360XT and RX 5700 to enable, which I installed Win 10 21H1 in Legacy Mode. The drives (M.2) would disappear with CSM enabled, on the other hand it was resolved by installing in UEFI which the M.2 would be visible with CSM disabled to use SMART. This is when "Above 4G decoding" and "Resizable BAR" which is accessible once CSM is disabled. I had originally installed in UEFI, then Win 10 Pro 21H1 "puked" the BSOD and it couldn't be recovered and I had forgotten to reinstall in UEFI but was a bonehead and installed in Legacy.    lmao

X570 Taichi, Ryzen 3600XT, 32G of F4-3400C16D-16GSXW, XFX RX5700, NH-D15, Fractal Design R5, SilentWings 3 case fans, Intel 660P M.2 1T, WDS256G1X0C M.2 256G

Actually on GPT partition Windows creates 4 partitions.

1- EFI System Partition

2- MSR -16MB Partition

3- Windows Partition

4- Windows Recovery Partition

Normally you don't spot the MSR partition because it is so small.

Not sure but if you run BIOS in UEFI Mode with a MBR Windows drive I believe it would give you an error stating as such and vice versa.

So since you didn't get that error than most likely your Windows drive is GPT.

Therefore I would follow Mauser1891 advice since this has happened to him in the past.

Journeyman III

Under Bios Features

Boot option 1 - DVD Boot option 2 - external drive

Bootup numlock state - on Security option - system Full screen logo show - enabled

Fast boot - disabled

Windows 8/10 features - other OS LAN pxe boot option rom - disabled Storage boot option control - uefi only Other pci device rom priority - uefi only Network stack - disabled

Mouse speed - 1x

System mode state -setup Secure boot state - disabled