Showing results for 
Search instead for 
Did you mean: 

General Discussions

Journeyman III

Site admin: please fix your member registration captcha for mobile phones

The captcha doesn't display correctly on mobile phone: I only saw the first seven letters, the last three letters (out of 10 total) were never displayed in portrait mode (haven't tried switching to landscape mode)

After 10+ unsuccessful attempts, I opened the image itself in a new tab and only then could I see all the letters.

Using Galaxy S7 edge (1440x2560) on Android 7.0 with Google Chrome 66.0.3359.126

EDIT: fixed phone orientation typo

3 Replies

even on desktop it's F****** awful.


It's not a big issue. Sometimes it occurs because of network issues and will recovered after a little bit of time.

Journeyman III

Well, not quite the same issue, but I spent *two* days, yes two days, trying to register for access to this community.

I must have tried at least 50 times, and used three  browsers. That on a laptop.  The problem seems to be the absurd jiveon system with its ridiculous entanglement with a vast number of third parties. An example of how not to write software.

I failed with Firefox and Palemoon: obviously I run Noscript on both of those, and I had to enable a myriad of dubious 3rd

party scripts to get anywhere. A major problem was lack of any feedback on failures.  The CAPTCHA's were quite impossible to decipher in 95% cases, and so I had to resort to the audio in most cases. Of course, the audio player was peculiar and again required a variety of contortions to get working. What ever happened to simplicity :-)

I eventually managed to register using a relativity obscure browser: Falkon. I was surprised that it worked.

I hope this will help other trying to register, but it seems unlikely that they would see this message in time.

It is worrying that AMD should be using such a poor badly designed over complicated system.