Showing results for 
Search instead for 
Did you mean: 

General Discussions

Ryzen 5 5600G on AsRock b450 restarting after 30 seconds, no post

I have bought the b450 steel legend in combination with the AMD Ryzen 5 5600G.
Including two memory sticks of 8GB each i had the build working.
To prepare the system for windows 11 i only had to enable the secure boot.
After some reading i tried the option 'enable EUFI boot' and i was playing around with 'fast boot'.
Now, after saving the settings i rebooted the system and thats when nothing worked anymore.
The fans on my MB, and green leds do work, but nothing anymore.
After trying to enter the BIOS i figured i'd do a reset, since i expected the system to go to the state i initially received.
After reading, i did the following to reset the BIOS:

  1. Remove any cables form the computer (power, HDMI, etc)

  2. Connect the jumper switch (part 19 on the design overview)

  3. Hold the power button for 30 seconds

  4. Remove the CMOS battery

  5. Wait for 5 minutes (tried a couple of times, wating 10 minutes and 12 hours)

  6. Inserted battery

  7. Removed jumper connection

  8. Restarted system
    Now after that, the system doesnt do anything, except for fans that run and lights that shine.
    There is no display on screen, not over MB not over GFX.
    Using a GFX card, or have none installed, no difference.
    I have two 8GB RAM cards, tried in any combination over the slots, nothing
    Used only one card, tried all slots, nothing. Not even with the other memory card.
    I tried the debug speaker, but no sound there. After i did a faulty installation of the RAM, the 3 beeps as expected worked. There was no other signal after correctly installing the RAM.
    I am out of options.
    One thing i now feel bad about, is that jumping the system (resetting the bios), affected the BIOS version, so the CPU is not supported anymore? I know this is a very far stretch, but i have no clue for any other options.

How can i get out of this boot issue? Especially when everything worked fine before i tried playing with EUFI en fastboot?

Thank you so much for your help!

14 Replies

Doing a CLEAR CMOS doesn't change the version of BIOS installed. So you still have the same BIOS version but it should be in its "Default' state and it should still support your new processor.

Which BIOS version do you now have installed that is if you can enter BIOS at all?

If you are able to enter BIOS Re-Flash the BIOS again to make sure it isn't corrupted.

If you can enter BIOS, disable Fast Boot and enable Secure Boot.

also make sure that you have :

Screenshot 2023-01-29 085606.png

The latest BIOS version is 4.60 :

Make sure you have both RAM Memory Modules inserted in DIMM Slots A2 & B2.

Also make sure you removed the CMOS Jumper from your motherboard.

Do you have the PC Speaker and Power LED connected here:

Screenshot 2023-01-28 141030.png

Make sure you have the Secondary Power cable connected to the Motherboard otherwise it won't boot up:

Screenshot 2023-01-29 085001.png


If your PC is Beeping when it boots up what is the Beep sequence that you hear?

To try and isolate the hardware involved using the Beep Sequence you need to disconnect all hardware from your Motherboard EXCEPT your PSU, CPU, Windows Drive and Monitor.

Power up and you should hear the Beep Sequence indicating you have a DRAM or RAM Memory issue if the CPU passed the BIOS test.

If you hear the Beep sequence for RAM, install just one stick of RAM in DIMM Slot A2  and boot up again. You should now hear the Beep sequence of GPU issue unless you have your Monitor connected to the Motherboard Video Outputs and have no GPU card installed.

The PC should now be booting into Windows in this situation. If it is install your second stick of RAM and see if it still boots into Windows.

Thank you so much for your very detailed reply, it is much appreciated!

So first things first: the build did work on windows 10, i entered BIOS and played around with secureboot (uefi and fastboot). That is where the trouble began.

After this, i am unable to enter/access the BIOS. There is nothing on screen. I have no way sure to verify what BIOS version is now running on the motherboard, since i cant access it.

To get access, i tried resetting the bios to reverse the changes i made and go back to the previous state.

1. I used the jumper pins, and have removed the connector as soon as the powersupply gets back on. I pressed the powerbutton for 30 seconds as per advice on most websites/forums.

2. I removed the cmos battery multiple times, for at least 10 minutes to hopfully go back to the default. This is done without the PSU connected and switched off. No other cables are connected to the system at any port.

3. I have been able to use the frontend speakers to connect to the speaker header. There is no beeps there. As soon as i boot up without memory, or faulty memory, the system beeps 3 times to indicate the RAM failure. This is gone when i install the RAM.

4. In most boot tests, i have installed one ram in slot A2, yet i tried A1, B1 and B2 as well. The same goes for dual memory cards, in A2 and B2, and other possible combinations. No results there.

5. There is no 5 beeps indicating issues with the GFX. I booted using no external GFX in the PCI port, installed one. COnnected it to power if installed there. Used that card with HDMI cable and none. I also used the HDMI cable in the motherboard, since the Ryzen 5600G supports graphics. No matter how i do the setup, the motherboard does not indicatie GFX errors by providing 5 beeps.

6. In all cases i tried, the system shuts down after 20/30 seconds, and then tries again. Regardless how long i let this run, there is difference in this sequence.

7. I have no components installed on the mobo, like a flashdrive or sata cables. Just the CPU and RAM, and in some cases the GFX card.

8. I have only used the 8 pin CPU power connector to the board.

9. The PSU test is positive, there seems to be no issue .

10. I removed all cables from the frontend panel, and only the power switch, to prevent shorts or misconnections.

11. There appears to be no instantflash for the bios to update the version to a newer one, without access to the bios (updating requires BIOS access).


If you have the Windows Drive, PSU, CPU, RAM Memory, and Monitor connected to the Motherboard's Video output (No GPU installed) power up.

Make sure your PC Case HDD/SSD LED and POWER LEDs are connected and working.

Keep an eye on the HDD/SSD LED light. If it is flashing or on constantly while power is on is indicating that it is booting up into Windows.

Wait until the HDD/SSD LED light stops flashing or is off for a few minute. See if by any chance you start having Video output on your monitor during this time.

Also see if you can connect another monitor or TV Set without your PC Monitor connected and see if you get any video outputs during POST or BIOS.

Also post any Beeps you hear as soon as you power up.


Thank you again.
I changed the build as you described.

The windows drive in a sata port. PSU conencted as supposed to be. Ram installed (one card) in slot A2. Monitor connected over HDMI on the motherboard, no GFX installed.

The power leds and HDD leds are connected.

When powering on the following happens:

1. No Power led activity

2. No HDD led activity

3. No display activity

4. No Beeping over the audio debugging

5. After 20/30 seconds the system shuts down and reboots

If you have the Power LED connected correctly then you either have a defective Motherboard or PSU or defective Power LED.

The Power LED should be lit up all the time as soon as you power up the PC.

Make sure you have the 24 pin Motherboard Connector tightly connected and also the 8 pin Aux Power cable.

One way to eliminate the APU or Motherboard is by either installing another compatible processor to see if it boots up or installing your APU processor in another compatible PC.

If your case fans are running when you boot up would indicate the PSU is giving out the proper 12 Vdc, at least.


So i tried to rule out as much as possible.

I cannot try the LED light, but i was able to use a multimeter to see how many voltage comes from the pins.
There doesnt seem to be any power over these connector pins. Correction, the leds are powered, so the light itself seems broken.

The PSU seems to be working fine, since all fans are running correctly. Any idea which pins i should test to see if the correct voltage comes out of the PSU?

I have found this article:

And tested all pins, the voltgae output is as expected. The PSU works fine

Sounds like your motherboard is bad. The motherboard is what supplies power to the POWER LED light and since you mentioned the fans are working that seems to still indicate something went wrong with your mobo, in my opinion.

You can always check for 12Vdc  from one of the spare Molex cables.

Also if you can find a diagram of your 24 pin Motherboard connector from the PSU you can also check the 5.0 vdc and maybe even the 3.3 vdc from the connector itself while plugged in.

I would open a ASRock Support ticket and see if they believe you need to RMA your Motherboard or it could be your APU processor.

EDIT: What I find hard to believe is just by you changing some common BIOS Settings caused all of your hardware problems unless you changed CPU parameters in BIOS like CPU voltages etc.

Changing BIOS settings shouldn't have caused hardware failure unless you mis-configured the settings for CPU overclocking.

So, thats the problem i have as well with this issue.

I cannot understand, retracing my steps, how this could lead to this behaviour.

I'm going to do my best to exchange the mobo, but i think i am going to look for a mobo that has better debugging options. I miss those leds that explain whats going on. After testing the PSU voltages, everything seems to work fine, so it has to be something in the mobo i cant figure out.

Lets hope i can swap the board or anything like it.

Sounds like something shorted out on the motherboard.

If you remove the motherboard visually check it for any type of damage.

From what I have been seeing helping other Users with No booting issue the MiniATX Motherboards doesn't seem to incorporate the 4 colored Trouble LEDs that other normal size mobos have.

One major feature I looked for before purchasing a Mobo to upgrade to a Ryzen processor was the BIOS FLASHBACK feature where you can update the BIOS with just power on and with the CPU installed or not.

Fortunately that feature is becoming more standard now in the latest Mobos.

The CPU seemed to check okay since you mentioned that BIOS indicated that there was a RAM issue when you had no RAM installed. That, to me, seems to indicate that BIOS checked the CPU and it passed its POST test and then went on to check your RAM.

But I find it hard to believe that a defective CPU would prevent the Motherboard from supplying power to the PC Case Power LED. 

In my opinion, The POWER LED PC light should illuminate as soon as you apply power to the motherboard with or without a CPU installed.

NOTE: I noticed that you scratched out about no power to the POWER LED. So the POWER LED is actually bad and you do have voltage at the 2 pins for the PC case LED?

You can always use the HDD/SSD LED wires since it also uses only 2 pins, Power and Ground to  replace the bad POWER LED light on the PC Case. You just won't know if your HDD/SSD is working or not.

Also what do you mean that all the "GREEN" LEDs are lit on the Motherboard or the PC Case?

Truthfully I was thinking of purchasing a ASRock Motherboard when I upgraded to a Ryzen processor. It had most of the features I was looking for at a cheaper price. But then I read ASRock's Warranty Policies and I didn't like it. So I went with Asus which is more expensive but is built with better quality components.

Thank you for the reply,
Dont get stuck on the led light of the case, this one seems defect. If i check the voltage, everything works fine.

The motherboard has build in RGB's, whic light up green to decorate it, that keeps working.

I returned the MOBO for RMA and the BIOS got updated by the vendor. They had no issue running it.

After return, i installed it again, and still get the same behavior! I losing my mind, cant seem to find what is ailing the system.

Any more suggestions what could be going on?


Hey this is quite an old post, I was troubleshooting another issue and stumbled upon this, have you tried running the second stick instead of the first stick on slot A1 or B1 to rule out a bad ram stick issue, also you could try using another drive because secure boot may have been "tripped" from the hard drive and thus refusing to boot (if the mobo is still relevant and you havent given up)  

Adept I

Change motherboard buy an asus or gigabyte with B550 or X570 and you won't have any problem, i have asus prime B550M-K with B550 and the gigabyte B520M-DS3H with B520 and they motherboard have Ryzen 5600G and i have no problem with loaded bios with AGESA V2 The Asrock, biostar and msi are very bad motherboards, they are for garbage, don't ever buy them. They have many problems with bios and compatibility with hardware. I still have motherboards asus from 2004 and later with AMD Athlon with dual-core and quad-core and hexa-core processors and Gigabyte GA-990XA-UD3 with FX-8350 and all work perfect without any problem.


Journeyman III

THanks everyone for helping, My problem got solved..

How was your problem solved?