Showing results for 
Search instead for 
Did you mean: 

General Discussions

Radeon Software won't open with last drivers 2021

hello everyone! here's my problem...Since I updated the driver 21.6.1 to the last one released (21.7.1), I cannot open radeon software in any of them. The driver is installed correctly but when I run to configure my profiles, nothing happens, it just doesn't open. I have tried everything but nothing works. I have uninstalled with DDU and reinstalled or changed registry value to 0 in regedit . is there any explanation or solution to this? it's very frustrating. I would appreciate any help. I should mention that the last driver that works in my case is 21.5.2. from there none of the later ones worked. my graphics card is a RX 570 4GB. thx for your time.


4 Replies
Adept I


Same problem here. Latest drivers 21.7.1 installed. Yesterday it was working normally and today Radeon Software does not open. Tried to Reinstall (Repair) drivers but does not work.

Please help!

Solved uninstalling drivers with DDU and reinstalling again. 


good for you! unfortunately it didn't work for me...i should keep waiting for a solution.


Hello FelipeBenjamin94,

The same problem was already reported a few days ago by some of us.

One guy, dehart420, was able to solve it. Here his procedure:

Good luck to you !