Showing results for 
Search instead for 
Did you mean: 

General Discussions

Journeyman III

Radeon 5700XT not working in PCI-E1 slot.

My Radeon 5700XT Sapphire Pulse does not work in the PCI-E1 slot of my MSI B450 Gaming Plus Max mobo but, it works in the lower slot. Has anyone had this problem or knows how to fix it?

5 Replies
Adept II

Have you checked the bios, to make sure the PCIe version is set 3 and not Auto?


I set the PCIe to”Gen 3,” but that did not work.

Sent from my iPhone


Need more information on your computer Setup including Make & Model of your CPU.

From your motherboard's MSI SUPPORT Specs: Specification for B450 GAMING PLUS MAX | Motherboard - The world leader in motherboard design | MSI ... 

Make sure you have the latest BIOS and CHIPSET versions installed: Support For B450 GAMING PLUS MAX | Motherboard - The world leader in motherboard design | MSI Global 

After doing all of the above and the RX5700 still doesn't work in PCIe x 16 slot 1 then I would suggest you open an MSI SUPPORT Ticket and see if your motherboard needs to be RMAed to be checked to see if Slot 1 is defective or not.

I have an AMD Ryzen 5 3600x, Radeon 5700XT Sapphire Pulse, and MSI B450 Gaming Plus Max.

Sent from my iPad

Journeyman III

I have a similar problem with my MSI B450 Gaming Plus, Sapphire Plus Radeon 5700 XT (and Ryzen 5). My PC reboots every few minutes spontaneously. The rebooting becomes less after fifteen minutes. Then the PC becomes reasonably stable and even can run a stress test like furmark. It does still reboot every hour or so. This behaviour appears in Windows 10 and also in Ubuntu 20.04. I flashed the mobo and have the latest drivers on both OS.
After I exchanged the Saphhire Plus 5700 XT with a GTX 1060 from another PC,  then both PC's become stable. I'll check if the second slot works ok like you said. I haven't tried that yet.