Showing results for 
Search instead for 
Did you mean: 

General Discussions

Adept I

OpenGL error in PS when using Nvidia texture exporter (dds)

So i get this kind of message when saving as dds, it happened suddenly, after the latest update. 



I googled a bit and downloaded opengl.dll and put it in PS folder. That did something since the error message changed and it gave me this. 



Have RX 6650 XT. Tried going back to previous version of drivers, didnt work. Reinstalled PS and Nvidia tools.

Can someone help? I have no idea what any of this is. 

8 Replies

So what makes you think any NV sdk tools would work with AMD cards?

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

It worrrr... umm worked for years? 

It's just their tools, a plugin for photoshop, for textures with MIP maps, it's not a GPU tool. 

Adept I

I get the same error since version 23.9.2 of the drivers with photoshop plugin.

But using the tool: It does work for me, but I find it not very useful depending on what you are working on, it is adding steps to the process of exporting .dds.

Although ami going back to version 23.8.2 it has worked again.
And the steps I followed were: Download the AMD Cleanup Utility: and then install these drivers

Have you managed to get it working with the latest drivers?


Didn't get it to work yet. Downloaded intel dds tools instead, although significantly worse plugin it gets the job done. At some point i will need to reboot windows and maybe it gets fixed then. 


Does it work with the latest driver?

I tried the one before 24.2.1 and it still didn't work... so I don't think they solved it


@ArwenKaboom  @jonatanfp_ 

Can you please provide clear steps to reproduce the issue?
And any example project or file you use to get the same error as you do?

Adept I

Simply hitting save to dds using the NVIDIA extension in PHOTOSHOP 2023 has worked consistently until the latest driver versions.