Showing results for 
Search instead for 
Did you mean: 

General Discussions

Journeyman III

amd shop (buy from amd - germany) cant add stuff to shopping cart

...had the problem all day long...with different browsers and different computers - even over my companies vpn.
can't be that i'm the first and only one to encounter that problem

does anyone know how to contact support or how to fix this?

10 Replies
Journeyman III

I think the bots just killed the site is all. I tried to get a Midnight black edition 6800xt, site had a small hiccup as I clicked add to cart and that was it. sold out in that flash.


well i'm trýing for almost 10 hours now. even before that gpu sale. i just cant add anything(availiable cpus) to my cart. it will load and show up empty.

Journeyman III

me 2,

it's not even possible to add CPUs to the cart that are availlable for days.

i used my daily Firefox and after that Microsoft Edge,, if this is due to trying to block scalpers i can assure you they had no problem,

your new 6800XT Black Edition is already on eBay for a high profit.

I now try since months to switch to AMD, i would like to switch GPU first and after that the whole platform but

your Resellers and the scalpers are better customers than me, right?

Adept I

I have the exact same problem, also Germany. A few days ago it worked but of course on the release day of the midnight edition everything is messed up. I didn't even have access to the website because I apparently refreshed the shop site too fast. I wonder how bots come through because they must refresh like every half a second.

I hope we Europeans will receive more updates on availability or priority in the near future. Not everyone has 2000€ to spend for a GPU.

just tested again, i was able to put a 5800X into the cart, but not the  2 3xxxx series CPUs.

but hey, i really want one of those 6800XT GPUs

Journeyman III

I keep getting "Please complete the reCAPTCHA challenge." and it doesn't matter how many traffic lights and crosswalks I click to verify. 

Anyone else has this problem? 

Not using a VPN. 

Screenshot 2021-04-15 at 07.19.13.png

So and now? Amd Support works on a solution? 

Same issue here. I did a test try by trying to add the AMD Ryzen™ 9 3900X CPU to the cart.

On my Android mobile I've managed it so far to get the captcha verification but then after verifying I got the same message like @WieslerOn Win 10 (it doesn't matter which browser I use) nothing happens when I click on the "add to cart" button.

It would be really nice if someone from AMD support would get in touch and help us. It is not acceptable that we normal customers are disadvantaged in such a way.

after 2 week still the same problem. Looks like they not care.

Journeyman III

It happens to me too, sometimes, even now if I try to add come CPUs in cart, especially with Firefox.

Some resource .js file fails to load with an Access Denied 403 and therefore an ajax call throws an error.