Showing results for 
Search instead for 
Did you mean: 

General Discussions

Journeyman III

AMD Reward Avatar: Frontiers of Pandora

I'm trying to claim Avatar: Frontiers of Pandora via the AMD reward page but when I log in with my Ubisoft account nothing happens and I only see a loading sign and this has been going on for almost an hour




2 Replies
Journeyman III

I am having the exact same issue I have changed wifi sources and tweaked my settings in the browser, I've even browser hopped in an attempt to resolve this and nothing seems to be working it just spins like yours does for an eternity before timing out.

Journeyman III

I am having the exact same issue myself. I've tried everything, no extensions or adblockers, every browser, disabled all security/pop up options, I've tried turning off my VPN, reset my ubisoft connect password to double check that its right and nothing is working. I did try going to directly to ubisoft connect through my browser to try and login and it won't let me login period, but it will let me login through the app on my desktop which doesn't matter cause to redeem the award it has to open it through the browser. It has to be something on their end because literally nothing is working hopefully this gets resolved. Ubisoft is complete and utter trash, people always have problems with them. I bought Assassins Creed Valhalla brand new through them a year ago and they took my money and I didn't get the game, couldn't get in touch with their customer service. Sadly they probably wont fix this either.