Showing results for 
Search instead for 
Did you mean: 

General Discussions

Journeyman III

All games crash with error 0xc0000005

Hello, I have been suffering with this problem for a long time, any game crashes to the desktop after ~ 30-40 minutes of the game, the same error is in the Windows log every time, Exception code: 0xc0000005.
What I tried: reinstalling drivers, reinstalling Windows, checking memory for errors, completely replacing RAM, replacing ssd with Windows, updating bios, none of this helps. Bios updates only got rid of blue screens and cache hierarchy errors, crashes have not gone away.
The computer goes through all the CPU and video card stress tests, I have no idea what exactly causes the failure, but I suspect the processor, because the whole Internet is clogged with the problem of crashes on ryzen, people wrote on the amd forum that only replacing the processor helped, but the store does not recognize the problem, pc undergoes all stress tests for a long time (more than 5 hours in OCCT) without any errors. There were also posts on reddit that replacing RAM can help in crashes, but again, I completely replaced the RAM and the problem was not solved.  
Ryzen 5800x processor
GIGABYTE B550 AORUS ELITE V2 motherboard (Rev. 1.0)
Kingston FURY Beast Black 3200 RAM
Galax rtx 3060 video card
DEEPCOOL PQ850M Power Supply
AK620 Cooling
Galax rtx 3060 video card
DEEPCOOL PQ850M Power Supply
AK620 Cooling

1 Reply

I first suspected it is a problem with your RAM.  The Kingston Fury Ram has had some similar problems in the past.   Some of it addresses assembly language issues when a procedure is called up and the Kingston RAM has some issues with it.  I would first check the QLV of the motherboard and make sure your RAM is listed as compatible, I'm going to guess it is not.  Here is the link to check and see if your RAM is compatible with your motherboard.

You will have to select which CPU you are using Vermere, Matisse, or Cezanne.  The first thing I noticed in the Gigabyte search was that Revision 1.0 was not even an option.  You mentioned that you updated the BIOS and I do hope you got the correct update.  Just check the Revision number with CPU-Z.  It should tell you if it has been updated to a more recent version.  

You have several things to look at but if you simply type "error code  0xc0000005" your browser search window it should give you the information you need.  Most of the ones I found were addressing the RAM as the culprit.


Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"