Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

wifi adapter not working

At the beginning of November, i downloaded a few updates for windows 11 and I suddenly had multiple issues, doing research it appeared my motherboard failed. I replaced the motherboard, and the issues persisted. I wiped the hard drive and installed windows 10. The system is stable now but i am unable to connect to the internet. the Ethernet connection will not recognize the network and has an IP config error. The WiFi has a code 10 "will not start" error on device manager. SO far i have tried:

1. turning everything (including router and modem) off and back on again
2. I have verified with other devices that the Ethernet cable and router port work correctly.
3. updated drivers for LAN, WI-FI , and GPU (downloaded directly from ASUS site for the motherboard)
4. updated BIOS
5. verified modem has current software
6. verified IPv4 is turned on/disabled IPv6 (has since been turned back on)
7. used Google DSN for IPv4
8. cleared network cashe VIA CMD
9. the entire first page on google results for "Ethernet doesn't have a valid IP configuration"
10. reinstalled windows and repeated all previous steps
11. Removed the SSD, installed windows 11 on a brand new SSD
12. installed a wifi card through PCIe, disabled wifi and bluetooth on the BIOS page

There have been a few brief moments where the WIFI would work properly for about 10 minutes and then stop talking to the network. Restarting the computer would cause it to revert to the code 10 error.

hardware configuration:
Motherboard: ASUS TUF gaming B550-PLUS WIFI II
CPU: AMD Ryzen 7 3700X
Memory: Corsair Vengeance LPX DDR4 3200 (2 x 16GB)
Hard drive: M.2 2280 hard drive (WD 1TB)
GPU: ASUS TUF Radeon RX 5700 XT
OS: windows 10 64bit


5 Replies

AMD has no WiFi drivers. Normally you get those from the Motherboard's Support download page of the Wifi manufacturer website.

Your Asus Motherboard uses a MediaTek Wifi  Driver:

Screenshot 2023-01-30 141649.png

Screenshot 2023-01-30 154907.png

Screenshot 2023-01-30 155027.png

Try installing Asus latest MediaTek drivers for both Wifi and Bluetooth and see if it starts working normally again.

I purchased a Asus TUF Gaming X570 Pro Wifi and it uses Intel Drivers for both its Wifi and Bluetooth drivers. So in my case I use Intel Driver updating app to update those two Intel drivers on my motherboard.


Those are the drivers i am using and where i got them from, problem still exists unfortunately. 


Which updates did you download and hopefully you didn't use any third part "driver updater" as those things should not exist.

1) Reboot you wifi-router, maybe even reset it to factory defaults
2) Make sure you do not use the default password for wifi-router management console, nor to wifi connection (WPA should be disabled as it offers no protection at all)
3) After setting those things and making sure there are no firmware updates available for your router, reboot it again

Computer hardware and software: 
1) Clear CMOS (unplug computer from wall socket, ledt LEDs dimm out, connect CLR CMOS pins in right lower corner for a few second using a tip of screw driver)
2) When you boot up, set DOCP back on, enable fTPM, SVM, UEFI boot to Windows and what other settings you use and that wifi is enabled and if there is any bifurcation setting, it is on Auto.
3) Do not enable/install any internet enhancers, TurboLANs nor install Asus Crate - if you have any, uninstall them
4) Make sure you have wifi-antenna screwed all the way in.
5) Uninstall wifi-adapter from Windows and reboot
5) Reinstall wifi-adapter using latest drivers from Asus website
6) Go to Control Panel > Network and Internet > Network Connections -> right click on your wifi-connection and choose diagnose and let Windows do its thing.

If you use any VPN or 3rd party antivirus software, they can install a driver type of thing between network and operating system, which can be incompatible.

You can also try to connect your computers wifi to your smartphone by enabling HotSpot-feature on your phone. Smartphones tend to overheat soon if you use them to download large files (tens or hundreds of gigabytes), so this is only for temporary use and testing. Also if you live in some terrible country, they can charge you by how much internet you use.

I am using the drivers from this site

I did the CMOS reset, verified/changed the BIOS settings, and on login had the same issues.  I did not do anything with my router.  Right now the WIFI card is not functioning so it cannot even see the wifi.  I cannot do the wifi diagnose for the same reason. 

I also removed and installed the WIFI drivers again, same result (Code 10 error, does not start). 



If the motherboard is still on Warranty I suggest you open a Warranty Ticket to see if it needs to be RMAed and repaired or replaced.

The Wifi is built into the Motherboard from what I can tell from the manual unless you have a separate Wifi PCIe card installed.

NOTE: If the Motherboard is out of Warranty then just purchase a PCIe WiFi card. They are relatively inexpensive.