Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Why can't AMD fix their chipset driver installer to work properly? I STILL can't install on system with 990FX MB and Nvidia graphics.

I have 2 systems with AMD 990FX motherboards, and FX-8350 processors.  I NEED the RAID drivers and RAIDXpert software, but it refuses to install on my systems with an "Error 173" because I use Nvidia graphics cards.  I know this has been reported previously here, and in over a year it's still not fixed.

Is AMD totally incompetent, or do they just not care about their loyal customers for CPUs who choose other vendor's video cards.

And -- don't tell me to install some software from 2016 or 2015 -- old versions are not acceptable solutions.

24 Replies

Here is a link from the beginning of the year concerning your problem. Error 173 when installing chipset drivers​ Is this the thread you were referring too in your Post?

You also need to :INFORMATION REQUIRED WHEN POSTING A QUESTION Since you never mentioned your Current Windows version running.

I guess depending on what Windows you have you may be stuck with drivers from 2016 or 2015 or download and install the Chipsets from your Motherboard's Support site.

Adept I

Yes, I saw the earlier thread, (beginning of LAST year) but no one ever closed the loop there.

Here are my system details, though (with 30+ years in the tech industry) I see no reason why they would matter...

  • AMD Graphics Card
    • Nvidia!
  • Desktop or Laptop System
    • Desktop
  • Operating System
    • Windows 10 Professional x64 Insider Preview Build 17074
  • Driver version installed
    • None, just default drivers
  • Display Devices
    • Makes no sense for this issue.  Two ASUS 32" monitors on Nvidia card.
  • Motherboard + Bios Revision
    • Asus Sabertooth 990FX Rev. 2.0 AMI Bios Version 2901
    • FX 8350

Power Supply Unit  Make, Model & Wattage

    • Really?  This completely stupid!  EVGA Gold 850Watt, I think.
  • RAM
    • Again, completely beside the point - 16GB

I have the exact Asus Motherboard as you do. Outstanding Motherboard by the way. I also have a Nvidia GPU card. I don't use RAID but I installed the AMD SATA CONTROLLER  from the AMD Chipset. When I ran the Chipset installation it didn't install the SATA Controller driver. So, What I did was go to Device Manager and opened the SATA Controller under Properties and manually updated by directing it to the C:\AMD folder. It promptly located the AMD Driver and installed without any problems. I also did this with the AMD SMBus driver in Device Manager under "System".

If you have RAID in your Device Manager you can also try manually to update the drivers by directing Device Manager to the AMD folder where the RAID drivers are located. If you don't show RAID then open the Device Manager and scroll down the list of devices to install a driver.

You may believe that posting your PSU is stupid, but it is not. Many people upgrade their GPU cards unknowingly without checking to see if their current PSU is strong enough to run the card in their system.

The post asking for your Computer specs is useful to AMD Support and users here in the Forum. I don't have any problems answering the questions about my Computer Specs unless it is some state secret or something

found this from another forum about installing AMD Chipset with a Nvidia GPU card. You could try this first:

Chipset drivers are seperate from Graphics drivers. And in general, they are necessary for what aidhanc stated in his post. Functionality, stability, and increased performance. AS a rule of thumb, dont mix different dates of driver packages.

Get the latest Graphics driver package to match your card, and the latest Chipset driver package that matches the board you are using.

Install chipset first (just my personal preferrence) reboot if required, install Graphics drivers, reboot if required.

If you have a previous version of graphics drivers installed, un-install them before installing the updated drivers. I personally have not run into a situation where chipset drivers suffered from conflicting drivers, they usually just get overwritten.

If you take your time and install them properly, they should not give you issues.

EDit: If your chipset package is asking to install AMD graphics drivers when you are running an Nvidia card, try cancelling out of the install process and attempting it again with the "custom" method of installation, which allows you to pick and choose which drivers get installed.

This should allow you to de-select the graphics drivers that are unnecessary and continue with the remaining drivers that are.


We don't validate our drivers against insider preview builds of Windows. Based on the information provided, this looks the most likely cause of the error. I can't see any other reason why the drivers wouldn't install.

Have you tried it on a non insider preview build? I am checking with driver engineering to see if this is a bug.

Adept I


What you suggest doesn't work.  You never get to the "custom" option. The software is obviously doing a hardware check early in its execution and just won't go any farther.  The code to fix this is simple.

I won't debate you over the need for configuration information -- this is clearly a software issue, not a power or memory or video card issue.  I'm retired from the tech industry after 35+ years in software engineering, software/hardware product management, product marketing, and corporate marketing.

Any engineering team that releases software that is this poorly tested (obviously never tested on systems with Nvidia graphics) should be embarrassed.  And - I was the Director of Product Marketing for Software Testing at Rational Software, and Sr. Director of Product Marketing at Segue Software - two of the premier vendors of software testing tools and methodology, so I have many years of professional experience on which to base this opinion.

The brainiacs at AMD tech support suggested I try uninstalling all my AMD drivers with their "cleanup utility," which, as expected, made no difference -  a complete waste of time.  If I was the product manager or engineering manager of their driver team (I have done both for products with many, many millions in revenue) I would be embarrassed and furious that such a simple problem has not been fixed and is causing customers so much grief and is making the team look bad.

This is what I sent to AMD Tech Support:

This is a simple fix for your engineering team to make – I don’t understand why, over a year after it was supposedly sent to them, they still have not fixed it!  I have managed several software engineering teams, and if a team that worked for me took more than an hour to fix this I’d be screaming bloody murder!!!

Send this to them:


Customer running Windows 10 x64 on a system with Nvidia, or other non-AMD video card, is trying to install AMD Chipset drivers (, or RAID Drivers & Utilities (


AMD installer exits with an “Error 173” because it does not detect AMD Video hardware on the system.

AMD Installer Error.jpg


Installing chipset and/or RAID drivers and utilities is independent of VIIDEO hardware – some systems will have AMD (RADEON) video adapters, many will not.  AMD chipset driver installer should not check for VIDEO hardware, but instead check for presence of AMD Northbridge/Southbridge, and install regardless of VIDEO hardware vendor.


I wrote a previous answer to this particular post but decided to delete it and write a update one.

I downloaded the latest AMD RAID chipset. Ran it and got the same 173 error. Went to C:\AMD RAID folder to packages and tried to install the RAID directly using the drivers own MSI installer. Received that my Windows 10 was not compatible. I did this with all the RAID drivers with the same results.

Basically, The AMD Raid software is not compatible if you have a NON-AMD GPU card installed. I even uninstalled my Nvidia Graphics drivers and still received the 173 error.

Found this link that REDFURY said to try which is a Windows 7 RAID Chipset (Error 173 when installing chipset drivers ). The thread is from 1/2017 concerning the exact same problem you are having. Going to download the link for the older RAID Chipset and see if it installs or fails. I will update this post to show my results. This is the last post concerning the different previous RAID drivers to use on Windows 10:

Re: Error 173 when installing chipset drivers


Try one of this versions:



Crimson Edition 16.3.2

Crimson Edition 16.7.3 WHQL

If these previous RAID driver installs with the RAID Xpert. I will then download the latest AMD RAID Chipset and try to install it ON TOP of the Older RAID Chipset. Hopefully, it will prevent the 173 error.

Hopefully, I won't have to restore my computer from my SYSTEM IMAGE if the RAID drivers screws up Windows 10 up.

I will check this information with driver engineering, I am not aware of any such limitation. I will respond back and update the thread when i have an answer.

Thanks, It would be nice to be able to install a RAID feature on my AMD Motherboard on my computer in the future without having to have a AMD GPU installed.

Just for my information, if Device Manager showed the RAID AHCI CONTROLLER active, Shouldn't Xpert2 have worked? Or is there another driver that RAID depends on besides the RAID AHCI controller driver

LoL, I wasn't expecting a answer from one of the moderators. Thanks again for trying to verify if it is something I am doing wrong or if it something with the installation.


Can both of you try this workaround and let me know if you are able to install the Raid Driver + RaidXpert software?

Extract the installer package to your desktop


Go to \Config folder and locate the InstallManager.cfg file


Open with Notepad and Add BUILDTYPE = CHIPSET in installmager.cfg file and save it


Save and close the file and relaunch the AMD Raid Chipset installer from setup.exe as normal.

Unpacked at D:\ where RAID-CHIPS driver package was downloaded using 7zip.  Went to CONFIG folder and clicked on INSTALLMANAGER.cfg file and copied from your image BUILDTYPE = CHIPSET. Saved file.




WorkaroundInstall=false   (shouldn't this be "TRUE" instead of "FALSE")




Ran setup.exe from D:\ drive. This time it took a little longer but came up with the same ERROR 173 screen saying I don't have an AMD GPU card installed.

Copied altered package to C:\download and ran Setup.exe. same result.

Ran RAID CHIPSET.exe installer normally. After getting ERROR 173, went to C:\RAID CHIPSET folder and manually added the above code to Installmanager.cfg. reran Setup.exe from C:\RAID CHIPSET folder. Same results. Error due to no AMD GPU card found.

NOTE: I didn't have my computer set for RAID. Still was set for SATA. But that shouldn't matter because the installation package doesn't go past the point of trying to detect a AMD GPU card first.


UPDATE: Copied 7zip extracted RAID CHIPSET Folder to Desktop. Made above changes. same results. Changed Workaroundinstall=True instead of default "False" . Same results. The way I see it, the installation doesn't read the INSTALLMANAGER.cfg file before first checking to see if the computer has a AMD GPU card. I even relocated the code lines to the very beginning of the CFG file to see if it will make any difference. None.


Performed the same procedure as adostrom​ with the same results. Different but the same. No components found.

Adept I

Thanks for trying those things, but I already tried installing the .msi files directly, and also with and without the GeForce stuff installed.  Sorry I didn't mention that - it could have saved you some time.

I also tried these packages:

  • Radeon-Crimson-ReLive-17.2.1-RAIDXpert-Utility-Win10-Win8.1-Win7-64Bit-Mar3 - result: Error 173
  • Radeon-Crimson-ReLive-16.12.2-SB-SATA-AHCI-Win10-Win8.1-Win7-64Bit-Jan12 - result: Error 182 - "AMD Installer cannot properly identify the AMD graphics hardware.

So - I have not found a set of the drivers/utilities that will install correctly.  It's been broken for a long, long time.


My  results was a failure but not totally. I have no idea how to set up a RAID on my computer. Which means i could have missed a step that cause the failure.

Anyway, I ran the AMD RAID Chipset. Got the 173 error.

1) tried to run the msi in the c:\AMD_RAID folder in the root directory under the folder of Packages - Drivers. When I ran it I received a message saying it was not compatible with the Windows OS even though I was using the drivers from the Folder WT64a. This happened with all the drivers in the DRIVER folder. So, I decided to install the driver forcefully by using the .INF file. It gave me a message saying that it installed Successfully.

2) Went to the APPS Folder in the PACKAGES folder. Ran successfully the RAID Xpert2 Setup.exe software inside the RAID BR folder. the RAID TR says it was for Processor 3 so I uninstalled that version of Xpert2.

3) Started the Xpert2 but gave me an error when opening. Then I remembered I hadn't set the SATA to RAID in BIOS. Restarted the computer and changed the SATA to RAID. Restarted.

4) Under Device Manager- Storage Controller, I found the AHCI RAID Controller (2012). I updated the driver and directed it to the C:\AMD_RAID folder. It indicated the driver being updated. But it was a driver from the same year as the previous driver (2012). So, I left it like that.

5) Open Xpert2 program. Got the Login. When I inputted the Logon and Password the "Submit" button was grayed out. So, I couldn't start the RAID utility. It said above the Logon "Doesn't Support RAID Xpert2".

Gave up and uninstalled RAID Xpert2 and returned my BIOS back to SATA/AHCI. I don't know if I have to reformat my drives that are going to be used for RAID or what.

So, Unless I left one or more steps off that prevented Xpert2 from recognizing RAID on my computer, AMD RAID Chipset is not compatible with any computer that doesn't have installed a AMD GPU with its drivers. It seems like Xpert2 needs the Catalyst software to work. And Catalyst doesn't install unless you have a AMD GPU card installed. Catch 22 I guess.


After further investigation, you would need to load the Raid drivers prior to installing the OS to then setup Raid. If you didn't do this during install, it would explain the error as the Raid drivers were missing during OS installation.

Greatly appreciate your help. Next time I need to do a clean install of Windows 10 I will install the RAID drivers via USB Flash drive before continuing the Windows OS installation.

  Just confused, because when I did put SATA to RAID in BIOS and rebooted, DEVICE MANAGER showed the proper RAID driver installed and working and the AMD SATA driver category was missing since it was inactive.

Adept I


I extracted the package with 7Zip, as requested, instead of using the built in extractor.  Then I edited C:\amd-raid-chipset-drivers\Config\InstallManager.cfg, as requested...








I still get the "Error 173" message.

Last night I managed to somehow find this package: amd-chipset-drivers-software-17.10rcp22-apr27.exe.  This kit has the following InstallManager.cfg:








I am going to try changing the line you suggested to "CHIPSETBUILD=true" and see if that works.  I'll report back by editing this post...


Report:  Well I did not get the Error 173 any more.  Now I get, "! No eligible components are found to install"

Progress / Partial success to report!

I went to  (previously) and downloaded the chipset driver package (no RAID drivers): amd-chipset-drivers.exe.


I edited the /config/InstallManager.cfg file to include "CHIPSETBUILD=true":








And...  It worked.  I was able to install the USB filter driver from this package (one of the issues I've been having is USB related):




So, we know we're on the right track.  Now all I want is to be able to install the updated AHCI driver (and any other chipset drivers) and I'll be happy.

BTW - I've decided not to run Windows/RAID on my second system - I'm turning it into a FreeNAS server instead, hopefully the needed Linux drivers are already included in the package (although they strongly recommend Intel-based systems I already have this motherboard, CPU, and memory).

Just did the same thing as you suggested. It also updated my USB Filter driver. Normally, when I run the installer, it completes without installing or updating any AMD drivers. I needed to do it manually through Device Manager. But this time using CHIPSETBUILD=true in Installmanager.cfg worked. It correctly updated that particular driver with a successful update.

Not sure if this is the latest guide (see chapter 6 ?)

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

Thanks I took a look at it, Especially Chapter 6 - Installation of RAID Drivers. Seems what AMDmatt was saying about pre installing the RAID driver before doing a Clean Windows OS installation.


In that case you don't need to do anything else, the ACHI driver is part of Windows already, so its not included in the drivers for Win 10.

That worked for me!!!!  I was having the same issues where I could not install RaidXpert because I didn't have an AMD Graphics Card. This was a problem because I was already running RAID 1 and one of my drives failed, and I needed RaidXpert to rebuild the array.

Using the syntax :


in the work around provided worked for me on my ASUS M5A97 LE R2.0. I was able to install the chipset driver and RaidXpert. My Logical drive is currently rebuilding!

Thanks so much and Hope this helps others!!


Thanks so much for your CHIPSETBUILD=true advice. I downloaded the chipset driver and it freaks out because it doesn't see an AMD GPU. I'm not sure why this happens when specifically downloading a chipset driver. Regardless, it works now. Not sure why they can't just add that line in there because I'd imagine anyone installing a chipset driver would be using it to.... install a chipset driver.