Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

USB motherboard ports with Ryzen 5 5600G

 I recently purchased a computer from CyberPowerPC via BestBuy with a Ryzen 5 5600G. A major issue that I have now sent the computer to the manufacturer for service FOUR times is that the USB ports in the motherboard intermittently stop working for devices I have plugged in such as mice, video game controllers, video game controller wireless receivers, etc. I have to re-plug in these USB devices for them to work again and this happens very frequently with some devices especially when I startup applications.

The manufacturer has replaced the motherboard a couple times and the power supply once without any luck. The two USB ports in the front of the PC do not have this issue.

Most recently the manufacturer service representative I spoke with suggested updating to the newest AMD drivers but he said this probably will not work since the drivers that the manufacturer uses is customized for OEM systems. I have tried updating from AMD's website and the update does not install for that reason. The service representative said AMD sends customized drivers to OEM's and that this can take a while and that they do not have a recent driver update that would help my issue.

Any advice on the issue I'm having and whether it is processor-related? Does AMD send manufacturers custom OEM driver udpates?

12 Replies

IMO, they have an issue with their motherboard, or they didn´t change it at all.

It´s pretty weird, and even though it could be driver related, they should have already fixed it.

Is it a custom motherboards made specifically for CyberPowerPC?


By AMD Drivers I assume you are talking about AMD CHIPSET Drivers that includes USB drivers.

AMD CHIPSET package are compatible with any OEM Motherboard as long as it is a AMD Motherboard and you pick the correct CHIPSET.

The OEM AMD CHIPSET drivers are the same as the AMD CHIPSET drivers except maybe it might have some extra customization to it.

That PC maker generally uses regular 3rd party Motherboard.  Download SPECCY or CPU-Z and run it. It will tell you which Motherboard you have installed.

Then I would go that Motherboard Support download page and see if they have an updated BIOS for your motherboard.

In the past AMD did have issues with USB connectivity issues with certain Motherboards which was fixed by a BIOS update.

Thank you for the help. For reference my motherboard is a Gigabyte B550 UD AC currently with BIOS version F3d Y1 (dated 11/23/2021).

I have actually already tried updating the BIOS with the help of CyberPowerPC's service reps. 

What is interesting is that they gave me a link to a list of BIOS updates on their own website, instead of downloading straight from Gigabyte's website - which leads me to think that they use custom BIOS updates. I ran this BIOS update again just to make sure my current motherboard was using the correct BIOS version. Still the same USB issues. Link to CyberPower's BIOS updates:

I then downloaded the newest BIOS version straight from Gigabyte's website (B550 AORUS PRO AC (rev. 1.x) - version F15c dated 5/11/2022). I tried updating the BIOS but when I started the BIOS update it said there was an error with compatibility - which also makes me think that they use their own custom BIOS updates. Gigabyte's BIOS updates link:

Taking another look at the BIOS update history for this motherboard, it looks like versions F12, F13h, and F13j all had fixes for "USB 2.0 devices stability and compatibility". I am wondering if these updates aren't included in the current F3d Y1 version I am using.

I have also updated my chipset driver to the latest version on Gigabyte's website.

Any other tips? Thank you in advance.



Okay it seems like the Gigabyte model you picked is the wrong Motherboard model. Which is why the BIOS you downloaded was incompatible.

Found his previous Thread at LinusTechTips that does seem to show the correct Gigabyte Motherboard which the User description is the same one you have:

This is the Gigabyte Motherboard from the above link. See if that BIOS is compatible or open a Gigabyte Support ticket and ask them if that is actually your motherboard.

Here is the BIOS download page for the Gigabyte B55M DS3H AC Motherboard:

Screenshot 2022-05-26 113352.png

This is the description of that Motherboard:

Screenshot 2022-05-26 113352.png

BEFORE downloading any BIOS you need to verify that the Motherboard above is the same one you have by asking Gigabyte Support. By the Motherboard's Serial Number they can tell you if this is the correct Model and BIOS for your CyberpowerPC computer.

EDIT: Looking at CyberpowerPC BIOS download page that you linked the above motherboard seems to be the correct model since the BIOS name at CyberpowerPC is the same model that I posted.

Screenshot 2022-05-26 113352.png

But I would verify your Motherboard with Gigabyte Support before installing any more BIOS since you can brick your motherboard with the wrong version if it should install successfully.

I don't believe the B550M DS3H AC (rev. 1.x) is my motherboard after reading through that thread. As you noted in your EDIT, the BIOS listed in CyberPowerPC's website seems to be the correct BIOS version. It appears these prebuild companies customize their motherboards in some way that the original manufacturer's (i.e. Gigabyte) BIOS versions will not install.

I have submitted a support ticket with Gigabyte and will report back my findings.

Thanks for the update. Please do report back to see if CyberpowerPC uses modified Gigabyte Motherboards.


Has the OP tried disabling 'USB selective suspend' in Windows power options ?




Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro..

I have tried disabling all possible 'USB selective suspend" but has not solved the issue. I appreciate the suggestion.

Journeyman III

I've got the same issue with a 5600G and an A520M S2H ( near new device, used for less than one month ).

Windows has detected overcurrent on external usb 3.1 port, then desactivate it with its bios access.
And nothing appears in the Event Viewer ( virus issue ??? ) except the "audit" when the USB 3.1 drives are unlocked randomly.

With the last bios from July 2022, if I restart my computer those USB 3.1 ports are unlocked and work again, but with the old bios ( compatible with 5600G ), it wa not the same, the ports wasn't unblock from this "may be" false issue.

So may be it is a bios problem.

I've checked the circuit board with a lens near the USB port, I've checked all the UBS port in Macro with my phone camera ( they look all news ).

The thing really strange is that it do not seems to be a real overcurrent issue, because I've plugged 3 high bit-rate usb 3.1 ( silicon power and transcend ), and copy movies on the 3 at the same time with no problem at all ! 

Then I've used a Maudio keystation 88 ( without the 3 usb drives ) for 40 minutes then it suddently disconnect, with an overcurrent message ( **bleep** an overcurrent with a midi keyboard ? And no overcurrent with 3 hots USB 3.1 drives at full bitrate ?! Ahah =D ! ).

My internal 3.1 USB port plugged devices are working well with no error on it ( a Doepfer USB64, a Novation MK3 mini launchpad, a UMC 1820 U-Phoria Behringer Soundcard with is powered with an AC adapter )...

The thing are getting really really strange...
when I let a lont time the 3.1 usb drives without using them with the last bios of the mobo.

After a long period of time mais be 20-30mn the usb port are unlocked/locked/unlocked... dozen of time and stay locked or unlocked in a random way, in random time duration... ( and there's no wait it's an overcurrent issue, because those usb drives are not used ). Then it's stop for 30-40mn... and ding-dong ding-dong ding-dong ding-dong ding-dong ding-dong, detected, overcurrent !

It wasn't doing this with the old bios.

The absence of message in the event viewer, also made me think of a virus issue.

So I am downloading KRD from kapersky.
I will see soon, if the problem is also on linux ( in that case it will be an hardware mobo or a bios mobo problem ).
If it do not disconnect and reconnect with an error message, that would mean that the problem, is the AMD windows driver or a virus.

Anyway I am going to scan windows with a web updated KRD.

I will post my conclusion here.

Best regard,


So I have the same issue of USB 3.1 port with KRD 18 linux ( the free antivirus scanner of kapersky ) .
The symptoms have changed a little with the last drivers.
It's not a drivers or a windows 10 problem for sure.
I think it is a bios or an hardware problem...
I was fan of gigabyte because I've never had problem with this brand of motherboards in the last 15 years, so let's see if they have solution to it.
It's not an AMD fault for sure !
For me the problem is solved here.
I've to find the forum of gigabyte lol !

Journeyman III

*The symptoms have changed a little with the last drivers  BIOS.

Journeyman III

to use amds update you got to enable the igpu I have the same usb problem and it did not fix usb intermittency

I tried the latest uefi updates for my board too