cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Nagrenol
Challenger

Ryzen Master Issue - Windows 11

Hi,

All upgraded to Windows 11, chipset has been updated.. literally everything is up to date etc etc

No issues with the exception for Ryzen Master.

Have uninstalled and reinstalled but Cannot get it to open and keep getting this error message

 

ryzm.png

I've seen other issues with people not being able to install it, but this installs without issue. Then I get this when I try to open it

Any idea's?

 

 

 

Specs if it's of any use

GPU: Red Devil Limited Edition RX 6800 XT
CPU: Ryzen 9 3900X
CPU Cooler: ARCTIC Liquid Freezer II 280
MB: Asus ROG Strix X570-E
MEM: Corsair Vengeance RGB Pro 32 GB (2 x 16 GB) DDR4-3200
PSU: Corsair HX Platinum 1000 W 80+ Platinum
CASE: Fractal Design Meshify S2
Mon1: MSI Optix MAG271C 27" 1080p 144Hz
Mon2: DELL OMEN 27i 27" 1440p 165Hz

17 Replies
elstaci
MVP

I don't see any Ryzen Master for Windows 11 to download yet from AMD download page.

In my case I had updated Ryzen Master before installing Windows 11. But I did a Ingrade Upgrade where Windows  11 was installed without losing any 3rd party apps or Windows configurations. Yet when I click on my Ryzen Master it opens without issue.

But I haven't tried updating Ryzen Master with Windows 11 installed so it could be the Windows 10 Ryzen Master is not fully compatible with Windows 11 when being installed in a Windows 11 environment. just guessing though.

Here is the latest Ryzen Master for the Ryzen 9 3900X: https://www.amd.com/en/support/cpu/amd-ryzen-processors/amd-ryzen-9-desktop-processors/amd-ryzen-9-3...

Screenshot 2021-10-07 192150.png

I guess we will need to wait and see when AMD will post a Windows 11 Ryzen Master to download.

But just in case it is a corrupt installation try using Microsoft Install/Uninstall App to uninstall the current Ryzen Master and install the program again. See if the same problem occurs.

I had it updated to the version you linked prior to updating to windows 11 and it is the only thing that doesn't work.

I totally get that certain things/apps etc are not updated to work with windows11 yet but I have seen a lot of people using it with windows 11 so it is odd.

The uninstall method you mentioned is how I do it anyway and I have tried it a number of times after the upgrade also.

cheers for the input either way.

@Nagrenol 

If you did a Ingrade Upgrade from 10 to 11 then something was changed to make Ryzen Master not work.

On my computer I did a Ingrade Upgrade with Ryzen Master already installed and afterwards with Windows 11 it continued to work normally.

When you upgraded to Windows 11 did you make any BIOS changes in the settings?

 

0 Likes

Nope, made no changes

0 Likes

Then the only thing I have left is to wait to see when AMD will post a Windows 11 Ryzen Master download, hopefully, very soon or open a AMD SUPPORT ticket and ask them what they believe is the problem from here: https://www.amd.com/en/support/contact-email-form

You did  do a Ingrade Upgrade correct? I mean you didn't do a Clean Windows 11 installation by deleting your old Windows 10 drive.

Maybe in my situation I got lucky that Ryzen Master works after upgrading to Windows 11.

EDIT: Found this tech site from this year about the exact same Ryzen Master error you are getting: https://howtodoninja.com/how-to/ryzen-master-failed-to-initialize-kindly-reinstall-the-program-fix/

Basically it says to run Ryzen Master program with Administration Rights to solve the issue.

mauser1891
Elite

Hello,

 

Please consider that the internals have changed since Windows 10, thus some applications and programs will need to be changed. Some tools have made things easier to find base settings in my opinion, but something really should be done manually. If most will take note that there isn't day when there's an issue or another with Ryzen Master, mostly version changes in which registry edits are need in some cases. Do not take offense, but merely sharing an observation.

Reference @ https://www.amd.com/en/support/kb/faq/pa-400 

<humor> I'm just an old guy who got started playing with things since ASUS P5A motherboards, AMD-233's and 100Mhz RAM with a 2.5 multiplier to run them at 250. I survived "Plug 'n' Pray" and made it through the "jumpers" ages ago with Windows 95. </humor>

 

X570 Taichi, Ryzen 3600XT, 32G of F4-3400C16D-16GSXW, XFX RX5700, NH-D15 Chromemax.black, Fractal Design R5, SilentWings 3 case fans, Intel 660P M.2 1T, WDS256G1X0C M.2 256G

@mauser1891 

This doesn't have anything to do with the OP but I was curious about your Ryzen CPU and GPU if it bottle-necked or not.

From a Bottleneck Calculator website this is what comes up with your hardware configuration:

Screenshot 2021-10-07 192150.png

0 Likes

Hello,

 

ArmA 3 UI doesn't exactly scale to well, while Guild War 2 has no issue's in 4k with SMART disabled/enabled. Please note that one can play without so much anti-aliasing, post-processing and a few other settings adjusted while playing in 4k. Now when dropping to 1080 one can make adjustments in the other direction so to speak. 

Reference @ https://www.youtube.com/watch?v=f1n1sIQM5wc 

I should state that I used to play Battlefield 3 with older hardware even for that time, yet I would get kicked as I was able to use the anti-aircraft vehicles fairly well. People didn't realize what I made up for in system performance, was compensated by the fact I could spot and make out the aspect changes for OPFOR helicopters by using a 42" display back then. They would cry that I was using an aimbot. If I go back farther I'd drop a running target at 500 meters with my M21 in Operation Flashpoint 10 years ago. Too me it's just playing smarter, not harder. Situational awareness even helps when an opponent becomes overconfident and charges in Guild Wars 2 in which one can merely jump and glide off a cliff, yet they fall to their death.

So at the end of the day, I've never concerned myself with "bottlenecks". Yet I do record my base scores and temperatures in order to check them. This I do especially for temperatures as I may need to change my CPU or GPU's thermal paste. 

X570 Taichi, Ryzen 3600XT, 32G of F4-3400C16D-16GSXW, XFX RX5700, NH-D15 Chromemax.black, Fractal Design R5, SilentWings 3 case fans, Intel 660P M.2 1T, WDS256G1X0C M.2 256G
0 Likes

I just mentioned it because I have a similar setup but slightly older GPU.

My 3700X is bottlenecked quite a bit by my Nvidia 1070.
0 Likes

Hello,

 

Regardless of anything else is that your hardware is up to the task of what you need to do at the end of the day as defined by your software. I really fall into this category, just as when I got back into playing a few games my budget determined what I could start out with. I'd love to have had the i7-920 at the time, but it was $1,000 USD and there was no way I was going to pay that much to play a game. So I made due with a FX-8350 with 32G DDR3@1600 and couple of matched MSI version 7770's. I've even made due building a machine from 7 different P4's without Windows or Office to take some online classes, in which I took a couple of soup cans, 12g copper wire and regular household cable to get online from a access point that was 450 meters away across a channel with a linux distro on it. Keep in mind that I needed the use of tools like Handbrake and a few others to do what I wanted. Later on it was great to have dual drives to do transcoding and such, as a file could be read, processed, then written to a second drive. Overtime I've also played with things like Radeon RAMDisk and PrimoCache and found them to be interesting how they performed with hard drives, to hybrid's and M.2's in different configurations. To be truthful, I didn't like StoreMI and won't install it. Nor will I use or install Ryzen Master, because I can merely take the time to find out what will work for my silicone by doing things in the BIOS. I'll probably play with Win 11, but I'll wait a bit longer as Win 10 Pro works well enough for my games. I run a few benchmarks for amusement, but then I'm not worried about bottlenecks at all as I accept that I'm going to get whatever performance with what I make due with. I'm also watching review content provided by Jay, Steve, Linus, Paul and Jim for example. Cheers 

X570 Taichi, Ryzen 3600XT, 32G of F4-3400C16D-16GSXW, XFX RX5700, NH-D15 Chromemax.black, Fractal Design R5, SilentWings 3 case fans, Intel 660P M.2 1T, WDS256G1X0C M.2 256G
0 Likes

There should be a thread that covers on how to remove them from the Registry and thus be resolved, else one could probably find a visual how-to tutorial.  AdvancedMD

0 Likes
cindyroberts
Journeyman III

I've had this issue since Windows 10. What gets me is that it isn't even installed.

0 Likes

Hello cindyroberts,

 

Ryzen Master will residual elements in the Windows Registry from a previous installation in the past. There should be a thread that covers on how to remove them from the Registry and thus be resolved, else one could probably find a visual how-to tutorial.

X570 Taichi, Ryzen 3600XT, 32G of F4-3400C16D-16GSXW, XFX RX5700, NH-D15 Chromemax.black, Fractal Design R5, SilentWings 3 case fans, Intel 660P M.2 1T, WDS256G1X0C M.2 256G
0 Likes
Matt_AMD
Community Manager

You want to try downloading this tool from Microsoft which can help to resolve the error you experience. 

https://support.microsoft.com/en-us/topic/fix-problems-that-block-programs-from-being-installed-or-r...

 

Alternatively, you may want to check you are using the latest version of Ryzen Master Tool. https://www.amd.com/en/technologies/ryzen-master

Demitros
Journeyman III

 I'm having the exact same issue. Nothing I tried worked then I stumbled on no ryzen master win 11 compatible. I resorted to manually O.C. though bios. Hoping to see an updated version in the future:/

0 Likes

It just randomly worked about 2 weeks ago

Same download (which is the latest) as it hasn't been updated in a bit, strange stuff

Has nothing to do with Windows 11. Windows 11 for the most part is still Windows 10 with a new skin. You more than likely have either done one of two things:

A. You ran a windows debloat script (they're never reliable and cause more trouble than they are worth, sorry Chris Titus) that turned off your workstation service. Run services.msg. Scroll down to Workstation and change it from Manual back to Automatic and leave it alone.

B. You turned on virtualization to try out the amazon android store or you were playing with some virtual machines/sandboxes. No worries we can fix that too. Run msconfig.exe and scroll down to Virtualization-Based Security. If its on, open the CMD prompt as an admin and type bcdedit /set hypervisorlaunchtype off. You can also reverse that as well to turn it back on if you for some reason feel the need to run android apps in Windows. Regardless VBS can not be on with an AMD overclock for whatever reason. After that reboot and enjoy.

Screenshot 2022-02-09 214600.png

Edit: Something else you can try if that doesn't work, is searching "Turn Windows features on or off" and make sure the following options are disabled:
Microsoft Defender Application Guard
Virtual Machine Platform
Windows Hypervisor Platform

Distro: Manjaro Linux - Kernel: 5.15.19-1 - RAM: 32 GB - GPU Driver: 4.6 Mesa 21.3.5 - GPU: AMD (PowerColor Fighter Radeon 6600 8gb) - CPU: AMD Ryzen 9 5900X 12-Core Motherboard: Asus-X570-Prime
0 Likes