Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

Ryzen 3 2200g driver crash


I am having some issues with the on board graphics of the ryzen3 2200g.

When I first built that PC I by thinking that for now i will use the on board graphics and later i will upgrade it to discrete GPU. But for some reason whenever i install the graphics driver after the bios  post logo i dont see any thing the only way i could boot into windows is by going into safe mode and then uninstalling the graphics driver using DDU.

The method i have tried

  1. Updating the bios
  2. Installing drivers manually
  3. Updating windows
  4. Installing chipset driver first then the graphics driver and vice versa.
  5. Using my HD led TV with HDMI to check if VGA has some problem .

I am really frustrated idk what to do next.
I had somehow managed installing the drivers properly by installing it manually but after 3-4 days the problem came again and now I am unable to install the drivers even by installing it manually.
Please some one help.

This is m,y first time using AMD stuff and i am having a bad experience. 

13 Replies

Hi, sorry to hear about your troubles. You may already be using the correct driver and your issue lies elsewhere, but one of very common issues that happens with these APU's is people downloading the GPU driver instead of the APU driver. Sorry if you already have the correct one just wanted to point out this might possibly the issue.

On the driver download page make sure you are getting your driver from here and pick what is correct for your system, desktop or mobile:   AMD Drivers and Support for Radeon, Radeon Pro, FirePro, APU, CPU, Ryzen, desktops, laptops 


 Then do a clean install of the driver.

If that doesn't help or that is the driver you already loaded and you did already do a clean install, you can report back here, you might then also want to open a support ticket with AMD support:

Online Service Request | AMD 

If you report back here because this didn't work. Please supply complete hardware configuration information and Windows version such as 1809  please, as we will need to likely dig a bit deeper to help. 

When posting a new question, please provide as much detail as possible describing your issue making sure to include the relevant hardware and software configuration.  
For example:

  • Issue Description: [Describe your issue in detail here]
  • Hardware: [Describe the make and model of your: Graphics Card, CPU, Motherboard, RAM, PSU, Display(s), etc.]
  • Software: [Describe version or release date of your: Operating System, Game/Application, Drivers, etc.]

I have the correct drivers but it does not i I have the correct driver but it doesnot work

my Pc specs

APU- Ryzen 3 2200g

MB-  Gigabyte b450 M gaming

Ram- Corsair vengeance ddr4 3000mhz 16gb kit 8x2

PSU- Coolermaster 550watt

SSD- kingston 240gb

HDD- Segate 1tb

If the AMD clean install alone isn't helping I can really only think that it is time to enlist help from AMD tech support as already linked above and I would also ask  Gigabyte your motherboards tech support on any additional ideas. 


Before going into the next steps. I want you to disable some thing in Windows that is know to interfere at times. Honestly you don't need it and IMHO it more a pain than it is worth. If this helps you and you want to re-enable it you can after the driver is loaded and the machine is restarted.

Disable Windows 10 Fast Startup. You can google how to do it.  Fast startup caches all kinds of old information that is know to introduce old driver info corrupting new installs.

Now lets try one more attempt at installing on a clean slate using a 3rd party utility that often helps better than the AMD clean install.

Make sure you have the driver for the APU downloaded not a GPU driver as I pictured before.


Download and run DDU from wagnardsoft_com. You will run this from safe mode while disconnected from the internet. Just follow the included instructions.


Re-Install the driver while still disconnected from the internet. Choose clean install if available. If not, that is good as DDU did its job fully.


Restart your machine.



If that doesn't help and tech support does or doesn't offer a solution, reply back here with what helped please and  if nothing we will try and figure out a next step. We users try not to give up on finding solutions but our resources are really no better than yours.  DDU works magic a lot of times so give it a go.

Good Luck!


I should have mentioned it isn't impossible that none of this is software related. It is always possible it is hardware. If you do all the above I would suggest if you have another hard driver available for testing that you disconnect your current drive and load Windows to a clean install and see if you are getting the same issue.


I did all the stuff and but none of them worked.

I also swapped the cpu with another 2200g of my friends but it failed it.

I tested the motherboard it was fine too.

Idk whats causing this issue

Note I also tried the latest driver 19.4.1 but had same result

i had tried it before but i will give it a go again

Adrenalin 19.4.1 is available, try that one


Triws that too but it didnt work


I'm in the same boat, have you had any luck with anything? Clean win 10 install and used ddu before installing several times, did an overnight mem test to make sure that wasn't the issue. No idea what to do now.


Okay so I think I just got it on mine. Asrock b450m mobo w/2200g and 2666mhz gskill ram.

1. Downloaded and put instant flash 2.2 bios update onto usb stick

2. I installed the chipset from the mobo disc

3. updated to newest chipset build from amd's website

4. Installed newest igpu drivers from AMD's website

5. Same issue, black screen after boot/crashing instantly at desktop

6. Did instaflash update on bios to 2.2

Whether or not this is the way to do it idk, but it worked. Boots to desktop and doesnt crash anymore, running on Vega 8! What a pita lol


No I did everything but it didnt work except downloading the older driver

Adept II

By the way I fixed the issue by downloading older driver of September 2018. But beyond that no drivers works Idk why

Journeyman III

I am having similar issues, currently I am using a dedicated GPU rather than Onboard APU. 

This is not ideal but I don't have time to spend time on this broken platform. AMD should provide more stable software before releasing products