Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

RX570 CODE 43 Windows 10


OS - Windows 10 Pro

Processor - Intel Core Pentium G4600

Motherboard - MSI H110 PRO-VH PLUS

GPU - PowerColor AMD Radeon RX 570 Red Devil

Yesterday i planned to clean and replace the thermal paste of my RX. But when i put them back together and placed it on a fresh installed windows 10, it shows me error "CODE 43".


Also, AMD software tells me that there is no detected Graphics card currently installed on my system. But when i use the GPU Z software....


Some data are not showing also there are some weird sensor datas...

7 Replies
Adept I

Same problem here.. after replacing an older GPU with an MSI Radeon RX570, complete deinstallation of previous drivers and installation with latest AMD drivers I got the same error message. My system: MSI P55-GD85 motherboard with Core i5 processor.

Any luck with solving the problem so far?

Journeyman III

Had this problem, in my case it's a bit different, I got a 2nd card, and it probably was used for crypto currencies mining. It turn out the bios of the card is modified, so AMD's driver no longer work with it, all I have to do is flash the original bios came from the manufacturer. You guys can find guides online on how to flash GPU bios, for AMD you need ATI flash which can be found here: Download AMD/ATI ATIFlash | TechPowerUp​ and the original bios of your card can be found on here VGA Bios Collection | TechPowerUp , remember you need the exact one for your card configuration, include series (ARMOR, OC, ROG, etc...), card manufacturer, GPU, memory capacity, memory manufacturer. You can search on google if can't find it on the website linked above. Good luck.

Adept I

Thanks for the info! Mine is a used card as well so this could well be the cause. I contacted the vendor to ask. Is there a way to check which bios is installed ? Thanks!

Adept I

I finally got the problem solved by running a patch called atikmdag-patcher-1.4.6 (found through google on a mining forum).

It was advised by the vendor of my used card, indeed used for mining, but not sure if it was related to a changed bios. I just checked the patch for viruses and ran it, without quite understanding the working of it. But no longer code 43 and card runs fine now.

i have had the sam problem, but it had a working 570 in the same system, and had 2 cards work and 4 that dont. not sure about a couple cards, but at least one that fails was bought new. any advice appreciated. i have 5 not working cards right now. ty.

Journeyman III

Hi! I'm having this same problem with the RX 570. Did you do that whole BIOS thing someone mentioned or just the download? Also was where you got the download patch?


Have the same problem (code 43) and flashed my bios with all the correct methods I learned from various resources on here.
 When I got to the program used to install the new vbios, I found that it was, indeed, one digit off of the one that I downloaded from techpowerup. 
The drivers still wouldn’t install with the original vbios, however, so I flashed it back to what it had when I received it.
 I tried that pixel clock patcher (with the unofficial vbios) and, for the first time since I installed it, my card worked and I was even able to start a couple games. Previous attempts at the pixel clock patcher made my screen freeze within minutes of boot up. 
I turned my pc off for an hour (squid game, wild) and, to my dismay, it froze again within minutes. This was after changing the name to include “-bios” at the end of the program to just install the bios signature. 
I wiped my ssd and reinstalled windows and called it a night. I know the card is capable of working so I won’t be giving up that easily. Let me know if y’all find a solution.