Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

Radeon Software: GPU Utilization 100% bug

Occurs when the following settings are made in some video games.
Remains at 100% usage even after exiting the game program.

Tom Clancy's The Division: Options - Video - Enable DX12 Renderer. - Yes
Tom Clancy's The Division 2: Settings - Video - Enable DX12 Renderer - Yes



This can be fixed by exiting AMDRSServ.exe, but this is a bad solution.


Adrenalin 21.9.2
Radeon RX 580
Windows [Version 10.0.19043.1237]
Core i5 10400

1 Solution

AMD Software: Adrenalin Edition 22.11.2

AMD Soft.png

Ryzen 5 5600; ROG STRIX B550-F GAMING; Sapphire RX 6600 Pulse; G.Skill Trident Z 3200GHz CL14 /2x8 Gb; Seasonic Focus-GX-750W 80 Gold Plus; LG 27GR75Q-B QHD; Windows 11 Pro 23h2; Kingston KC2500 250Gb M2. /Kingston NV2 1TB M.2; SSD Crucial MX500; HDD WD Blue - 1T.

View solution in original post

175 Replies
Adept II

Adrenalin 21.10.2
The Division 2(Direct3D 12)

The same problem was also observed in Ghost Recon Breakpoint (Vulkan).

new driver (22.7.1) but the problem is still here


@chuil, I think it is still under "known issues" from the release notes for RX 570 cards, although I believe it happens to at least all Polaris cards.

I know we all feel it should have definitely taken priority to have been fixed by now, but at least AMD is "taking note" of it, which is means it will likely be fixed it some point, whereas there are other issues they do not take note of at all, or disregard evidence thereof.

"which is means it will likely be fixed it some point,"

I wouldn't bet on that. I think the enhanced sync issues are under "known issues" for more than a year now.
They gonna "fix it" by ignoring it for so long till people will give up on it and either moved on to a new GPU.
I mean i always preferred AMD.. if performance was on par.. i'd choose AMD over Nvidia or Intel (CPU)
Next time if i'll get the same performance/price i'll go for Nvidia or Intel instead that's for sure lol.

Hey @nonametoday ,

I get what you are saying, to be honest I think they are looking in the wrong places or not looking at all for the fix with Enhanced Sync, I actually think it is a physical hardware issue that somehow passed through the QA process in manufacturing, and it is probably something they are not bypassing.

For example, I have in issue with my Radeon/FreeSync/Monitor setup where the display will go black almost everytime when I reach about 70-77C on my RX 480 for a second. On top of this, even more persistent is that my display (AOC 2460G5) is very unique in that it supports LFC at 75Hz with FreeSync range of 35Hz-75Hz, but when a game such as Crysis 1 forces 50Hz the Radeon driver freaks out with audio crackles and black screens when the frame-rate drops below 50FPS since I've had the display and as soon as I disable FreeSync the latter issue disappears.

This indicates to me that either some hardware issues are passing through VESA standards, or AMD does not know or dedicate time to look into the issue.

I must admit, someone wanting to jump onto team Ryzen/Radeon now will have a good time, but for a 2013 switcher like me, AMD has been way more expensive than it would've been to save up for a high-end combo of today. I had to now upgrade my AMD CPU three times to get the most out of my RX 480, first AMD CPU was FX 8350 (in 2016), then R5 1600 (in 2019), now R5 5600 (in 2022) and now I am starting to experience what my RX 480 should've been like as advertised in 2016.

Just hope my RX 480 lasts, since I have been taking steps to improve it's thermals within the last three years, I cannot afford to buy a new GPU to, although I like the RX 6700XT.

Yep, still getting this issue even in October, almost a full year after the first post in this thread. Ended up just reverting to a previous patch since I guess AMD just doesn't care about the 590 customers. Definitely swapping to Nvidia next GPU.

Adept I

I have this problem too, after playing Doom Eternal the gpu mantains at 100% all the time (RX 570). It looks like a Polaris exclusive bug.

I also have this problem when using a Vulkan API game (e.g. Doom 2016). DX9/11/12 games don't have that problem. Using a RX 470 with Adrenalin 21.12.1.

Does anyone knows how to fix it?

This BUG is happening, AMD knows this, I've tried contacting them via support email, after long ping-pong they just ignored me.

Okay, problem lies here: GPU video encoder gets stuck while playing certain DX12 and all Vulkan titles.
I have several workarrounds:

Method 1. (100%effective): Exit Vulkan/DX12 game that causes 100% utilisation bug. Then on desktop record couple seconds video of your desktop with Radeon Re-Live.
GPU will revert to idle state.

Method 2. (95% effective): install GPU-Z. Right beside Bus interface (PCIe) there is the question (?) mark. Click it and side window will appear. Then start render test in fullscreen. Wait couple of seconds for Radeon software logo to appear on top right corner of your screen. Press ESC and check your GPU clocks/usage.

Method 3. (100% effective): temporary launch an DX11 game and exit.

Method 4. : Re-install radeon drivers without Radeon Relive recording software (works 100% but you loose gameplay recording capability). Radeon Re-live IS THE CULPRIT OF THIS, especially on older polaris cards.

Method 5. -Ditch AMD (ex Ati) Radeon brand get nVIDIA card (you'll be da*mn right that my next GPU will be from nvidia, I'm tired of this ATi sh*t since radeon 9500 pro back in 2000's. AMD/ATi drivers are simply I-N-F-E-R-I-O-R, what you save in $, you pay with headache's). When nvidia f*cks something up, they driver R&D team fix it in no time, simply because their company invest more money in driver development and have more qualified manpower at their disposal. Nvidia doesnt bother with updating it's "old-style" control panel (what aint broken don't fix it philosophy), they bother at performance and bugfixes.

Thankyou So much I want to give you a big smooch


Thanks for all the posts folks, we are investigating.

Well, I'm waiting until they fix it, then I have to use the minimum driver, and there is no record and no screenshot and the fps meter is missing. Although the fps counter also works every once in a while, make it steam, constant when the game is turned on

killing the process mentioned here in the thread also works or just starting another game. Though i agree it's super annoying.
Also i think it's not just that the GPU  Utilization that goes up to 100% I think "clocking" doesn't really work in these games as it should. I mean even in the Menus the games would run at maxed gpu-clock. Usually you'd expect it to run at lower clockrates.
I sure hope this gets fixed within the next driver. I mean it's so easy to reproduce they (AMD) should be able to find the Cause pretty fast.

Adept II

I am also having this problem. RX 590

Ryzen 5 5600; ROG STRIX B550-F GAMING; Sapphire RX 6600 Pulse; G.Skill Trident Z 3200GHz CL14 /2x8 Gb; Seasonic Focus-GX-750W 80 Gold Plus; LG 27GR75Q-B QHD; Windows 11 Pro 23h2; Kingston KC2500 250Gb M2. /Kingston NV2 1TB M.2; SSD Crucial MX500; HDD WD Blue - 1T.

Try Adrenalin 21.8.2 Recommended (WHQL) from 2021.
You can still find those drivers here:

Unfortunatelly, that is the last driver revision that doesn't have this weird bug. I've tested it on my RX570 4GB. AMD F***d something up.

ahhh does this still work or not? just asking cause I might use that version and see if it solves my problem with my rx 570 being 100% utilization after playing rdr2.


21.10.2 is more recent and 100% does not include this bug.

Weird how AMD prioritizes the optimization of 6K series above all, and does not spend manpower to fix this issue for months now..

Big sad.

ryzen 5600 + 6700 XT
Community Manager

Thanks for the posts, we are investigating this issue and I will update the discussion as soon as I have more information. 

Just want to add that Doom Eternal has the same bug. I already sent a report as well.

I am glad to see this. Also, I want to add that a possible solution to the bug is to kill the radeon host service process, forcing it to restart.

wwe 2k22 is another game suffering from this issue (but not always).

Do you have any specific steps to follow that can help to reproduce the issue consistently in any specific game?

It would also be helpful if folks could post the following information about their system, for example:

  • AMD Graphics Card Make & Model
    • Radeon VII
  • Desktop or Laptop System
    • If a laptop, Make and Model of the Laptop
  • Operating System
    • Windows 10 64bit 1909 Build
  • Driver version installed
    • Radeon Software Adrenaline 20.10.1
  • Display Make and model and connection/adapter in use, resolution, and refresh rate.
    • Samsung UE32850R 3840x2160 @60Hz Active DP to HDMI adapter
    • One line for each display device connected
  • CPU/APU Make and model number
    • Ryzen 5 5600X
  • Motherboard Make & Model + Bios Revision
    • Asus X570 Prime Pro BIOS 2802
  • Power Supply Unit Make & Model + Wattage
    • Seasonic Focus 750W Platinum
  • System Memory Make & Model + Frequency
    • GSkill Trident Z RGB 3200Mhz CL14 2x8GB

I can reproduce it in 99% of cases by just starting Doom Eternal once. There isn't much more to do. Just firing it up causes the Utilization (and GPU Clockrate) to get stuck at 100%.

RX580 (also have a RX570 in another System with the same Results)
Windows 10 21H1
22.3.2 (happend as well under 22.3.1 and maybe even before)
Display LG 24GL600F 1920x1080 / 144hz /DP
Ryzen  5 5600X
Seasonic Focus GX 750W
Crucial Ballistics 3200Mhz 2x8GB

So I have the same problem on the RX 580 in any game on Vulkan and dx 12. games like Red Dead Redemption 2, Cyberpunk 2077, Shadow of the Tomb Raider, fixes if you run some video player in full screen, or restart the computer. in the minimum driver this problem is not present.

I noticed that this occurs when applying the logo first game, or overlay, if you turn off the overlay overlay then everything is fine but may reappear

my computer
// OC Windows 10.
// Motherboard: Asus TUF B450M-PLUS GAMING
// Processor: AMD Ryzen 5 2600 3.4 (3.9) GHz
// Video card: Asus Radeon RX 580 8GB DDR5 DUAL OC
// RAM. 16 GB
// Hard disk: 2 TB.

CPU: AMD Ryzen 5 2600X

Motherboard: B450 Gaming Pro Carbon MAX WIFI
AMI BIOS Update to AMD ComboAM4PIV2


Ram: 16Gb DDR4 G.Skill Trident Z 3200GHz CL14

PSU: Seasonic Focus-GX-750W 80 Gold Plus 

Monitor: LG 27GL650F UltraGear 144 Hz FHD (1920 x 1080) DP-HDMI
Display Port ● v1.4

OC: Windows 11 Pro OS Build 22000.556

Driver version installed: Radeon Software Adrenaline 22.3.2

Red Dead Redemption 2 (sorry for the video quality)

Ryzen 5 5600; ROG STRIX B550-F GAMING; Sapphire RX 6600 Pulse; G.Skill Trident Z 3200GHz CL14 /2x8 Gb; Seasonic Focus-GX-750W 80 Gold Plus; LG 27GR75Q-B QHD; Windows 11 Pro 23h2; Kingston KC2500 250Gb M2. /Kingston NV2 1TB M.2; SSD Crucial MX500; HDD WD Blue - 1T.

temporary solution, restart process - AMDRSServ.exe :

1. Create .bat file:

start " " C:\Windows\System32\taskkill.exe /F /IM AMDRSServ.exe

2. run as administrator after playing



Ryzen 5 5600; ROG STRIX B550-F GAMING; Sapphire RX 6600 Pulse; G.Skill Trident Z 3200GHz CL14 /2x8 Gb; Seasonic Focus-GX-750W 80 Gold Plus; LG 27GR75Q-B QHD; Windows 11 Pro 23h2; Kingston KC2500 250Gb M2. /Kingston NV2 1TB M.2; SSD Crucial MX500; HDD WD Blue - 1T.

  • AMD Graphics Card Make & Model
    • MSI RX 470 4Gb Gaming X
  • Desktop or Laptop System
    • Desktop
  • Operating System
    • Windows 10 64bit 21H2
  • Driver version installed
    • Radeon Software Adrenaline 22.2.1 but it also happens on 21.12.1
  • Display Make and model and connection/adapter in use, resolution, and refresh rate.
    • LG 22EA53 @60Hz DVI
  • CPU/APU Make and model number
    • Ryzen 5 5600X
  • Motherboard Make & Model + Bios Revision
    • Asus Prime B450M/BR - BIOS 3205
  • Power Supply Unit Make & Model + Wattage
    • Corsair GS600 600W
  • System Memory Make & Model + Frequency
    • Hyperx HX424C15FB/16 2400Mhz 1x16Gb DDR4


The problem occcur everytime I play a Vulkan API game like Doom 2016, Wolfenstein 2, Rage 2. Just start the game and play for some minutes. After quitting, the GPU usage and clock maintains at 100% usage and the only way to fix it is killing the AMDRSServ.exe proccess.

I have a RX 570 and same things happens with me after i quit horizon zero dawn, clock stuck at 1340mhz.

If i run heros of the storm right after that and quit, clock goes back to 300.

Been since March since i've seen a update on this, Its now August. Is this issue ever going to be fixed or do I need to start buying Nvidia cards again. Last time I left Amd it was do to driver issues that nobody at Amd seemed to care about fixing. 


Glad to see that the problem is now under "known issues" in the driver changelist

yup and it just took some months...

Me too glad that the problem is now under "known issues" in the driver changelist.
They finally get the "message" for crying out Loud.
Btw, that .bat file fix in previous comments works. Open notepad, copy this text:  
start " " C:\Windows\System32\taskkill.exe /F /IM AMDRSServ.exe

Save as text file, then close notepad and change file extension from .txt to .bat
Right clik on it and launch as an administrator. Big thanks to doncor7 !!!!

How is this still not fixed in the latest drivers. Wow.. just wow.

I also have exactly the same problem. RX 570 4 GB Sapphire Pulse Mini ITX. The problem is occurring since driver version 21.9.1 and it continues in almost every subsequent driver release to this date. The last driver version without this problem is 21.8.2. For me this issue appers after playing Red Dead Redemption 2 on Vulkan API. AMD please fix it. This is not a minor issue, but a serious problem existing for many, many months.

I can add another issue that hardly anyone might notice and which might be also related to this.
When playing older games for example Unreal Tournament 2004, Quake 3 and the original Stanely Parable. Sometimes Windows will get very choppy afterwards. You will notice that when moving around a window with your mouse.
I tried killing every AMD process however that didn't resolve the issue (killing the AMDRSServ.exe doesn't work  this time) What's helping (just like with the Utilization Bug) is starting another game..after that the issue will be gone again.

@nonametoday I experience the same exact issue. What works is pressing Ctrl+Shift+Win+B to restart my graphics driver, it takes 2 seconds. Give it a go next time and see if that works - if so then others could be helped with it. 

But it's still really annoying. By the way I went back to 22.1.2 WHQL for a while to test and it didn't happen once.

Kinda could reproduce it, it's enough to fire up Unreal Tournament 2004 and just quit it as soon as you arein the menu lol. Once again dragging windows was choppy.. clicking on the windows button will bring up the menu also kinda choppy. However performance isn't really affected. There isn't any process that uses high CPU or GPU Utilization, nor is RAM filling up. Only windows Menus/Windows feel really choppy.  Restarting graphics drivers as you discribed did indeed fixes the problem.
But i also think it's worth mentioning again that also just starting another game will fix it as well.


Ctrl+Shift+Win+B does NOT restart the graphics driver. It does appear to discard the desktop surface buffer and re-create the allocation from DWM (Desktop Window Manager).


Glad to hear that it worked for that particular problem, even if a permanent solution is preferred.
Not sure it is a GPU driver issue, if it is an old Direct3D game from 2004 it could very well be a problem together with a modern operating system.

You can try to install DirectX End-User Runtimes from Microsoft:

Another thing to try is to enable Microsoft DirectPlay, to be able to play some old games:
Best regards from Sweden