cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

miwo1604
Adept I

Problem with Vega11 Ryzen 3400G Graphic drivers

Hello.

Completely new system.

New MSI B450M Gaming Plus Mainboard

New Ryzen 3400G processor.

New 16GB Ram and SSD and nowthing else. 380Watts Antec Power supply.

At first everything works. Flashed new Beta Bios from MSI. Works. Windows 10 Pro Clean install okay.

Installing chipset driver... display is blue and staying blue. System is booting but no signal to Display in Windows.

Only solution is to restart windows in safe mode and unistall Vega 11 Diplay driver so sytem switches back to Intel drivers.

Tried the newest catalyst from AMD website.

Tried to install all Windows updtes first and then the driver... Bluescreen.

Tried to unistall Intel driver first and the Vega11 driver.... Bluescreen.

Tried another display with DVI... no Signal in Windows.

Tried old MSI Bios (was compatible with 3400G!) and... Bluescreen.

Inbetween I have done around 6 Windows10 clean installs. Sorry AMD but actual launch for these new processors is a little messy.

38 Replies
zoley
Adept I

Hi,

Somewhat  similar issue with a similar system.

I have a Gigabyte B450 I board with latest bios (F40) and a Fractal Design 450W PSU as differences and the rest (Ryzen 5 3400G, 16GB ram, m.2 SSD) is the same, nothing else. I have done a few clean W10 installs myself and once the integrated graphics starts working I get blinking lines, blinking black screen, flashing static on screen and sometimes missing a colour component from the image on screen. Funny enough, none of this happens before I install any drivers or even after that when the GPU load is in single digit.

Now the big question is whether you and/or I have a defective vega 11 in Ryzen 5 or is it something else?

Matt_AMD
Community Manager

Please could you confirm which AMD Chipset driver version you are you using and which AMD Display Driver version? Did you obtain these drivers from the AMD website?

What is the make and model of your display and how is it connected to the motherboard?

0 Likes

Both drivers were downloaded directly from AMD at the time of the post. The chipset driver is still the same offered there, but AMD has released a new version for the igpu just today/yesterday (dated to the 16th but haven't seen it yesterday) and that is listed as 19.7.2. No idea why is the current version numbered lower than the one that was available from the 8th for a week, but the versions in the reddit post were copy-pasted from AMD's website at the time of writing.

The first TV is Toshiba 49U5766DB

The second TV is a Tesco branded one with model number LED 47-E271 (product code TA47C187BFTCUGR01)

The monitor is a Viewsonic VX2270SMH-LED

Connected with HDMI cable (standard quality, tried 3 different ones, didn't seem to matter).

OS: Windows 10 pro 64bit

0 Likes

hi 
even i was facing the same problem when i have installed the latest version of adrenalin 
but
yesterday when i have wipes my boot drive and then i have freshly installed windows 10 
after that i have no problems please just dont install the adrenalin software 

hope it may helps you
thank you

0 Likes

Hello all o/

I read through this thread trying to find a solution to my problem too = no stattering or flickering, just random (?) freezes and BSODs. I've collected all your suggestions and whatnot and if i haven't missed anything, they are:

  • try a different monitor/tv screen set (the newer the better, it seems)
  • try different memory (RAM) frequencies; ftr. i found out that ALL mobo manufacturers these days have extensive tables listing known compatible RAMs for each model o.O
  • AsRock mobos seem to be more compatible with said APU than those of MSI
  • AMD driver 19.7.2 seems to have worked best - for some of you at least 
  • disabling CSM in BIOS and enabling UEFI 
  • using a stronger PSU - at least 2 of you suggested 1000W

I haven't tried any of the above yet so I plan to start through this list from top to bottom and tell you what works and what doesn't, for me. My son's setup  is as shown in the signature below. I got him 2 RAM modules but found early on that his PC was severely unstable when using both of them, so I took out one thinking it was defective... Now that I ready your suggestions I think that it might be an insufficient PSU issue. We'll see

Build:

mobo AsRock B450M-HDV R4.0 Retail, RAM G.Skill F4-3200C16D-16GIS (2X8GB) AEGIS Dual Kit, PSU Thermaltake 650W Gold, Samsung EVO 500 SSD.

0 Likes
didi_82
Journeyman III

Hi. Same here. Ryzen 5 3400g with GB B450M DS3H. System doesn't boot after adrenaline 19.10.22 driver. Please help!

0 Likes

Where did you get driver version 19.10.22 from?

0 Likes

I think we all obtained the drivers from AMD official website. Display and chipset. 

0 Likes
miwo1604
Adept I

Well. When readig all the other forums with massive issues I just suppose AMD and the board Partners just simply released a not finished product with really bad bios and drivers...

0 Likes
kingfish
Volunteer Moderator

You all should report it to AMD > Online Service Request | AMD 

0 Likes
miwo1604
Adept I

Hello.

Already contacted MSI and AMD customer support two days ago. Now waiting for reply. Today I have ordered an ASROCK B450M Pro4 with new bios. Will test it and if it will work the MSI board goes straight away back to the dealer.

0 Likes

Hi. Please let me know if you solve the problem changing the motherboard.

0 Likes

tell us please, what happened, new board solved the problem?

0 Likes
zoley
Adept I

I managed to narrow my issue down to AMD driver incompatibility with TVs. Details in my reddit post.

https://www.reddit.com/r/AMDHelp/comments/cduxbd/3400g_in_b450_board_igpu_issue/ 

Matt_AMD
Community Manager

Please could you confirm which AMD Chipset driver version you are you using and which AMD Display Driver version? Did you obtain these drivers from the AMD website?

What is the make and model of your display and how is it connected to the motherboard?

0 Likes
prashantn
Adept I

Black Screen Appears on Monitor Because of Graphics Driver

I am facing the same problem. How many days do I have to wait for the next update of Graphics Driver ? Is there any other way ?

0 Likes
prashantn
Adept I

Hey Friends, I just Installed the new graphics driver update released on 16th july 2019, 19.7.2 patch. Its working fine now. No more problems with black screen. All set.

miwo1604
Adept I

SOLVED!

Hello. Problem solved with new graphics Drivers from 16th july. 

Still not happy with the MSI B450M Gaming Plus. G.Skill AEGIS F4-3000C16D-16GISB Memory 16GB DDR4 ( 2x8GB ) on the board. Max speed is 2400 or I get Ram error in Windows or no boot. Problem is here probably with Ram/Board compatibility. 

Will test the Asrock when it will be delivered and see which board will suit me better

miwo1604
Adept I

Okay summary:

Ryzen 3400G, MSI B450M Gaming Plus. G.Skill AEGIS F4-3000C16D-16GISB Memory 16GB DDR4 ( 2x8GB ).

MSI bios is completely unstable, you need newest graphic drivers from AMD from 16th July to make it work even slightly. MSI support is.... well lets not talkabout it but horrible is nicely meant considering the total failure.

SO:

New board Asrock B450M PRO4 -> WORKS! Stable (MSI didn´t do it) and Ram speed at 2933. 3000 was not stable and caused bluescreens sometimes.

MSI was only slightly stable at 2133 Ram speed and still crashed sometimes.

Thank you Asrock.

0 Likes

Asrock B450M PRO4 is ready for ryzen 3400g

without updating the bios?
0 Likes
michael_zhou
Adept I

I have the same issues, screen goes black midway installing the newest driver. Just want to know if did you use express or custom installation?

0 Likes

Hi.

Express or custom should not make any differences. Please install it with Ram Speed not higher than 2133. later you can try Ram stability tests. With new driver I hadn´t any issues any more. But like I have already written: MSI Board was never really stable. Beta Bios probably bad. Changed to Asrock and it is far better.

0 Likes

Thanks - I've give the above a go. I was debating to get a Asrock or Asus TUF B450M for the new build, decided to get the Asus in the end.

0 Likes
michael_zhou
Adept I

Lowering the ram speed had the same results, tried the newest release that can out recently and still no good.

AMD support suggested to install the Asus chipset drivers first last time I did that I had BSOD.

0 Likes
ren72
Adept I

I am having exactly the same issue. When I try to install the latest Adrenaline version, I get a black screen... After waiting a lot of time with the black screen I had to turn off the computer and restore it to a previous restore point.

System:

mobo: MSI MPG x570 Gaming Edge Wifi

CPU: Ryzen 3200g 

RAM: Corsair vengeance 3200 16GB

Storage: m2 NvME 500GB Samsung evo plus 970

No external graphics cards. I would like to play with the APU

I have tried a lot of different things without success. Still getting the black screen. PLEASE HELP

0 Likes
michael_zhou
Adept I

I have solved my issue by using a different PSU, was using 550W and went to a 1000W.

jyc921
Journeyman III

Hi, I am facing the same problem at the moment: black screen during installing radeon software. I have tried several versions, from 19.7.1 to 19.7.5 and 19.8.1, none worked.  

Installing the latest chipset driver (1.8.19.0915) for b450 in advance makes no difference. 

I am able to get a fully functional system with the Microsoft basic driver, so hardware-wise other components should be working. Apparently the problem occurs when installing the graphics driver, if I use custom install and uncheck the graphics driver, the installation will work fine, but still, no graphics driver obviously.

setup:

motherboard: ASUS ROG STRIX B450-I GAMING

cpu: r5-3400g

psu: corsair SF450

ram: corsair vengeance ddr4-3200, running default at 2133. 

ssd: intel 760p

OS: win10 1903

Already submitted a support ticket, just wanted to see if there are some things that I should try as well. 

0 Likes

Bro, once I changed my monitor I solved the issue. Try that and let me know.

What I went through was the same..  During the installation the screen flicks couple of time then forever sleep.  Went through the rma to get a new motherboard fresh os install and still the problem. I had another psu (newer 1000w) in a older pc. So I plug it in,  install the driver,  screen flicked on off then magically screen stay on.

My conclusion was that their wasn't enough power to power the motherboard's HDMI to keep the display up. I thought without a dedicated gpu, 550w should be more than enough but I was wrong. 

So try a higher psu if you can and good luck. 

Motherboard I'm using is Asus tuf b450m plus gaming. 

0 Likes

So, following @ren72 's advice, I changed a monitor and problem was solved.

A‌pparently, the new graphics driver does not go well with my other monitor for some reason. 

Thank you @michael_zhou as well!

0 Likes
googie
Journeyman III

I have similar issues: Blinking lines, flashing static after the system crashing about the integrated graphics driver installation, by last, W10 Pro get damaged and it can't start.

After trying several times, having actualized all the mobo drivers before the installation of the latest version at this day, Adrenaline 19.8.2 and the other previous versions of AMD drivers; and vice versa, first installing such AMD's drivers versions the issues still remain. I also actualized the latest BIOS version Asus Prime B450M-A (1807) and it seems works worst.

Setup:
Mobo: Asus Prime B450M-A
CPU: Ryzen 5 3400G
RAM: G.Skill Trident Z DDR4 8GB, 3000 Ghz (I tried with default 2133 to 3000)
HDD: Toshiba 1TB
OS: Windows 10 Pro
PSU: EVGA 500 BR 80 Plus

0 Likes
j_sok
Journeyman III

Completely new system.

ASUS Rog Strix X370-F Gaming Mainboard

Ryzen 3400G processor

ddr4- 2x8GB Ram 2666MHz

OS: Windows 10 Pro

After installing the driver, a black screen.

The problem was solved by changing RAM the frequency from 2666MHz to 2400MHz.

0 Likes
diogo_sousa
Journeyman III

Hello,

I bought a custom pc with Amd Ryzen 5 3400g Quad-Core 3.8GHz with/Turbo 4.2GHz 6MB and the motherboard is a Micro-ATX Gigabyte B450M DS3H.Ram - 2x8GB  DDr 4 -3000MHz

Yesterday i wanted to install the drivers to see if i have everything updated but a problem occured. When i started to download the amd drivers and it started to install a bluescreen appear and then I had to restart my pc and i could not see. Everything was black on my screen as i didn't have any graphic card. I tried to reboot and few several times after i was succeeded but then, after my second attempt and by trying to install the recommended version (first time was the optional one) the same thing happended. What can i do and what can be the problem? Everything was ok before i tried to install the drivers.

0 Likes
rinlau
Journeyman III

Hi,

I am using a 3400g, G.Skill Aegis DDR4-3000 DIMM CL16-18-18-38 Dual Kit and Asrock B450M Pro4 V. 3.90. Upddating to latest software and drivers never solved the crashes. My RAM was always running at 2133Mhz instead of 3000Mhz. After loding XMP to start at 1,35 V and 3000Mhz it did not even boot. So I started to try out all other frequencies and ended up with 2733Mhz as fastes one. Since then I havent got any new bluescreens or strange beaviour more.

0 Likes
joemm210
Journeyman III

I was having a similar issue and I think I found the solution, although my issue is with my benq monitor GL2760 and it will randomly blink black for a half a second then back on. It was easy to recreate the issue over and over again
by playing youtube videos at 4k resolution, (it would blink at other times but it seemed easier to recreate the issue by playing youtube 4k content)
I tried this test on my living room tv and it actually does not blink so this is a problem with just my benq monitor and I tested the monitor on another computer and it works without any blinking, so it needs to be a resolution issue with the ryzen 3400g on my benq monitor.
 
my monitor says it only supports 1920*1080 60hz, however amd has custom resolution settings, so you can modify a few things to try. what actually worked for my situation is going into amd radeon settings then display, create a custom resolution, and I changed the timing standard from cvt to CVT - Reduced Blanking and saved the settings.
this was the first one I tried and I have not had the issue again, however depending on your tv or monitor I could see one of the other timing standards fixing the issue worth a shot.
things I tried that did not work include a new cable, tried hdmi and dvi. AMD asked me to try a older driver, 19.12.1 and it didn't fix the issue but I am still using that driver.2020-01-10 (1).png
0 Likes
screwdr1ver
Journeyman III

this may be an old thread but just like to share for as there may still be those having problems in getting vega 11 to work on ryzen 5 3400g.

i solved the problem by disabling csm and enabling uefi mode instead. worked like a charm.

mobo - msi b450 gaming plus max

cpu - ryzen 5 3400g

ram - corsair vengeance 8g 3000

ssd - wd green 240g

monitor - any monitor worked even old ones

bios default ram setting - 2133 mhz

bios version - h6

0 Likes
julianocrvg
Journeyman III

I'm having the same problem
I bought a Ryzen 5 3400G, 8gb ram 3200 and A320 K-M/BR (I think this is a version just to Brazil, where I'm from, so I hope you dont care about my english).

Since the first day I'm dealing with a lot of problem, but probably its just about the same error that I cant find.

The most common it is Windows freezing ramdonly, but never when I'm playing any game. When it is not this error, I get a bsod with IRQL_NOT_OR_LESS, amdppm.sys and rarely, memory_management. I'm with contact with the support where I bought the pc and waiting for some light.

I've already tried to format, sfc, memory test, etc, and all of these never showed me an error. I tried all ram frequencies, from 2400 to 3200 and I had problems all the times.

I just discovered this discussion right now and I'll test everything that I read, maybe someone really found the problem.
I'll back soon

0 Likes

Anyone get the problem with Lumion, hardware graphics do not work with the rendering, AMD controllers office department are you readme???

 

0 Likes