cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III
Journeyman III

Missing PCI Encryption/Decryption Driver - PCI\VEN_1022&DEV_1486

I've recently built a new PC and can't seem to fix this missing driver in device manager. I believe it may be linked to the 2x HDDs I have set-up in RAID 1 with RAIDXpert2 Drivers, but not sure.

I've tried reinstalling the Chipset + SATA + RAID drivers, which didn't fix it.

Any ideas from the ID?

I can see a couple of other reports of this in the last few weeks, but no clear fix, so it's something recent.

Including this post: https://community.amd.com/message/2928312 

My system is; ASUS B450-i, 3700x, EVGA 1070, 32GB RAM, 500Gb NVMe + 2x 4TB HDDs in RAID.

0 Kudos
16 Replies
Esteemed Contributor III

Re: Missing PCI Encryption/Decryption Driver - PCI\VEN_1022&DEV_1486

This is what PCI - 1022 DEV - 1486 refers to in Device Manager:

According to this website it does seem to be connected to RAID: Ryzen 3000 series build / Struggling with PCI-e lanes - Page 3 - Motherboards and CPUs - Unraid 

Also this recent Reddit Thread: https://www.reddit.com/r/VFIO/comments/cky2fv/iommu_groupings_gigabyte_x570_aorus_elite/ 

Also Tech One Thread: https://forum.level1techs.com/t/x570-taichi-iommu-groups/145762/2 

0 Kudos
Journeyman III
Journeyman III

Re: Missing PCI Encryption/Decryption Driver - PCI\VEN_1022&DEV_1486

yea, seem to be happening to a few people. But not clear how to actually fix it. Any ideas?

0 Kudos
Esteemed Contributor III

Re: Missing PCI Encryption/Decryption Driver - PCI\VEN_1022&DEV_1486

Try opening an Online AMD Service Request and see if they say anything useful from here: https://www.amd.com/en/support/contact-email-form 

0 Kudos
Adept I
Adept I

Re: Missing PCI Encryption/Decryption Driver - PCI\VEN_1022&DEV_1486

I had the same issue. First install the latest chipset driver from AMD (https://www.amd.com/en/support/chipsets/amd-socket-am4/x570). Then go to Device Manager, right click on the device, choose Update Driver on the device, Browse my computer for driver software, choose this folder: c:\Program Files (x86)\AMD\Chipset_IODrivers\PSP Driver\

It fixed my missing driver for me, now it says: AMD PSP 11.0 Device, under Security devices.

Journeyman III
Journeyman III

Re: Missing PCI Encryption/Decryption Driver - PCI\VEN_1022&DEV_1486

That fixed it! Thank you.

0 Kudos
Journeyman III
Journeyman III

Re: Missing PCI Encryption/Decryption Driver - PCI\VEN_1022&DEV_1486

I registered an account just to say thank you! I downloaded the drivers for the chipset from the official site, and there was the right one for PCI!
0 Kudos
Journeyman III
Journeyman III

Re: Missing PCI Encryption/Decryption Driver - PCI\VEN_1022&DEV_1486

What should I do if my computer says this cant be found?

0 Kudos
Adept I
Adept I

Re: Missing PCI Encryption/Decryption Driver - PCI\VEN_1022&DEV_1486

I wrote some instructions in that thread, have you tried that?

0 Kudos
Journeyman III
Journeyman III

Re: Missing PCI Encryption/Decryption Driver - PCI\VEN_1022&DEV_1486

In what thread? Im new to this forum and didnt see anything

0 Kudos