cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

ssh
Journeyman III

i can't install amd chipset driver 17.40

hi there!

I download amd chipset driver file. 17.40 (01/16/2018)

and I click file.

it's self extract. (c:amd:amd chipset driver)

after file extract nothing happen. when I see process there is amd process. but no install.. no work. how can I solve this?

os : win10 pro 64bit 1709. 16299.192

cpu : ryzen 5 1600x (no overclock)

mb : asrock x370 taichi bios 3.20

ram : corsair 8g x4 32gb

gpu : gtx 1080

spu : corsair rm650i

0 Likes
8 Replies

One for amdmatt​ or ray_m

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro..
0 Likes
Matt_AMD
Community Manager

0 Likes

Oh I tried older version 17.30

And it’s same.

File download

It’s self extract. But no install. Nothing happen.

0 Likes

When you say no install, you mean the installation completed without installing any AMD drivers? or the installation didn't complete?

When I run the AMD Chipset, it finishes installing but doesn't install any drivers. I usually need to go to Device Manager and update all the AMD drivers manually  through properties. For instance, AMD SATA driver, I go to the driver and point it to the C:\AMD chipset folder. Then I click on update. It searches the folder and correctly updated the SATA driver from the folder. I did the same thing for AMD SMBus driver.

0 Likes

I built my own pc. With X370 mb, ryzen1600x, and install win10pro 64bit.

And other programs and games I need. I use it well.

I mean my pc just use ms windows 10 pro 64 bit own dirver only.

Cause I couldn’t install This amd chpset dirver. My pc is just working well. Without amd chipset driver From amd site.

But recently there is some issue with meltdown and specter. So I download brand new driver from amd site. But I can’t install it

Installation progress did not start..

0 Likes

Oh I tried this. And installation progress works.

I download the file. 17.40 from your site.

And I extracrt other extractor program (like 7zip) to d:amd I create this folder on d:, and I click setup. It’s works. Thanks!

Not using self extractor, and self install.

When I do it with self extractor, it extract file to c:amd, nothing happen, installation progress didnt start. and it isn’t work.

0 Likes
Matt_AMD
Community Manager

Might be an OS related corrupt file issue. Clean install of Windows?

0 Likes