Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

How to fix "AMDRSServ.exe - Application Error"?


For the past couple of weeks or so this error has been popping up every time right before I restart my computer. A few days ago, I uninstalled and re-installed the AMD Radeon Software because I've been unable to capture media or use any hotkeys (this didn't fix that problem). Now, this error is popping up every ten minutes or so that I'm using my computer.

AMDRSServ.exe - Application Error

The instruction at 0x00007FFF901C9BD1 referenced memory at 0xFFFFFFFFFFFFFFFF. The memory could not be read.

I've included a picture of the error message below. I don't know if it's related to the media/hotkey problems, but I'd appreciate any help. I'm using version 20.5.1 of the software, which was the same before I re-installed.

10 Replies
Adept II

I also get the EXACTLY same message with the same versionv 20.51 :  RX580   8gb version.    Pagefile is 16gb~24gb

AMDRSServ.exe - Application Error

The instruction at 0x00007FFF901C9BD1 referenced memory at 0xFFFFFFFFFFFFFFFF. The memory could not be read.

Journeyman III

pye‌ I have an 8GB RX 580 as well.

Journeyman III

Update: Following the instructions on a similar post, I uninstalled Radeon software using Display Driver Uninstaller while in safe mode. After reinstalling, this fixed the application errors. Hotkeys are now working for me along with screenshots. However, screen recording is still not working.


Today, I have gone back to my last known working version. v20.2.2 WHQL.        There used to be no stutter and instant replay worked and Gif maker, just did to.  I have always used the official uninstaller DDU in safe mode, so can discount that when trying all previous versions. Since 20.2.2, the stutter problem went from a 3 second pause to a mouse (timer icon) appearing frequently to the 20.7.2 , micro pauses every second or 2.      The 20.4.2 (WHQL) had the stutter , mouse icon intemittent problem. 


ashtonm99‌   We have the same model card, that is telling.  My card is an 'ASUS' RX580. have you got that make?   Go back to v20.2.2 and I bet screen recording works for you too.  After every beta driver after v20.2.2. I was always hoping they would fix it like it 'USED TO WORK'  .   I'll keep trying the new betas, and with the new reporting tool, hopefully they fix it, whilst fixing another cards problem, if they can't find our cards problem.


Oh, forgot to mention  in version 20.7.2 the memory error did get fixed for me. Only the micro stutter with instant replay on. I did not try instant gif on it own, because its instant replay that is the most usefult for me to record those 'TEAM KILLS' on me

Adept I

Same issue here. I uninstalled the monitor driver from the manufacturer, leaving Generic PnP Monitor in Device Manager. In my case was a Samsung 4k 32 inch monitor with a XFX RX480 8gb and latest AMD drivers.


EDIT: Did not fix it after all.

Tried DDU with different AMD drivers and nothing. 

It seems the problem is linked to Antimalware Service Executable (Windows Defender Antivirus Service) running in the background consuming CPU resources until crashes AMDRSServ.exe

The only way I got rid of the problem has been leaving windows to download and install the drivers for the RX480 (from 2019). Monitor 4k working fine now. I'm aware gamers won't like this workaround, but until Windows Defender Department and AMD find a solution this is the only way I've found so far. 

Uninstall AMD drivers with DDU, reboot and wait until windows 10 installs the video drivers (check if Wupdate is working properly).




It seems the Cleanup Utility from AMD is doing a better job than DDU.


Download latest AMD Drivers

Run it. This will extract the AMD files into a folder...By default in C:\AMD

Once opened cancel the installation. We don't need to install the AMD software yet.

Go to 


(Folder may vary depending on extraction location and AMD drivers version. you'll need to accept permissions to access the folder )




As administrator go to Device Manager, and click to update the Video Driver. Pick the location to find the drivers that we had extracted previously:


Once AMD drivers installed, REBOOT

Now  run AMD Setup installation


Once installation completed, Reboot.

If System is stable, Don't forget to Create a Restoration Point in case is needed in the future. 

Enjoy your AMD GPU!

Journeyman III

three years later, ... the problem persists

i have a radeon 6650 xt.  message reads:

"amdrsserv.exe" "application error" the instruction at 0x3f1b49ae referenced memory at 0x00000000 "the memory could not be read"

amd never fixed this problem.  i can definitely say that nvidia drivers & software are not as buggy as amd radeon.  i suspect that this is a microsoft issue; how much nvidia stock does microsoft own ?  that's the question that needs an answer

could also be incompetence on the part of amd.  when your primary objective is making money for your shareholders instead of providing excellent customer service, this is what you get

the root cause of this is a broken money system.  manifesting itself in every facet of business, and now here

this is just pathetic.  that's the bottom line.  what you get when you have insipid spineless yes men running a multimillion dollar tech giant

2023-07-03_12-57-58 amdrsserv dot exe application error.png