cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

thanatoast
Adept III

Forced restart when applying Wattman Profile potentially caused by PBO (how the f-)

Ryzen 5 5600x w/ NH-D15
MSI B450 Carbon BIOS 7B85v1F6(Beta version)
Crucial Ballistix Sport LT 2x8Gb 3000MHz CL15
SAPPHIRE Vega 64 Nitro+ @ ~1632MHzP7 999mv 1050MHzHBM2 - Driver Version 22.1.1 (also present on previous driver)
WD BLACK SN750 1TB M.2 // Crucial MX300 525GB SATA SSD // WD BLUE 1TB HDD - Win10 19044
EVGA G2 1000w PSU

  • Upgraded to 5600x from 2700 recently
  • Tweaked PBO stuff in BIOS (2700 does not have PBO which might explain why i've never seen this problem before)
  • Upon applying my OC profile in Wattman (fully stable, had this specific profile for ages), a tuning widget will pop up saying something about Default Tuning, and it will force restart my PC (full Windows restart as if one had clicked Power->Restart )
  • After this forced restart, PBO values in BIOS will be reset back to their defaults (PPT, TDC, EDC)
  • Wattman profiles will now apply properly without forcing a restart, but ONLY WHEN PBO VALUES IN THE BIOS ARE AT DEFAULT

In the 22.1.1 fixed issues list, this can be found;

  • After upgrading to the latest Radeon™ Software, the Power Tuning component of a saved tuning profile may not load correctly when a user imports a previously saved tuning profile.

At first I thought this was related to the issue so I updated to this version, but it turns out to be unrelated. Whatever is causing my specific issue is still not fixed on the latest driver.

 

So yeah, this is a strange one. Incredibly inconvenient too since now whenever I want to do stuff on Wattman, I either have to go into bios and disable/revert PBO temporarily, or change the profile and have wattman boot me out of windows.

I've had many strange bugs since I got my first AMD card (including one related to ReLive that seems to have randomly decided to fix itself after upgrading to this 5600x, which makes NO sense) but this one takes the cake. How does this even happen? Maybe due to Ryzen Master's integration with Radeon Software? Which by the way, has never once worked for me. The option to use Ryzen Master isnt even displayed. How can applying a profile on the GPU be influenced in ANY way by PBO values? Im absolutely baffled. Hoping this wont just get ignored.

0 Likes
0 Replies