cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Dougberry
Journeyman III

FirePro W5100 drive installation error loop

Hello everyone!

I think I'm trapped in a cyclical error and I've reached the end of my ability to troubleshoot. 

I had an error pop up while attempting to launch a videogame that indicates I need to update my driver, but while installing the driver, the installation fails and the reason given indicates I need to update my graphics driver.

Since I can't post a screenshot, the text reads:

"Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options
QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1,
greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior
QSurfaceFormat::DoubleBuffer, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSpace,
profile QSurfaceFormat::NoProfile) .

This is most likely caused by not having the necessary graphics drivers installed.

Install a driver providing OpenGL 2.0 or higher, or, if this is not possible, make sure the
ANGLE Open GL ES 2.0 emulation libraries (libEGL.dll, libGLESv2.dll and d3dcompiler_*.dll) are available
in the application executable's directory in a location listed in PATH."

 

Has anyone run into this before? I had this issue running Windows 7, and have upgraded to Windows 10 as of today. After the Windows 10 installation, I attempted to install the driver and got this error. I then used a tool to uninstall the graphics driver, rebooted in safe mode, and tried to reinstall again. I continue to get the error.

Any insight or assistance would be greatly appreciated. Thank you so much for your time!

0 Likes
3 Replies
elstaci
MVP

Re: FirePro W5100 drive installation error loop

I remember another User had the exact same error also using a Professional GPU Card. It is best if AMD Moderator @fsadough takes a look at your question since he is the expert on Professional GPU Cards.

EDIT: Found the thread where the above User was  having that exact error and the Fix that he was able to do to: https://community.amd.com/t5/drivers-software/firepro-w700-drivers-install-fails-quot-failed-to-crea...

This  was  his fix but this might only apply to his situation only:

Screenshot 2021-10-07 192150.png

0 Likes
fsadough
Moderator
Moderator

Re: FirePro W5100 drive installation error loop

  1. Please specify your exact OS version including build number.
  2. Please specify the exact make and model of your system, If no OEM, specify motherboard make and model.
  3. Specify your System BIOS version.
  4. Which GPU driver is installed?
  5. Which Videogame are you running (including version)?
  6. How are you connecting your monitor(s) to W5100? 
0 Likes
talentlessness
Journeyman III

Re: FirePro W5100 drive installation error loop

Hey mate, Ive just been trying to figure this out for the last few hours or so as I also needed to update my drivers for my firepro w5100.

I found a work around!

So I downloaded the drivers and opened the .exe file and the message comes up as you stated. 

On windows 10 - open settings then click on 'system'

Click on display

Scroll down and find 'Advanced display settings'

Then click on 'Display adapter properties for Display x(whichever monitor you had plugged into your firepro)

Click on properties - then 'driver'- then 'update driver'

Click on browse my computer - then click browse next to folder directory path and choose the file that was created when you opened .exe file. For me it is C:\AMD\Win10-Radeon-Pro-Software-Enterprise-21.Q2.1

Then click next - Updating drivers XD

*Just realised after typing all this you can just go to device manager *right click start* and update drivers from there using same method*

Hope this helps.