Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Error 202 but there's no pending Windows Update

I've made sure every possible Windows Update is installed, there's no updates pending, my system is 100% fully updated but I can't install my AMD software, it keeps saying "Error 202 - AMD Software install cannot process as a Windows Update is currently in progress."

How can I get it to see that there is no Windows Update in progress? I've already restarted my system 4 times but AMD always thinks there's an update in progress when there is not.

5 Replies
Journeyman III


The same behaviour for me!



Me too, it started right after I used Windows recovery to delete my AMD driver and uninstall the Adrenaline Edition software because a March 2023 update it installed made all opened windows invisible. Fixed that, but now I'm getting this error. Can someone please help us? I've had Windows Update disabled since 2021, no Windows updates are trying to install.

AMD Windows Update Error.PNG

Journeyman III

I'm on a newly built computer. Installed 23.4.1 ok. Then came 23.4.3 upgrade.

There is no Windows Update running, still the error 202.

Journeyman III

I figured this out. Stopping Windows Update Service solves the problem.

On PowerShell, I ran: Stop-Service -Name wuauserv

This made the install pass initial checks and complete ok.

Journeyman III

I have been having this problem ever since AMD implemented the Windows update security check and have reported it through the Bug reporting tool. I want to know what is being done about this problem! I tried disabling that service and that did not work are you sure your syntax is correct? I have not updated to Windows 11 and won't until I have to. ALL updates are 100 done, I have "paused" the updates and even disabled all security. This needs to become a number-one priority for AMD, because I am pretty sure it is more common than this thread is showing!

HERE is the FIX!

I ran the services app in the search bar at the bottom then went to  "Windows Update" and clicked on it, mine was STOPPED and set to manual. I then set it to automatic and restarted and then I stopped it. Then I was able to do an install. There seems to be a disconnect between what the Windows UPDATE SETTINGS are telling us (mine says paused and 100% updated), and what the Windows Update APP is ACTUALLY doing (it is running). I would post a screenshot if I could.

I think you guys at AMD are using the wrong detection method!