cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

bobroarrman
Journeyman III

Driver install stuck at "Please wait while detecting hardware"

I'm trying to update drivers for my RX 480.  When i try to download them, it works to the point of asking me express of custom install.  Regardless of what i choose the next ADM Software popup just says "Please wait while detecting hardware".  It doesn't get past this point.  Is there anything else i should be doing?  

0 Likes
3 Replies

Does your RX 480 show up in "Device Manager" without any yellow exclamation point or errors?

You need to use DDU to uninstall the previous AMD Driver. Here how to do a basic installation:

install AMD driver:


1) Download the correct AMD Full Set of drivers from AMD Support. Make sure your Windows is fully updated via Windows Update. Windows Must be fully updated because the latest AMD Drivers requires all the latest "Optional" and "Recommended" updates to be installed.

2) Use Windows Uninstall to uninstall current AMD driver and software and disconnect the internet from your computer. Then use DDU (Display Driver Uninstaller) Display Driver Uninstaller (DDU) from Wagnardsoft  Forum in Safe Mode. This will eliminate all traces of the AMD driver and software from your computer.

Delete C: \ AMD folder from the Root Directory. Reboot

3) Go to Device Manager and click "Display Adapter" and make sure you are on the MS Basic Display Adapter. If not, uninstall the AMD driver using Properties.

4) Try reinstalling the AMD FULL SET OF DRIVERS that you have downloaded manually. Make sure you disable the Internet to prevent Windows from installing a newer version. So configure windows to prevent it from updating drivers via windows update. So it has been mentioned to disable any anti-virus programs before installing AMD Drivers.

5) If the new AMD drivers installs and works correctly, delete again the C: \ AMD folder from the root directory. To save space on the HDD.

6) Enable both the Internet and Anti-Virus program (if applicable).

7) Go back to Device Manager and check your GPU card driver is working and identified correctly.

Here is the latest AMD Driver for the RX 480: Radeon™ RX 480 Drivers & Support | AMD 

saithies
Journeyman III

I've had this problem on various computer for YEARS. DDU did not fix it and nothing else I tried either. The error affected different builds of windows and graphics cards from my HD 7770, HD 6950, r9 Fury X and my RX 590 and I finally found a fix!

 

It started with the above comment to go to C:\AMD\Win10-64Bit-Radeon-Software-Adrenalin-2019-Edition-19.11.2-Nov14\Packages\Drivers\Display\WT6A_INF\B348697 and run CCCinstall.exe.  One of the folders said I did not have permission to open it!!! I did the steps below and it works!

 

When you run the installer and it extracts to C:\AMD exit the installer. Go to that folder, right click it and go to the security tab. Click advanced. Change the owner to your account and be sure to include subfolders. Afterwards be sure your account has Full control, also be sure subfolders is selected here as well. Watch a YouTube video on changing ownership and permissions if need be but this has worked. I pulled all my old cards out and tested them one at a time being sure to DDU and delete the AMD folder each time. I verified the error occurred first then corrected it and it works every time for me. I hope this works for everyone! Good Luck!

0 Likes

Hey man, i bought a 6800 XT and could't install the drivers for the life of me, tried DDU twice, disabled Windows Update, none of it worked, but now thanks to you i am playing Red Dead Redemption 2. Thank you so much!

0 Likes