Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


DirectX9 Unreal Engine 3 optimizations loss still not attended to.

Hi everyone,

System specifications:

- Windows 10 64-bit latest service pack,

- Ryzen 5 1600,

- 2x 8GB DDR4 2667Mhz,

- Radeon RX 480 8GB,

Ray_m please to not close this post, because @dorisyan , @dipak , @xhuang  has not responded in so long that the issue has not been attended to and our previous thread has automatically been locked.

There are still numerous people on steam forums complaining about the loss of performance in numerous Unreal Engine 3 games on at least any pre- Navi card.

As I have stated previously, I personally have narrowed down the issue for you (the AMD driver team) to 17.7.2 and upwards where AMD lost performance optimizations for a lot of DirectX9 Unreal Engine 3 games after the removal of "Radeon Additional Settings" in 17.7.2 and upwards. I am in no way stating AMD should bring back Radeon Additional Settings, I am simply indicating that AMD should pay attention that this is the driver they lost their optimizations in and they have not fixed it 5 years later up until the present. This issue has been reported numerous times since 2017 on numerous forums from numerous customers.

Games/Software I have personally tested to definitely be affected:

- Unreal Tournament 3

- Heroes of Might and Magic 7

- Singularity (the one developed by Raven Software)

- XCOM Enemy Unkown

- Alien Rage

One other game I have seen users complaining about the issue:

- Batman Arkham Asylum.

Even though my Ryzen 5 1600 is also affected by the issue, kindly pay attention to CPUs of the time that are now greatly affected, not your modern success of Ryzen 5000 CPUs. CPUs like any AMD FX, AMD APUs (even top of the line ones of the time like A10-7850K), 1st, 2nd and 3rd Gen intel core i processors including core 2 duo's, core 2 quads, etc.

Here are the video links again where I easily reproduced the issue with clear, day and night, drops in performance between using 17.7.1 or any newer driver:

- Acceptable original performance in 17.7.1:

- Unacceptable post 17.7.1 performance (please pay attention that I have tested this on the latest 22.4.1 driver already):

AMD please pay attention to your Quality Assurance, you introduced this issue 1.5 years after the Polaris series has been released and close to the release or 1st Gen Ryzen and you have not attended this issue since. It is as if your separate driver teams to not have consensus between driver versions when they merge code.

Kind regards

4 Replies

Putting in my vote to have this investigated, there are many great UE3 titles that are being completely hamstrung by this oversight and it needs to be fixed ASAP


This issue has already been forwarded to DX driver team, based on the feedback I received that the developers from DX driver team is not able to re-produce internally using our dev platforms. 

Hi @xhuang 

I highly doubt that they actually did, and they explicitly tested a game which was not on the list of games in which I described the steps to reproduce the issue, therefore their results are invalid.

Furthermore, there was no evidence provided to prove that they actually tested it, they came up with the excuse that they do not own Unreal Tournament 3, and then they went on and apparently tested Borderlands 2 a few months ago, which is not on the main list of affected games I mentioned.

This is a real major issue, do not rub it under the carpet, it has been ignored for way too many years. We want to see them provide video evidence on the Hardware and game we have mentioned with the easy as kindergarten steps I have listed/shown in the video(s) and not their rumours.

@xhuang @dorisyan @dipak ,

another video game severely impacted by this Radeon Unreal Engine 3 DirectX9 anomaly is Alien Breed 3 from Team 17.

It seems the post 17.7.1 Radeon driver has major overhead in these games, almost as if it has having memory leaks or duplications of some API calls.

Early in the game, after the first manual save point you run on a platform with a water canal underneath it in the spaceship, then you get to this small open room with two structures split, still by the pathway, where the FPS plummets to the ~28FPS range continuously on your modern drivers which is over a 50FPS loss since after 17.7.1.

Please investigate and attempt to fix this issue.