Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


Corrupted Boot Files/Black Screen when installing AMD APU Drivers or Windows Auto Updater

Hi Everyone, 

I've browsed the forum many times but unfortunately find myself in the position I need to ask for some help/advice! 

Small back story, I was given a budget at work to buy/build a new pc for myself of £350, a small budget but my requirements are very low, this is just a desktop PC I use from time to time for mundane tasks. so I opted for the following - 

APU - AMD Ryzen 3 3200G Gen2 (Socket AM4)

RAM - HyperX FURY 8GB (2x 4GB) 2400MHz DDR4 RAM

SSD - Kingston A400 480GB 2.5" SSD Solid State Drive

PSU - Aerocool Integrator 500W 80 PLUS Bronze Non-Modular PSU Power Supply
OS - Windows 10 (latest version available boot creation tool)

I took all components home to install in an old case I have and almost instantly hit issues, whenever microsoft auto installs updates, I get the all too common black screen and what looks to be corrupted boot files.

It feels like i've tried a million things from fresh installs to reformatting the SSD and completely starting fresh, I tried the DDU in safe-mode + installation of the driver with no internet also with no luck. 

One thing I find particularly strange is when the PC is booted into safe-mode it's incredibly stable and the Device Manager's Display Adapters section shows Vega 8 Graphics, yet in 'Normal' mode all hell breaks loose, the Display Adapter shows as Microsoft Basic Display Adapter.

Any ideas would be amazing because whilst it's not a 'important' PC for me work wise, I am getting moaned at by those above me at where my PC is and why i'm not using it! 

Thanks again in advance.

2 Replies

** UPDATE **

When installing the AMD Drivers manually with no internet connection I get a BSOD with VIDEO_TDR_FAILIURE error code around the 70% mark, only fix is to boot into safe mode and delete all drivers with DDU.

Tried new RAM sticks from another build with no luck, and tried installing a Sapphire RX580 8GB with no luck either.. surely an APU issue?


** UPDATE 2 ** 

I’ve also tried a different MoBo to no avail. Tested the SSD in another build which worked perfectly. So it’s all narrowed down to the APU. 

Currently waiting a response from AMD via email but if anyone has any ideas in the meantime it’ll be much appreciated!