Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

cant open radeon settings

I just got a RX 580 and everything was working as expected, but then as I try to open Radeon settings it just doesn't appear on my screen.

I have tried reinstalling the latest drivers and installing older drivers as well. please help.

Specs (in case you need to know):

Intel i5 7400

AsRock H110-M

Kingston 1x8GB DDR4

Sapphire RX 580 4GB

- Connor

1 Reply
Adept I

Ok guys, i had the same problem (nothing happens when i try to open Radeon Settings) and reinstalling the driver suite (using DDU first) did not help me. Then, after a lot of google searches, i solved my problem. I don't exactly remember at which site i found, thus, i can't give credit (sorry for that). I'll share my solution here hoping to help others. I'll explain as simple as i can.

(This solution may work if you are using an intel CPU with CPU graphics enabled alongside your main AMD GPU)


Step 1: Open Windows Task Manager (right click on the clock and click on Task Manager). Switch to "performance" tab. Here, you can see real time performance graphics for your hardware like HDD, Network, GPU etc. Do you see your intel on-board GPU here? Is it seen/identified as GPU 0 or GPU 1 by Windows? If your intel CPU graphics is seen as GPU 0, this solution may not be for you (but you can still try it cause it doesn't involve anything potentially harmful for your system)


As i understand it, If your intel CPU graphics is listed as GPU 1, this is the problem. Supposedly Radeon Settings tries to communicate with GPU 1 and it doesn't work because it's an intel on-board GPU. This may be a Windows fault too, i don't know. 

Step 2: Now the solution is pretty simple. You need to first uninstall (in my case it's a HD 4600), download and install the latest drivers for your on-board GPU.

To download most recent drivers (if you know this you can skip this paragraph): Go to intel web site, navigate to "drivers&software" page (direct link: Drivers & Software ) and from there you click on "Graphics Drivers" link and at the next page you only need to select your CPU family (ie 4th Gen), download type (you need drivers), your OS version.

You should install (as admin) the suitable and most recent driver package. 

Step 3: After installation is completed, restart your PC. In my case i didn't need to do anything else after restarting and my Radeon Settings worked flawlessly. I didn't need to re-install Radeon Settings either. And now Windows sees my on-board graphics as GPU 0 (as it should be).

I'll share this solution in similar forum posts.

Sorry for my poor English. I hope this solution works for you.