cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

baszczer
Adept III
Adept III

Can't install amdgpu drivers on Ubuntu 20.04.1 (5.4.0-56-generic)

Jump to solution

Hi,

System: Ubuntu 20.04.1, Gpu: Sapphire RX 5700 XT, Drivers tested (20.30, 20.40, 20.45)

When I try to install drivers, I get this:

Building initial module for 5.4.0-56-generic
ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/amdgpu-dkms-firmware.0.crash'
Error! Bad return status for module build on kernel: 5.4.0-56-generic (x86_64)
Consult /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/make.log for more information.
dpkg: error processing package amdgpu-dkms (--configure):
installed amdgpu-dkms package post-installation script subprocess returned error exit status 10
dpkg: dependency problems prevent configuration of amdgpu:
amdgpu depends on amdgpu-dkms (= 1:5.6.20.906300-1164792); however:
Package amdgpu-dkms is not configured yet.

dpkg: error processing package amdgpu (--configure):
dependency problems - leaving unconfigured
Setting up xserver-xorg-amdgpu-video-amdgpu (1:19.1.0-1164792) ...
No apport report written because the error message indicates its a followup error from a previous failure.
Setting up mesa-amdgpu-omx-drivers:amd64 (1:20.1.6-1164792) ...
Setting up libegl1-amdgpu-mesa:amd64 (1:20.1.6-1164792) ...
Setting up libegl1-amdgpu-mesa:i386 (1:20.1.6-1164792) ...
Setting up libgl1-amdgpu-mesa-glx:amd64 (1:20.1.6-1164792) ...
Setting up libgl1-amdgpu-mesa-glx:i386 (1:20.1.6-1164792) ...
Setting up amdgpu-pro-core (20.45-1164792) ...
Setting up libgles2-amdgpu-mesa:amd64 (1:20.1.6-1164792) ...
Setting up libgles2-amdgpu-mesa:i386 (1:20.1.6-1164792) ...
Setting up libgl1-amdgpu-mesa-dri:amd64 (1:20.1.6-1164792) ...
Setting up libgl1-amdgpu-mesa-dri:i386 (1:20.1.6-1164792) ...
dpkg: dependency problems prevent configuration of amdgpu-pro-rocr-opencl:
amdgpu-pro-rocr-opencl depends on amdgpu-dkms (= 1:5.6.20.906300-1164792); however:
Package amdgpu-dkms is not configured yet.

dpkg: error processing package amdgpu-pro-rocr-opencl (--configure):
dependency problems - leaving unconfigured
Setting up vulkan-amdgpu-pro:amd64 (20.45-1164792) ...
No apport report written because the error message indicates its a followup error from a previous failure.
Setting up libosmesa6-amdgpu:amd64 (1:20.1.6-1164792) ...
Setting up libosmesa6-amdgpu:i386 (1:20.1.6-1164792) ...
dpkg: dependency problems prevent configuration of amdgpu-pro:
amdgpu-pro depends on amdgpu (= 20.45-1164792); however:
Package amdgpu is not configured yet.

dpkg: error processing package amdgpu-pro (--configure):
dependency problems - leaving unconfigured
Setting up comgr-amdgpu-pro:amd64 (1.7.0-1164792) ...
No apport report written because MaxReports is reached already
Setting up hsa-runtime-rocr-amdgpu:amd64 (1.2.0-1164792) ...
Setting up ocl-icd-libopencl1-amdgpu-pro:amd64 (20.45-1164792) ...
Setting up clinfo-amdgpu-pro (20.45-1164792) ...
Setting up hip-rocr-amdgpu-pro (20.45-1164792) ...
dpkg: dependency problems prevent configuration of amdgpu-pro-lib32:
amdgpu-pro-lib32 depends on amdgpu (= 20.45-1164792) | amdgpu-hwe (= 20.45-1164792); however:
Package amdgpu is not configured yet.
Package amdgpu-hwe is not installed.
amdgpu-pro-lib32 depends on amdgpu-pro (= 20.45-1164792) | amdgpu-pro-hwe (= 20.45-1164792); however:
Package amdgpu-pro is not configured yet.
Package amdgpu-pro-hwe is not installed.

dpkg: error processing package amdgpu-pro-lib32 (--configure):
dependency problems - leaving unconfigured
Setting up libglapi1-amdgpu-pro:amd64 (20.45-1164792) ...
No apport report written because MaxReports is reached already
Setting up libglapi1-amdgpu-pro:i386 (20.45-1164792) ...
Setting up libgl1-amdgpu-pro-dri:amd64 (20.45-1164792) ...
Setting up libgl1-amdgpu-pro-dri:i386 (20.45-1164792) ...
Setting up libgl1-amdgpu-pro-appprofiles (20.45-1164792) ...
Setting up libegl1-amdgpu-pro:amd64 (20.45-1164792) ...
Setting up libegl1-amdgpu-pro:i386 (20.45-1164792) ...
Setting up libegl1-amdgpu-mesa-drivers:amd64 (1:20.1.6-1164792) ...
Setting up libegl1-amdgpu-mesa-drivers:i386 (1:20.1.6-1164792) ...
Setting up libgles2-amdgpu-pro:amd64 (20.45-1164792) ...
Setting up libgles2-amdgpu-pro:i386 (20.45-1164792) ...
Setting up libgl1-amdgpu-pro-glx:amd64 (20.45-1164792) ...
Setting up libgl1-amdgpu-pro-glx:i386 (20.45-1164792) ...
Setting up opencl-rocr-amdgpu-pro:amd64 (20.45-1164792) ...
Setting up libgl1-amdgpu-pro-ext:amd64 (20.45-1164792) ...
Setting up amdgpu-lib (20.45-1164792) ...
Setting up amdgpu-lib32 (20.45-1164792) ...
Processing triggers for libc-bin (2.31-0ubuntu9.1) ...
Errors were encountered while processing:
amdgpu-dkms
amdgpu
amdgpu-pro-rocr-opencl
amdgpu-pro
amdgpu-pro-lib32
E: Sub-process /usr/bin/dpkg returned an error code (1)

1 Solution

Accepted Solutions
deepmindser
Adept I
Adept I

Re: Can't install amdgpu drivers on Ubuntu 20.04.1 (5.4.0-56-generic)

Jump to solution

well, i'm not baszczer, but still.

Thanks to baszczer, I've tryed to use 5.4.0-54 (the previous one) and it just works!

To install 5.4.0-54 do next:

sudo apt install linux-image-5.4.0-54-generic linux-headers-5.4.0-54-generic linux-modules-extra-5.4.0-54-generic

then reboot to 5.4.0-54

then

sudo apt remove linux-image-5.4.0-56-generic linux-image-unsigned-5.4.0-56-generic

(unsigned mentioned here because it tryed to install it for me by some reason.. it just helped)

then do

sudo apt autoremove

then go to /usr/src and remove linux-headers-5.4.0-56-generic and inux-headers-5.4.0-56 (if any of them are there)

now you can do

sudo ./amdgpu-install -y

View solution in original post

161 Replies
rick4665
Adept I
Adept I

Re: Can't install amdgpu drivers on Ubuntu 20.04.1 (5.4.0-56-generic)

Jump to solution

I have the same problem.  Amdgpu-pro driver ver 40 was working great.  Tried to upgrade to ver 45 and get that same error.  Tried reinstalling ver 40 now I get the same error with that driver as well.

SurlyJest
Adept I
Adept I

Re: Can't install amdgpu drivers on Ubuntu 20.04.1 (5.4.0-56-generic)

Jump to solution

I am getting a different error on Ubuntu 20.04  with kernel 5.4.0-56-generic:

ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/amdgpu-dkms.0.crash'
Error! Bad return status for module build on kernel: 5.4.0-56-generic (x86_64)
Consult /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/make.log for more information.
dpkg: error processing package amdgpu-dkms (--configure):
installed amdgpu-dkms package post-installation script subprocess returned error exit status 10
dpkg: dependency problems prevent configuration of amdgpu:
amdgpu depends on amdgpu-dkms (= 1:5.6.20.906300-1164792); however:
Package amdgpu-dkms is not configured yet.

dpkg: error processing package amdgpu (--configure):
dependency problems - leaving unconfigured
Setting up xserver-xorg-amdgpu-video-amdgpu (1:19.1.0-1164792) ...
No apport report written because the error message indicates its a followup error from a previous failure.
Setting up mesa-amdgpu-omx-drivers:amd64 (1:20.1.6-1164792) ...

It seems to me that this version is unusable in the current version of Ubuntu 20.04 (I just updated today to a newer kernel).  So, I can't use this until they fix this, unless I want to go fixing their code (and I'm not confident with that).

The make log file indicates several errors in compiling, possibly due to a compiler difference (mine is newer):
DKMS make.log for amdgpu-5.6.20.906300-1164792 for kernel 5.4.0-56-generic (x86_64)
Wed 02 Dec 2020 12:01:34 AM EST
make: Entering directory '/usr/src/linux-headers-5.4.0-56-generic'
/var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/Makefile:20: "Local GCC version 90303 does not match kernel compiler GCC version 90300"
/var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/Makefile:21: "This may cause unexpected and hard-to-isolate compiler-related issues"
AR /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/built-in.a
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/main.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/symbols.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_memory.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_ioctl.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/scheduler/sched_main.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/scheduler/sched_fence.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/ttm/ttm_memory.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/scheduler/sched_entity.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_device_cgroup.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/ttm/ttm_tt.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_drm_cache.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_drv.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/ttm/ttm_bo.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_device.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_drm.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_fence_array.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_fence.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_io.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_kthread.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_mm.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_pci.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/ttm/ttm_bo_util.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_perf_event.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/ttm/ttm_bo_vm.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_reservation.o
/var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_fence.c:30:1: warning: ‘dma_fence_test_signaled_any’ defined but not used [-Wunused-function]
30 | dma_fence_test_signaled_any(struct dma_fence **fences, uint32_t count,
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_kms.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_suspend.o
LD [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/scheduler/amd-sched.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_workqueue.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_seq_file.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_connector.o
/var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_pci.c: In function ‘amdkcl_pci_init’:
/var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_pci.c:103:84: warning: passing argument 2 of ‘amdkcl_fp_setup’ discards ‘const’ qualifier from pointer target type [-Wdiscarded-qualif
iers]
103 | _kcl_pcie_link_speed = (const unsigned char *) amdkcl_fp_setup("pcie_link_speed", _kcl_pcie_link_speed_stub);
| ^~~~~~~~~~~~~~~~~~~~~~~~~
In file included from /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_pci.c:4:
/var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_common.h:12:63: note: expected ‘void *’ but argument is of type ‘const unsigned char *’
12 | static inline void *amdkcl_fp_setup(const char *symbol, void *fp_stup)

CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_backlight.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_drm_atomic_helper.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_drm_crtc.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/ttm/ttm_module.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_drm_fb.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_drm_modeset_lock.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_drm_modes.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/kcl_mn.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/ttm/ttm_execbuf_util.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/ttm/ttm_page_alloc.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/dma-buf/dma-resv.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/ttm/ttm_bo_manager.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/ttm/ttm_agp_backend.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/ttm/ttm_page_alloc_dma.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_atombios.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/atombios_crtc.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_connectors.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/atom.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_fence.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_ttm.o
LD [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdkcl/amdkcl.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_object.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_gart.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_encoders.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_display.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_i2c.o
LD [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/ttm/amdttm.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_fb.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_gem.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_ring.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_cs.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_bios.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_benchmark.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_test.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/atombios_dp.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_afmt.o
/var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_fb.c: In function ‘amdgpufb_create’:
/var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_fb.c:252:14: warning: assignment discards ‘const’ qualifier from pointer target type [-Wdiscarded-qualifiers]
252 | info->fbops = &amdgpufb_ops;
| ^
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_trace_points.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/atombios_encoders.o
CC [M] /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_sa.o
/var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_bios.c: In function ‘amdgpu_read_platform_bios’:
/var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_bios.c:200:9: error: implicit declaration of function ‘pci_platform_rom’ [-Werror=implicit-function-declaration]
200 | bios = pci_platform_rom(adev->pdev, &size);
| ^~~~~~~~~~~~~~~~
/var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_bios.c:200:7: warning: assignment to ‘uint8_t *’ {aka ‘unsigned char *’} from ‘int’ makes pointer from integer without a cast [-Wint-conversion]

 

SurlyJest
Adept I
Adept I

Re: Can't install amdgpu drivers on Ubuntu 20.04.1 (5.4.0-56-generic)

Jump to solution

I may have exceeded a reply length - my message was truncated. The last bit of the make.log is:

cc1: some warnings being treated as errors
make[2]: *** [scripts/Makefile.build:275: /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu/amdgpu_bios.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [scripts/Makefile.build:522: /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build/amd/amdgpu] Error 2
make: *** [Makefile:1757: /var/lib/dkms/amdgpu/5.6.20.906300-1164792/build] Error 2
make: Leaving directory '/usr/src/linux-headers-5.4.0-56-generic'

So it is failing the build since it is set to treat these warnings as errors.

baszczer
Adept III
Adept III

Re: Can't install amdgpu drivers on Ubuntu 20.04.1 (5.4.0-56-generic)

Jump to solution

Temporary solution that worked for me is to remove 5.4.0-56 kernel and install drivers on 5.4.0-52.

taskforce131
Elite
Elite

Re: Can't install amdgpu drivers on Ubuntu 20.04.1 (5.4.0-56-generic)

Jump to solution

try this 

https://www.amd.com/en/support/kb/faq/gpu-601 

idk if it is will work on Ubuntu or not 

0 Kudos
henshu70
Journeyman III
Journeyman III

Re: Can't install amdgpu drivers on Ubuntu 20.04.1 (5.4.0-56-generic)

Jump to solution

I am running KDE Neon based on Kubuntu 20.04.1. I tried installing AMDGPU 20.20 (which was the only one working for me before), 20.30 and 20.40. Nothing helped. The only solution was to update the Linux Kernel to 5.8 (Linux Kernel 5.8 is Here. This is What’s New ). Now everything is working. I guess we will have to wait for second release of Ubuntu/Kubuntu/Neon 20.04 as that should be based on Linux Kernel 5.8.

0 Kudos
henshu70
Journeyman III
Journeyman III

Re: Can't install amdgpu drivers on Ubuntu 20.04.1 (5.4.0-56-generic)

Jump to solution

The link is not working.

0 Kudos
deepmindser
Adept I
Adept I

Re: Can't install amdgpu drivers on Ubuntu 20.04.1 (5.4.0-56-generic)

Jump to solution

I have the same problem. It started right after an update.

everton137
Journeyman III
Journeyman III

Re: Can't install amdgpu drivers on Ubuntu 20.04.1 (5.4.0-56-generic)

Jump to solution

It was working until recently. My HDMI monitor stopped to work, so I tried to uninstall and install amdgpu-pro-20.20-1089974-ubuntu-20.04 and I get the following error: https://pastebin.com/ik8CNSa6

The relevant part seems to be:

 

Building initial module for 5.4.0-56-generic
ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/amdgpu-dkms.0.crash'
Error! Bad return status for module build on kernel: 5.4.0-56-generic (x86_64)
Consult /var/lib/dkms/amdgpu/5.6.0.13-1089974/build/make.log for more information.
dpkg: error processing package amdgpu-dkms (--configure):
 installed amdgpu-dkms package post-installation script subprocess returned error exit status 10
dpkg: dependency problems prevent configuration of amdgpu:
 amdgpu depends on amdgpu-dkms (= 1:5.6.0.13-1089974); however:
  Package amdgpu-dkms is not configured yet.

dpkg: error processing package amdgpu (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Errors were encountered while processing:
 amdgpu-dkms
 amdgpu
E: Sub-process /usr/bin/dpkg returned an error code (1)

Here is the content of the file /var/lib/dkms/amdgpu/5.6.0.13-1089974/build/make.log  https://pastebin.com/JQ0QSz5C

I've also tried to purge and re-install the package amdgpu-dkms, which seems to be the source of the problem. It cannot not be installed.