Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Can't delete Custom Resolution in Radeon Settings Panel


I'm running Win 10 Pr0 1709 (16299.371) on an SSD

I'm using Radeon software 18.3.4

I'm on a desktop PC:

Asus Z87 Plus mobo

i7 4790

32 GB DDR3


XFX R9 390 DD

I'm connecting to a Sony 4K TV with a Club 3D DP 1.2 to HDMI 2.0 adapter. The adapter manufacturer recommends using a Custom resolution where you just change the Timing Standard to CVT-Reduced Blanking. I did that to run some tests, and this is it:

Screenshot Radeon Panel Custom rez 3840x2160_annotated_1300cr.png

Screenshot Radeon Panel Custom rez 3840x2160 Display page_1000cr.png

Now I want to delete the resolution, but it won't let me. When I click the little trash can delete on the "Display 1" custom rez it gives me this message:

Screenshot Radeon Panel Custom rez Delete Error Message_1000cr.png

Where it says "To delete this resolution, first go to the OS resolution page and change the resolution" I'm assuming it means the Win 10 > PC Settings > Display > Resolution.

So in Win 10 I changed the display resolution from 3840 x 2160 to 1920 x 1080.

When I set it to 1920x1080 Windows accepts that but now it displays that resolution with black box bars around it. So here's my crappy camera shot of the TV, and hopefully you can see Windows displaying within black bars on the TV:

Camera shot of Windows 10 PC settings_annotated.jpg

I rebooted and it stays that way. If I then go to the Radeon Panel and try to delete the Custom Resolution it gives me the same error messages, still saying: "The Custom Resolution is currently in use. To delete this resolution, first go to the OS resolution page and change the resolution".

So I'm stuck. How can I delete the Custom Resolution or switch back to the Radeon Panel auto detecting resolutions?


15 Replies

Do you have any third party graphics controllers like afterburner, trixx, asus installed on your computer?

Tried this ?


This didnt help i cant even load up my game because this isnt working i just want to know how to fix this please help

Journeyman III

can we get a solution to this? cant delete my custom setting either and havent come across anything,,,,, so BUMP!!!

Adept I

l didnt have this issue with lesser versions... l can change resolutions on W10 display settings but Raedon still not recognizing lve changed it. And l still getting "To delete this resolution, first go to the OS resolution page and change the resolution" also l dont want to try to restore defaults cause there is no option to save your current settings,for some reason l cant understand.

Which lcan do is to create the resolution l want,though if l check GPU scaling to On its automatically goes to the highest resolution supported


Hey, I had the same issue, and I figured out a way eventuality. You will have to uninstall your monitor, and once you do, reboot your pc. You’ll have everything removed and you can simply readd all your resolutions you had before, make sure you don’t make the same mistake the next time.. That’s a lesson i learned.

Journeyman III

Hi, I recently figured out a solution to this problem. Please note that doing these steps will reset all your graphics settings, but it's the only way to get rid of the stuck resolution bug. Take screenshots of your custom graphics settings before proceeding.

Step 1: Uninstall your AMD graphics driver (also known as AMD Software) from Uninstall or Remove a Problem on Windows.

Step 2: Install the AMD Cleanup Utility here: AMD Cleanup Utility | AMD 

note - Doing this will remove all AMD settings you set including the glitched custom resolution that you can't remove. If you don't do this step, your resolution settings will still be on your PC and when  you reinstall AMD, it will come back.

Step 3: The tool will ask you to restart your PC in safe mode, allow it to do so. Once in safe mode it should automatically start uninstalling AMD. Wait until it says it has successfully uninstall all AMD sources. It will then ask you to restart your PC again, click yes.

Step 4: Once you boot into normal Windows, you may notice that your resolution may change to something wacky, that's normal. Go to Windows Search> Change Display Settings> then apply a better resolution. If that doesn't work, simply move onto the next step. (this just makes it easier to see)

Step 5: Reinstall your AMD graphics driver on the AMD website by searching for your version online or using the auto detect drivers: Obtaining Graphics Drivers Using the AMD Driver Auto-Detect Tool | AMD 

Step 6: Once install, your graphics settings will all be completely reset and the custom resolution will be gone. If your graphics driver partially installed, follow this video here: Solution | Error:1603 Radeon Software Partially/Not Installed Error - YouTube 

Like this comment to bump up so others with the same problem can see! ~WootMoo

Journeyman III

The easiest way to fix this [without even rebooting]:

When you are stuck in a custom resolution, go to system settings>Display Settings> Advanced Display Settings > Display adapter properties for Display 1>List All Modes, from here select any mode other than current. Then go to display settings and change the resolution to any other than current.  voila!! now you can just simply delete the custom resolution from Radeon setting.

After that, you can go back to your desired resolution. 

when i go to List all Mode there's only one resolution ??


wow thanks man you really helped me a lot :))


Tysm man!! This worked for me I was stuck with black bars on the side of my screen for days!!

Journeyman III

hi, i had the same problem and i enabled "Virtual Super Resolution". the screen will flicker for a bit and then try to delete the custom res that you dont want and it works. the screen started working again. if that doesnt work, idk what to do next, it worked for me and i hope it works for you too

this actually works thank you very much ur a life saeva


bro where can i see this?


 First Press ALT+R (to open the radeon control panel)first go to settings (the nut icon near the top right of the screen) then  in the sub tabs go to

DISPLAY (the 3rd sub tab from the left) then just below  the FREESYNC option there would be a option to enable VIRTUAL SUPER RESOLUTION  enable it then wait a few seconds then go on your custom resolution then press the delete option it should delete then. then disable the VIRTUAL SUPER RESOLUTION and you are good to go. take a deep breath and promise you will never mess with the setting ever again.

If its not working  then idk accept the reality and move on ( btw i dont trust myself with reinstalling drivers) or just buy a  new hardrive and restart with a new fresh life.

 btw all credits go to



Had this same issue even in the newest 21.4.1 version; I was able to finally delete the custom resolution by changing mode from from the Display settings > Advanced display settings > Display adapter properties > List All Modes, as described by xoker01 on the first page.

Just changing display resolution the basic way didn't work. Factory-resetting AMD Software didn't work; the custom resolution persisted even though the reset. Turning Virtual super resolution on and off didn't work either.